Comodo firewall not running at startup [merged topic]


I recently did a fresh install of Windows 8.1 64-bit version on my computer, which used to run Windows 7 in the past. One of the first programs I installed was the Comodo firewall, which I downloaded here: Free Firewall | Best Comodo Firewall Software Download 2022. The installation went well and no errors occurred, after which the Comodo firewall asked me to restart my computer. After I restarted my computer, I noticed the firewall wasn’t running properly and no Comodo firewall icon was shown in the system tray. So I checked the task manager and noticed 2 processes were missing: cis.exe and CisTray.exe. After clicking on the Comodo firewall shortcut, which was located on my desktop, these processes appeared. No notifications (both firewall and defence+) appeared when I tried to install or update something like Ccleaner before I clicked on the shortcut. However, after the processes cis.exe and CisTray.exe were running, these notifications appeared like they should.

Please note:

  • My current Comodo firewall version is 7.0.55655.4142
  • I’m running Avast free antivirus and Malwarebytes anti-malware next to Comodo firewall
  • Comodo firewall was working just fine when I was running Windows 7, even with the programs listed above
  • 2 other Comodo Internet Security processes called cavwp.exe and cmdagent.exe were running since startup
  • Windows security center didn’t show any notifications and actually told me Comodo firewall was running before I clicked on the Comodo firewall shortcut
  • When I check Autoruns, the Comodo service isn’t listed at logon

Problem: Comodo Firewall doesn’t start at startup

What I tried so far:

  • Running the diagnostics program several times, which didn’t found any errors
  • Running the install file again and trying to reinstall Comodo firewall
  • Removing and reinstalling Comodo firewall by using add and remove programs found in Windows
  • Same as above but also running Ccleaner and removing any register entries found after I removed Comodo firewall
  • Running the install file with Avast antivirus and Malwarebytes disabled
  • Followed all steps found on this thread: Comodo Forum, which included running the Removal tool after removing Comodo firewall

I’d like to see if I can fix this problem, so any suggestions are welcome. :wink:

When you installed CFP were Avast and Malwarebytes running in the background?

When I installed it the first time, it there were running. At my last few attempts, they were not.

Yesterday, I tried uninstalling both Avast and Comodo, restarting in safe mode and running a removal tool for both programs. I also used Ccleaner to clean the registery and remove any junk on my system. Then I restarted my computer and made sure no Malwarebytes processes were running when I tried installing Comodo firewall. After it was installed I restarted my computer and had the same problem as before; Comodo firewall is not running. Also, no Comodo processes were listed down at Autorun’s logon tab.

I tried moving the Comodo firewall icon to the startup folder and restarted to my computer to see if this works. Sadly, it didn’t so I visited the startup folder again and noticed the icon was gone. I added the icon again, this time with 2 other icons: 1 to a text file and 1 to an exe file. I restarted my computer to see if they got all removed from the startup folder. After the restart I noticed only Comodo firewall’s icon was removed.

I’m out of ideas on what to do and looking for answers online didn’t help either. :frowning:

Hi Jordy K,

Could you please clear your event logs, restart your computer system and post your newly created logs here?


All logs except the configuration and defence+ logs are empty. I attached the logs to this post.

[attachment deleted by admin]

Any news about this topic? I face exactly the same problem and it’s weird, because I remember to have it working fine before. And now I don’t remember exactly which version was the one that was working.

Windows 8.1 Update 1 x64 here.

The installer probably did not add some registry entries.
Please create a restore point and run the removal tool in Safe Mode.

After that, please install using these installers:

I’m running 64-bit OS here. Should I install x86 as well?

Anyway, I did what you mentioned, restarted in safe mode, cleanup and then in normal mode installed what you suggested there. Same thing happens, no icon for CIS/CPF at startup, if I start it manually it works.

The thing is this has happened to me before in Windows 8 with some other apps. And to be more precise, the troubling app was Corsair Link software, that until latest versión did pretty much the same (not loading icon, but working fine if started manually). BUT the funny thing is that now, with CIS installed, not only the CIS icon dissapears, but the Corsair Link software too! If I uninstall Comodo, Corsair Link software gets loaded at startup as it should. Maybe those problems are related?

I don’t know what to do because, as far as I love Comodo, I also need the Corsair Link software to check my fans and pump.

Thanks for your answer.

P.S. : from the installer that has been attached to the last post I only install firewall component.


Did you check Defense+ logs?
Besides the problem you mention, did you experience any other issue?

Thank you.

I installed a different firewall on my pc because I didn’t manage to make Comodo firewall start at startup. This firewall is running great so far and I didn’t experience the problem I had with Comodo firewall. I guess I’ll stick to it for now.

Thanks for you help all, greatly appreciated! I’ll keep following this topic to see if it gets solved. :wink:

I, too, am experiencing the same issue. Upgraded from win 7 by doing a clean install of win 8 and then updated it to 8.1 online. I have Norton Security Suite, Malwarebytes and attempted to install Comodo firewall. Comodo icon is not showing up. However when I click it, the icon will appear on the taskbar, but am not sure if it is working properly. I already did the safe mode, removal steps, still exhibiting the same behavior. I don’t have Corsair.

Thanks for any assistance!

Did you uninstall Norton Security Suite? I assume NSS is a firewall with AV solution.

I did not uninstall Norton because I have another machine with Win XP, running a similar setup (Norton Security Suite, Malwarebytes, and Comodo Firewall). I only have one firewall, Comodo. I disabled the firewall in Norton as well as Windows firewall. That set up has been running very well with no Comodo issues.

Another laptop still has Win 7 (64-bit) with the same setup - Norton (Norton firewall disabled), Malwarebytes, and Comodo Firewall. Windows firewall is also disabled. Similar with the XP machine, I have had no issues with Comodo firewall.

But with Win 8.1 (64-bit), I am not sure how Comodo Firewall is responding. So what I am doing now is running the Win 8.1 with the Norton Firewall enabled and Comodo uninstalled until this gets resolved. I really prefer Comodo firewall, though.

I appreciate the effort and hopefully I’ll be able to run it also on my Win 8.1.

Please try this (temporary) fix. Check attachment.

  1. Make sure you have installed CIS.
  2. Restart your computer system.
  3. Check results.

Thank you.

[attachment deleted by admin]

I don’t use Defense+ in my case, I disable all related to it. I only use the firewall and its rules.

I don’t have any more problems than I described with Corsair link 2.7 AFAIK.

I’ll try the attachment that has been suggested in the last post. I will report my results.

Ty al for ur help :slight_smile:

With the Norton firewall disabled the Norton firewall drivers and service are still loaded and could interfere.

I tried the cistray fix1 recommended and it added the cistray.exe to the registry. I rebooted and voila!, the icon is back. I would think this would have been added automatically to the registry during the initial install.

Anyways, thanks so much for the assistance and I’ll see how it behaves. So far, it has been prompting me when something wants to go online just like it used to.

Thanks again!

Keep me updated.


I would appreciate if anyone that is experiencing this issue on a different Windows OS (other than Windows 8.1) could reply in this topic.

Thanks again.