Comodo Firewall is Periodically Blocking Web Traffic

I’m running Comodo Firewall on Win 10.

In the last month or two, I’ve started experiencing intermittent issues where every 1-3 days, I find that I lose all access to web traffic. Meaning that I can’t reach anything by browser, but I can still ping external servers. Rebooting always fixes it.

I finally figured out that this is being caused by Comodo, because if I turn the firewall off, my web traffic returns - but when I turn the firewall back on, the web traffic stops again.

I also noticed that this is far more likely to happen if I have internet traffic for an extended period of time (e.g. multiple hour web meeting, streaming, etc…).

So I have two questions:

  1. Why is this happening and how can I fix it permanently?

  2. Is there a more convenient workaround than rebooting my machine? What is the proper way to completely restart CIS?

1 Like

It sounds like a problem with DNS. Can you see what happens when you flush the DNS cache.

When that does not fix it could you check the Firewall logs of around the time and post a screenshot?

Also do you have specific rules in place that address DNS?

1 Like

So when it last happened, I flushed the DNS cache, but that didn’t do anything. One or two sites I was still able to reach, most everything else I couldn’t. But I could still ping out.

I don’t have any rules regarding DNS specifically.

And although I looked at the firewall log, I didn’t see anything that I wouldn’t normally expect to see (sorry, but I’m not comfortable posting it).

I’ve used Comodo Firewall for years and I’ve never had this happen before, so this is very odd.

Do you have your computer switched on for multiple days? Do you have other security program(s) that run in the background alongside CIS? Do you run Comodo Firewall or do you run the suite?

When you run a ping do you ping a url or an IP address? I assume pinging an IP address works. Is that correct? What happens when you ping a url? Does the url get resolved?

What happens when you switch the network adapter off and on?

Logs may be of help. Please consider to post them. You can blur all external IP addresses. I want to see what is happening at which ports and if it logs blocking.

I sometimes have my computer on for multiple days, but very often, that’s not the case. That’s especially true ever since this issue started happening, because lately, it’s been happening every day - forcing me to reboot every time.

Within Comodo, I only use the firewall. As for other apps, I use ESET for AV purposes (its firewall is disabled, although network attack protection and botnet protection is enabled). However, I’ve used ESET in conjunction with Comodo for years without any problems.

As for pinging, actually, I do ping by URL. In fact, I can successfully ping a website that will NOT come up on a browser, oddly enough.

I’m not sure what you mean by switching the network adapter off and on, however. Can you clarify this?

And to go back to one of my initial questions - until we figure out how to actually solve this problem, is there a way I can at least fully restart Comodo without having to reboot the entire computer?

That is truly odd indeed.

There is always a slight chance that things break each time one of the two gets updated. Hence why I am asking to temporarily uninstall ESET and reboot your PC to see whether that plays a role. That will truly help us further.

This can be done in Network and Sharing Settings. When you click on the affected Network Adapter the Status window will open. One of the options it provides is to switch the network adapter off and on.

If what I wrote in the above does not work there is another thing to try.

Again with the Status window open in Network and Sharing Settings open Properties and disable Comodo Internet Security Firewall Driver. Click OK to close the Properties pane.

Now see what happens and then enable the Comodo Internet Security Firewall Driver again.

Well, I can confirm that turning the affected network adapter off and on does NOT help.

Also, disabling and re-enabling the comodo driver in the Properties setting for the network adapter also does not help.

Doing that does not have the effect of fully restarting Comodo because there are still background services running, etc… So I still don’t have a way to fully restart Comodo without actually rebooting the machine itself.

At some point, I will have the time to try reinstalling Comodo as well as to temporarily uninstall ESET - but I can’t do those things on a whim, so they are not as easy to test.

You can do this at your own pace and we will pick up the conversation at any given time.

1 Like

Do you use LAN or WLAN? I had the same problem for a long time (LAN connection, Windows 10, cis 8012). I changed DNS, used Microsoft’s “problem finder” - nothing helped. I got a Fritz! stick (AV 430 MU-MIMO) as a WLAN connector and the problem was/is solved. Finding the error is quite difficult, I hadn’t managed to do it. Controlling DNS, HOSTS, comodo’s Proxy-and Hosts-Setting, Ethernet-Adapter-Setting a.s.o. - no success. The PC kept losing the I-Net connection.
With BETA 3 and now Windows 11, LAN no more problems by now.

That’s promising to know, thank you.

Out of curiosity, did you ever try to uninstall/reinstall Comodo with your original LAN?

I bought a new PC and only use LAN. I use the stick with the older PC (still Windows 10 and cis 8012 there) and no longer have any problems with the internet connection. Stick isn’t expensive - I think it’s worth trying.

I never ever had this issue when I used V12.2.2.8012. LAN connection was always rock solid.

The following might resolve your issue :
Import a new clean default configuration (located in your CIS default installation directory) and activate the imported configuration.
Check if that resolves your LAN issue.

It’s worthwhile to try this.

1 Like

I did that too, it didn’t help. Only when I uploaded an older backup (deleting the partition beforehand, i.e. only the contents) did I have success. But not with all backups either. It was faster than the endless search for the error. Didn’t actually want the WiFi connection. But I don’t notice any slower speed. But I haven’t carried out any major downloads etc. yet.
I restarted the router, resettet it etc. pp. WiFi helped! I wonder why! Forgotten: I have a new router (Fritz! 7030 XC). But I wonder, why I have with a WLAN-stick a stabile connection? With the new PC I have it with the same cable. My provider is the same.
It must be somewhere in the depths of the settings - did everything humanly possible. But why then solved with this stick? Or with the new router? I can no longer remember whether it was a stick + first router.

Well, I tried fully uninstalling and reinstalling Comodo. That did not help. But we know that it wasn’t due to a corrupt installation. So something else is causing a problem.

It’s pretty bad now - any non-momentary traffic triggers this issue (i.e. 10 minute youtube video or 5 minute VPN use). Oddly enough, any traffic that has been ongoing is usually able to continue. For example, if I stream a 2 hour youtube video, then maybe 10 minutes in, I won’t be able to browse most sites, but the video continues to stream just fine.

Is there any chance that some Windows update caused an incompatibility with Comodo?

I also noticed that Windows Defender Firewall is enabled. Should that be the case? And would it cause this issue?

Then - your problem is another problem than I’ve had.
In Internet I didn’t find any solution for my problem. But I looked for your’s perhaps you may find help there:

That does look eerily like what I’m experiencing. The key point with me, however, is that if this were solely a Windows problem, then I wouldn’t think that disabling Comodo’s Firewall would have any effect.

However, as soon as I disable Comodo, I have full internet access again. So it’s hard not to think that Comodo is still a key part of this. Although I’m open to alternative ideas.

I would say then there is not enough information. I also just had a similar problem. I Changed the configuration according to cruelsister’s instructions, no longer had an I-Net connection… I changed the configuration (e.g. that’s what @cisfan said), the connection was available again.
Ev. someone who is familiar with IT technology can get to the bottom of the problem by asking specific questions. You can’t possibly set everything here that could be the cause:
DNS changes or settings? Adapter settings? Proxy and host settings or entries, etc.

Well, I just tried the trick of importing the default configuration. At first glance, it looked like it worked. However, as I experimented with it further to see what changes were relevant, I realized that the effects were temporary.

Importing a new configuration kind of just rolls the dice again giving me some access for an indeterminate amount of time, but eventually, the same problem occurs.

And disabling Comodo’s firewall still restores connectivity.

It seems that a solution isn’t very easy:

Look under “Common Tasks/Unlock Applications” or under “File Rating/File List”.
In my case, I noticed or took screenshots of all the settings when I had an internet connection, but I still couldn’t solve the problem. Maybe you can tell the difference between being connected and not being connected.
Otherwise I have no more idea.

What I didn’t try is a winsock reset (Netsh Winsock Reset). I didn’t think of that. By the way, I had no internet connection at all.