Comodo Firewall Bug: Popup Steals Focus[M2210]

I noticed a bug in the latest version of Comodo Firewall ( Whenever a popup alert appears it steals the window focus so if you were just typing an email in your web browser, your keystrokes automatically start applying to the Comodo popup alert. In previous versions the popup alert did not steal the user’s focus away from the active window.

System information:
Windows 10 x64 (up to date as of 4/7/2017)

Not a bug.

Then Comodo should make this a preference setting. Always stealing focus is an undesirable behavior for any application.

which version? are you sure? thanks.

I ran a test on my laptop which is using and you are correct, the application also steals focus.

The other day, when I wrote my “bug” post, Comodo Firewall 10 stole focus and also appeared to accept a rule automatically by a few keystrokes.

I ran another test this morning by removing some known rules on Firewall 10 and resumed work as normal. The popup came up as expected but this time it did not automatically set a rule despite pressing many keys on my keyboard. However, I do see that the popup window responds to tab and the enter key! I can therefore speculate that as I happened to be working on code at the time I experienced the “bug” I probably was in the middle of hitting several tabs and enter which automatically selected a rule for me.

I can definitely understand the need for being able to select rules using tab/enter (for users without access to a mouse) so I’ll chalk this one up to just bad timing on my part. Thanks so much for responding and prompting me to run additional tests.

I’m not sure if not stealing focus is a good idea. It’s debatable. I see your point.
Not allowing keyboard input is probably a bad idea. Just to clear this one out.
I proposed that alerts should be defaulted to last answer or/and negative answer since you can answer with keyboard key by mistake. What do you think?

I think the ideal solution would be to have the alert not steal focus but instead be marked as “always on top”. That change combined with the auditory alert should be adequate notification for the user and also prevent accidental alert box submission. This could also be made a user setting so the user could decide whether they want the focus steal or just the “always on top” solution.

That’s a very nice idea: ontop window without activating. Hmm.

// bug 2210

Please, NEVER EVER put the focus at the default button for restart!



Already discussed here:

Sorry, I’m mad, because I lost almost half hour of coding. :cry:

I understand your frustration. Submitted some suggestions but it’s up to them. :slight_smile:

Just happened to me as well.
Was typing some text and a restart popup appeared.
As I was finishing typing a word (and didn’t notice/react the popup yet, it’s been on-screen for less than a second), I hit space and boom. Instant restart!

Just happened to me as well.
When stealing Focus the Window should at least ignore inputs for a few seconds (but not stealing focus would be even better).

Has cis become a beta to try unstable features?

Andreww, I fail to see your point.

This issue, coupled with Firewall and HIPS alerts stealing focus from each other have existed for as long as I can remember. Numerous times have I accidentally allowed or denied a request because the alert appeared and stole focus while I was typing, or because I was trying to allow an HIPS request just as a Firewall request stole focus from it and I ended up allowing the Firewall request even though I wanted to deny it. Any change in this behavior would certainly be appreciated.

On two occasions this has caused unwanted restarts and cost me work, time and money. Not to mention unnecessary stress. There I am merrily typing away and just as I hit return the popup alert sounds and bam! Instant restart. It almost feels like Comodo is lurking waiting for me to hit return so it can snatch the key stroke.

So far I estimate it’s cost me £40.

Who do I bill?

Hello Comodo Community.
I’ve had the Antivirus update today, like usual the popup just appears on the screen and tells me to update, I’d really prefer if this was always done on system startup to prevent it getting into the way of other activites, I asked last time and the only options were to disable updates or always toggle silent mode, both no real options for me(and I am certain that I’m not the only user).
After that, Comodo asked me for a Reboot, since I was currently working on something I wanted to do this, so remind me 4 hours later.
4 hours later, I was writing something, just about to hit space as the popup appeared, I only heard the sound as my entire Desktop shut down.

Having popups is one thing, but focus stealing popups which pretty much “automatically” do stuff due to the user currently inputting text into another window and causing loss of data isn’t only infuriating but also a bad design in my view.

Can Comodo’s Popups in general just appear in the background and not steal focus? I don’t see any issue with that and them playing a sound.

Hi r543,

Sorry for the trouble caused. We already have a wish submitted regarding this.

Thanks for understanding.

Kind Regards,