Comodo Dragon ver 28.1 is now available for download

Comodo Dragon 28.1 is now available for download from the following link:


  • Dragon is based on Chromium 28.0.1500.95.
  • Dragon includes updated COMODO CertSentry 1.11.


  • Update notification icon is not present in the “About” tab when manual
    updates are enabled

Hi sergey,

Thanks for the update

I notice something a bit strange.
When I browse to with this version dragon wishes to make a DNS query to google’s dns with the query ??
Any clue where that comes from??

Anyone else having this?

Very timely software updates! Unfortunately, my download speed is very slow, only 50K. :frowning:

Thank you, fixed my issue with twitch (intentional or not) ;D

:■■■■ Thanks for the update

Just updated and everything is working fine.

I checked and didn’t encounter this behavior. Isn’t this query just made because your configured DNS servers were not responding? Maybe a DNS flushing and ipconfig release and renew could help?

Thanks for the update, but why so slow?! :embarassed:

After the update to 28.1 today the dragonupdate.exe was still using High CPU. I could not end it so i had to restart the computer to end the exe. W7 SP1 Ivy Bridge I-7 Dell.

High-Quality, High-Stability

Maintenance Comodo Dragon is perfect

Thank you very much updated

:love: (:LOV) (:CLP)

Hi ujku1977,
Slow to update or slow to use?

Thanks for the update Comodo. :-TU

Hi captainsticks,

It was about the updating speed. First I tried form CD, it was impossible, it stuck in 35%. Then I tried form the link above. Max. download speed was ~ 28kB/s!

Anyway, in the end, CD was successfully updated and works fine. :wink:

I had the same thing, and have been having it pretty much every time CD has just been updated, I think they have a high load during the initial wave/start of the updates, seeing as it downloads rather fast right now.

Yes this is true. I just updated CD on my laptop and it ended quickly.

Hi ujku1977, good to hear it was eventually successful.
I think SanyaIV hit the nail on the head, especially in specific locations. :-TU

Great job this one. Working smooth so far.

Comodo Dragon is crashing almost constantly since last update. I use two instances open at the same time: one for normal browsing, and other for Facebook.

If I use only one, it doesn’t crash. If I open the second, it crashes RANDOMLY. I tried disabling the extensions.
I’m using the portable version. I use two profiles in different folders, let’s called them “MAIN” and “SECONDARY”.
I launch the main one with a shortcut with --profile command, and the second directly from the “session” or “user” selector.

I can’t stress how annoying it is to lose data and having to restart the browser 50 times a day.

Anyone else having problems with this version not opening in sandbox? I try to run CD via the widget sandboxed, i see 4 applications running in sandbox, one being CD, but CD itself does not open… I also tried just opening CD normal then switching to virtual mode via the Customize and control button, with same experience, CD will close, i will see the 4 applications in sandbox, but CD does not open back up… I tested IE with the widget, and it opened just fine sandboxed?

Known Issue

need answers to solve the crash, please

Thank you for quick reply… It seems im not alone with this issue… I was just confused for a minute, as mine was placed on a clean system, just freshly reset to factory settings…