Comodo Dragon ver 28.0 is now available for download

Comodo Dragon 28.0 is now available for download from the following link:


  • Dragon is based on Chromium 28.0.1500.72.


  • Dragon didn’t use TLS 1.1.
  • “Scan and navigate” command in “Comodo Web Inspector” extension stopped working.

:■■■■ update went smoot & quick .Thanks

Downloading for testing purposes now.


Thanks for the update. :-TU

It’s working normally it seems like, no websites that randomly stops working and no downloads that doesn’t complete! :-TU

many thanks

Thanks :-TU

Update is downloading & by mistake you close CD, it should mention update is downloading, do you want to exit, currently it doesn’t informs.

Downloading second time as first time I forgot it was downloading & closed CD.

Something weird going on here…

CD wont work in normal mode for me. In normal mode it just tries 2 load up the webpage and it just say ‘loading’. Doesn’t matter what website i try. But in Virtual mode so does it work just fine.

Any suggestions?

Just heard from a friend… she have the same problem also.

Okay never mind me saying it worked normally, when watching streams on it often gets stuck on “Loading channel data…”

Hi Barough,
Maybe a previously installed extension is conflicting with the updated Dragon version.
Try disabling any third party extensions.

I can’t even access the Extension page. :frowning:

Can you get to it by typing dragon://extensions/ into the address bar and enter?

Also try clearing your browsing data. Ctrl+Shift+Del

Can’t access anything in normal mode.

Just did a ‘clean’ install of it and that didn’t help either. :frowning:

Thanks. :-TU

there is something thats help .

Comodo Program Manager use it to uninstal CD. But wait till CPM shows you all the registry to uninstal.
Afer that restart PC & download CD again & CPM will follow the download informing of any mistake .

Wait for popup from CPM .

Having CPM on board CD is downloading on my PC even I did not switch CD on.

Im switching PC on & CPM popup inform me - CD finished to download succesfull.

Edited link – JoWa

…working best here in a while - waaaaaaayyyyyyyy snappier opening, rendering, & closing - got it back behind EMET (4.0 ‘new’) /w/ no probs - thanx Comodo team - great job…

Why am I getting “wow_helper.exe” error when I try to download CD? Cannot download it at all. I had a much older version that I haven’t used in a long time and decided to go back to using dragon but can’t upgrade because of this error. Even tried uninstalling the old version and nothing happened.

Didn’t have any other option than downgrade to v27. Couldn’t get v28 to work in normal mode no matter what i did.