Comodo Dragon ver 28.0 is now available for download

Hi Barough,
Sorry nothing has worked to solve this issue.
The only other thing I can think of is a maybe a corrupt user profile, but I am not sure what is happening sorry.
You could try the portable version, this would eliminate any Dragon user profile issues.

If it turns out to be a user profile issue, you can create a new user profile, remembering bookmarks, extensions, settings etc do not roll automatically roll over into the new profile.
To create a new user profile in Comodo Dragon

Older versions can be found in the link below.
Dragon FileHippo

Hi captainsticks

I’ve tested with a new user profile also and that didn’t help either.

I know of 4 other persons that have the exact same problem as me with v28.

Hi Barough,
If you have the time can you please create a bug report, in the hope Developers can reproduce this issue.
Bug Reports
Bug Report Guidelines

Your time is appreciated, thank you.

Edit: I am presuming the update and re-install was done in a non virtual environment?

Is the blink engine included in this release?

Yes, Blink is used in Chromium 28+. Go to dragon://version to confirm.

Hi Barough,
I’ve had the same problem, nothing worked with CD, uninstall and install and nothing. I had to uninstall it completely. I installed Google Chrome to check and the same problem. It seems to be something in this version of Chrome that is not compatible with my Desktop Pc. Update on a laptop also with Windows 7 64bits and there it works fine.
We will have to wait for another version to see if that solves the problem. Perhaps it is incompatible with some program. I have Avast and EMET installed.

I can’t open 90% of pages (yt, google+). It just won’t load.
2 different pc (on second new installation of CD all default settings, no additional extension from default installation) same thing. Connected to my home pc (different isp) same thing (although here [at] work im not filtered by isp as it is dedicated link and i’m sys admin).
Just to mention that today before update everything worked just fine so it’s the update to 28 that made this !

ff,ie works fine

Just made a bug report.

No virtual environment used.

One of my frends have a similar problem with CID after downloading some updats for Kodak printer .

Whats happened , was a conflict & CID was send to untrasted file in the CIS setting its worked only i wirtual box.

Have uninstaled the update & after that .

set up CIS .

go to advanced tasks , go to security setting , go to trusted file , choose Comodo , klick right on and ad to trusted .
Check as well unrecognised file , maybe CD is there as well.
Check as well trusted wendors.

On the end reset sandbox .

Thats is a well know AVAST & AVG problem , just tape in google to check.

In that keys switch off AVAST or AVG & install chrome or Comodo Dragon , you will be fine .

But still you can have some problems with opening some websites.

Here a example from CNET about that How To - CNET

There is nothing wrong with Chromium or Chrome , at the time best browser as we know & propably the reason CD is based on Chromium.

CD will not run fully virtualised on my Windows 8 Pro 64-bit system. The task starts but the browser window does not open. This happens whether I use the Switch To Virtual Mode menu item, the desktop icon or when I start Virtual Kiosk and run CD in there.

It’s always repeatable, I’ve tried uninstalling CD 27 and installing CD 28 from scratch, it’s always the same. CIS v6 is up to date as is Windows 8.

Edit: I just tried an uninstall and reinstall of CIS and the problem still remains. I’ll post a bug report.

Later edit: I’ve also tried a complete reinstall of Windows 8, all drivers, all updates, CIS 6.2 and CD 28 and it still won’t start in virtual mode. Bug report filed.

I do not think it’s a problem with avast, use Comodo Dragon for some time and there were no problems before, just after the upgrade to version 28.

I checked my other computer that my brothers and sisters use to surf the web.
Apparently, someone cancelled the update.
When I click About, I get the message about the update cancelled and I would like to know how we can get the update to start.

Just updated a minute ago. Everything seems fine.

Same prob on Win 7 64 here.

No probs on XP i.e even after update is skipped, about screen shows new version available.

Same prob on Win 8 64 here. ???

Either my brothers, my sisters, or their friends stopped the update manually, I want to know how to make it install the update again.
If I have to go and download the client again, I will uninstall Dragon and use something else.

Download and run the setup file.
Choose Upgrade.

Unfortunately,I had to go back to CD 27.2. I had a few instances that did not work for me so I did a rollback. Unfortunately again, 27.2 does not fully agree with my Dragon NaturallySpeaking. But I will survive! :slight_smile:

downloading comodo dragon 28 will notify my experience latter.