Comodo Dragon ver 16.0 is now available for download

Comodo Dragon 16.0 is now available for download from the following link:


  • Chromium core 16.0.912.59.


  • Fixed compatibility with Comodo Backup that prevented Dragon from opening.
  • Information was missing on the download bar.
  • Comodo logo was not transparent on a new tab page.
  • Proxy information was deleted when deselecting “Use this proxy server”.

Congratulations on the first stable release before Chrome!!! :-TU

Well Done :slight_smile:

And I must say my theme looks much better with the logo transparent

Updated smoothly, well done and thanks :-TU.

excellent work guys!

our releases are now much faster :wink:

Thank you for the update.

Thank you for the last bug fix!

Couple of problems with the installer …

My previous default browser was Dragon 15

Checked all boxes to import default browser options (passwords etc)

Mostly that went okay …

FavIcons for bookmarks - All replaced with the default bookmark icon - They start updating again when you revisit the sites bookmarked so no biggie, just a bit of installer polish required.

And even though Dragon 15 was my previous default - I now have a new folder for bookmarks on the bookmarks bar titled “Imported from IE”

So thanks for the extra bunch of microsoft bookmarks … deleted them afterwards.

Also “Keep my Search engines” - It did, I only had one; Startpage - Private Search Engine. No Tracking. No Search History.
… but now I also had Bing, Google etc again … deleted them afterwards.

On dragon://flags/ page …

Disable WebGL.

Does clicking the ‘Enable’ toggle, enable disabling of WebGL, or does it enable WebGL ? (confusing) - Personally I want to disable WebGL, but looking at its default state if I click it its not clear to me that it will do what I want it to, or it is aleady doing what I want it to.

Hi w33d3r,
When updating an already installed Dragon you don’t need to tick anything to import as it is already stored in your profile which will continue to be used.

WebGL (Disable WebGL), I agree it does sound confusing when you actually need to enable the disable function.
Enable toggle function, enables the disabled function, which can be confirmed at dragon://gpu-internals/
Hope that helps.

my wish fulfilled for Comodo Dragon’s transparent logo.

Congrats to ALL COMODO DRAGON TEAM for this new stable release. :-TU :-TU :-TU

im glad you got the download bar fixed and made it look like it dose when you download a file in google chrome with the updated icon’s you have added to it and how it looks all nice and clean it kinda looks like advanced updated version of google chrome with better security , And i thank-you for all of your hard work for fixing it

^^ that image explains what i am talking about

I’m having a strange issue that if I load a webpage who uses a ‘secure’ tracker I now get a SSL warning for that tracker while the main page is not in SSL.
This behavior wasn’t there in v15.0 is this intentional behavior?

same here, for instance with Twitter,

EDIT: I found that what is connected with social sites, that gets a SSL warning

yeah i m also having same problem and even if i click proceed anyway, page doesn’t load… and i made it worked by unticking warn if low validation ssl option…after that page loads smoothly…

Had to take the same action to make the browser ‘usable’ :cry:

I have downloaded the new version. I live in Holland and I use as search engine. Before if I used the header as search I got information from but now it is from
Can I change that so that I search in

Hoi everth,

Welcome to the forums!
Did you select Secure DNS to be used for Dragon?
I’m dutch also and if I go to I don’t have the issue, so it might be caused by Secure DNS ip’s being used in the UK.

You can try to ‘disable’ this setting in Options, Under the hood, Enable malware domain filtering and uncheck that option, restart dragon and see if that helps.


Hi Ronny,

Thank you for your reply. I have the comodo dragon dutch version. I went to the options screen, advanced options and there the Enable malware domain filtering was already unchecked. I checked this and logged out. Started it up again and went again to options and unchecked the Enable malware domain filtering. Started up again but still when I do a search in the header it automatically searches from

would it be better to go the “older” version?

I have the problem even with this:

tried to read about this continuous issue, and got the same SSL warning

Can you check, Options, Basics, Search, Manage Search Engines, see if it states there?