Comodo Dragon v65.0.3325.147 is now available for download

Hello, everyone!

We are very pleased to announce the release of Comodo Dragon version 65.0.3325.147.


  • Updated the codebase with Chromium 65 for 32-bit and 64-bit
  • Added the Comodo Online Security extension
  • Removed the WebInspector extension

Comodo Dragon v65.0.3325.147 64-bit can be downloaded from:

md5: DE5A9A6C343DE3974894096103E22611
sha1: 622EF083AA1FACF74373939A2D993D431DC8FB82
sha256: 9A65FE760C12E19B2E7ABB884075802B0DD7567C3DA1661F95337C43CB1933A8

Comodo Dragon v65.0.3325.146 32-bit can be downloaded from:

md5: BA4B27935450EA5CE4DCC8FFBCF61DFD
sha1: 3F3428A025B1EDCEFC83B9FCC2B878CD74417B12
sha256: 31CE8CF17B0CB99969D1152DC3F94C61A3D5A6662B7AF6C1C10504C2468DC647

Note: After install the Dragon v65.0.3325.146 32-bit only it will auto update to Dragon v65.0.3325.147 32-bit due to a required update path. Existing installs will auto auto update to v65.0.3325.146 and then v65.0.3325.147

Thank you very much,

The Comodo Browsers team

Mod edit changed to https link. FT

Links are “404 Not Found”

If i want to install dragon 64 bit now, do i have to uninstall dragon 32 bit first.


Why download links are “http” ? and Why Comodo does not release “https” download links?

I still have x32 version installed
Now I have set yahoo as main page and I’ve select that I don’t want to have it on installation
And on youtube it doesn’t load all the video thumbnails and I cannot click them

I have edited the post to point to the https version.

Thanks futuretech :-TU

Andrei Hreapca answered my first post but he seems deleted his asnwer. He told me use “http” instead of “https”. I am using HTTPS Everywhere extension by the way. Why do I have to use http?
Anyway, thank you for your edit on the links. They are working now on my end :-TU

When I don’t want to use the program updater but use the installer. Can I install build 147 using the installer on top of v63.0.3239.108 or do I first need to install 146.

Either the windows update or the new version of Comodo are causing all Google based sites to crash. Sad face.


I just want to report a bug for the latest release of Comodo Dragon web browser version 65.0.3325.147 (32-bit). It’s possibly not a bug that concerns most people however it’s a bug that annoys someone like myself as there doesn’t appear to be any way to stop it from doing what it is doing?

Comodo Dragon is configured with my personal settings, these settings are different from the default settings. Some of these settings include changes to the default page, homepage and new tab settings. When I launch the Comodo Dragon browser it honours the requested settings i.e. My home page is set to Google Search (not Yahoo). On all previous releases of Comodo Dragon if I were to launch an additional browser instance, normally a blank Comodo Dragon Browser would appear, instead when I launch the second instance the Browser ignores my preferences and automatically delivers me to Yahoo news main page.

This is rather annoying as I then need to create a new tab on that session before I can close the Yahoo News tab.

This only occurs when there is already at least one instance of Comodo open and running. This doesn’t occur when you cold launch the primary browser instance ONLY when launching a secondary instance? I cannot see anywhere where there is a setting to remove Yahoo web page?

I can cleared my preferences and settings to default and configured Comodo again, yet it still launches Yahoo (a web site that I never use). Please do your best to rectify this small but annoying issue, as I and possibly a large portion of your other Comodo users, use short cut keys to Alt + Tab between multiple browser instances.

The correct configuration should always launch a new session/instance of Comodo and the new instance is always a blank page not

Thank you

@Jarmezrocks. I have merged your topic with the release topic.

Lags and crashes on different sites, including Turning off extensions didn’t help. Tried x32 and x64. This version is completely unusable for me. Where can I download a previous one?

I have that same problem. Please do your best to rectify this small but annoying issue.

This is really bad. Can’t make any changes in the settings, nothing sticks. Can’t install the 64 bit version it only upgrades the 32 bit version. Tried installing it as a portable on another drive and importing nothing but it still won’t let me make any changes. I don’t want Yahoo, EVER! I want a blank tab, nothing I do will make that the start page in Incognito. The browser even says dragonsetup.exe is a dangerous file and shouldn’t be downloaded. I tried to turn off protection and though the slide button is off protection is still on. The keep and discard boxes are black as are the download box so if I didn’t know what they were I would be in trouble. Can’t even roll it back because it is updating even when I unplug the network cable. Dragon is now useless.

i have same issues with him. I just submit the issues here

Try enabling hardware acceleration. No idea why, but it stopped the page crashing for me.

Thanks, its solved.

Has anybody installed dragon 64 yet and how is it working.

Yes - works fine for me. . . . I don’t use it much and it’s not my default, but I haven’t found any problems with it on any site I’ve checked and not a trace of Yahoo - Win10 Pro 64 1803 (17134.48)