COMODO Backup 4.1 BETA2 Bug Reports

Please post all bug reports & BSOD’s here.
Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Other Backup & Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • if the issue is a BSOD, please post all the dump files in \Windows\Minidump folder (you can compress them)
  • if the issue is a crash, program stops responding or freezes please see this topic
  • if the issue is an error (not program crash or freeze) please run the dbgInfo.bat in installation folder and post the resulting cbu file.
  • Any other Additional Information (for example, any non-default settings used);

Your Operating System (and whether it’s 32bit/64bit)
Windows 7 x64 SP1

Other Backup & Security Software Installed
Avast Internet Security

How you produced the problem
I don’t know if this issue is specifillay related to this beta version but since I’ve installed, I always get an error message saying “Could not load language file” -see attached picture-
I reported another issue in the previous beta version;msg593273#msg593273 -I have no answers yet- and I tried out this new beta to see if this problem was resolved. After uninstalling previous beta and restart the computer, I tried to install the new version. Now, even if I uninstall this beta and install the last release version, I get the same error message.

How you tried to resolve the problem
Uninstalling CB and performing a registry cleaning with Argente and CCleaner.

Screen-shots with the error (if any)
See attached

Any other Additional Information (for example, any non-default settings used)
I disabled temporary Avast Internet Security during the installation but the same occurs

[attachment deleted by admin]

I want to share how I fixed the problem that I reported relating to the installation fail -Could not load language file-
Even after cleaning the registry with CCleaner or Argente, the issue persists so I decided to explore the registry manually to find the cause.

These are the registry keys I found and I deleted to fix the problem:

  • HKEY_CURRENT_USER\software\Comodo Group\ComodoBackup
  • HKEY_LOCAL_MACHINE\software\Comodo Group\ComodoBackup
  • HKEY_LOCAL_MACHINE\software\Wow6432Node\Comodo Group\VersioList
  • HKEY_USERS.Default\Software\Comodo Group\ComodoBackup

In the two last keys I found references to GUILANG.dll so I suspect this was the cause.
Deleting such keys solved the problem

I’m facing exactly the same issue as reported in previous beta;msg593273#msg593273

Whenever I try to perform a backup trough the Shortcuts menu of one of my encrypted CBU files, I get a error message telling me the encryption code entered is wrong.
If I try to restore this CBU file and set the password, everything works fine so neither the file nor the password are wrong.

Thank you for reporting the issue.
We found the problem. It will be fixed in next release.

Win 7 64

  1. In Settings I tried to use a shared folder as the Default backup location and I received and Invalid location error message. This is working on 4.0

  2. When setting up a new File and Folders backup and try to select a shared folder for the destination, I receive a message that I need to specify a file name. I can type any name in the address bar after the shared folder and the program accepts it. Otherwise, I can go nowhere. The name can be anything like …\shared folder[u]anyname[/u].
    The 4.0 version does not require anything like this.

  3. When I finally save the backup as a Custom Profile and attempt to run it I get an error code 30 (write error) and the backup fails. This is the same behavior as 4.0. All other processes and programs I have can read/write to the share without any problems.

By the way, the share I am talking about is a drive attached to the ASUS router RT-N56U and it is setup without password.



Your Operating System (and whether it’s 32bit/64bit)
Windows 7 Home Premium x64 SP1

Other Backup & Security Software Installed
Avast Antivirus

How you produced the problem
Unable to make Default Backup Location a remote path e.g. NAS box. Even if you browse to it etc., the error is ‘Default backup location path is invalid’

How you tried to resolve the problem
Tried changing the server name to IP address.
Disabled Avast

Any other Additional Information
Using Beta version Beta 2

Can you please collect the debugging information after you encounter the error and post them here.


In case you want it, my OS is Windows XP Home Edition SP3,
Firewall is Comodo 5.1022…
Antivirus is Avast 7

I created an incremental backup “simple file”, scheduled “service run”, it worked perfectly while CB was not started. As soon as I booted CB (seconds after the end of “Service Run”), it requested to backup as if it had missed the backup. To check, I pressed yes and effectively it did another backup.
It looks like if you don’t remove the option “Prompt user” it wants to backup disregard it did in service run while CB was closed.

1- I noticed, after creating a “Shortcut”, if I create and save a schedule for it, this new backup job moving from “Shortcuts” to Manage Events", doesn’t appear in the “Manage” “Events” until I exit and reopen CB.

OK, here’s the debug info as requested.

[attachment deleted by admin]

Your Operating System (and whether it’s 32bit/64bit)
Windows 7 Home Premium x32 SP1

Other Backup & Security Software Installed
Avast Antivirus

How you produced the problem
By trying to open it. After several times, I only managed to open it a few times.

How you tried to resolve the problem
Disabled avast

Any other Additional Information
Running CB beta, v. 4.1.1

Best regards,

These issues will be fixed in next release.
You can try the new GUI.exe to see. (Place it in the installation folder).

For this issue we need the debug logs. The issue might happen with connections that sometimes fail randomly during large network backups. We just need to be sure if this is the cause.


Please try the GUI.exe I posted above (place it in the installation folder).
It should have the issue fixed.


Be careful people in using the instant sync (real-time synchronization) at least with simple copy.
I tried it to backup my Outlook Express emails folder. After that, I realised my Inbox had lost half my emails. This was from a list of cumulated good-for-now emails since Oct 2008. My emails 2010 to 9April2012 were gone from my new sync backup as well as from my Outlook Express inbox.dbx (source). Thank goodness I had made a copy before testing.

I unticked this instant sync (real-time synchronization) but it would never give me back the options of “If schedule is missed” and “Run mode”, not even after closing and trying again nor by exiting and restarting CB. And from that moment, CB would constantly synchronise my emails folder backup non stop, one backup after the other every few seconds without me changing anything in the source.
I had to delete the backup job from “Events” and rebuild a new “Shortcut” and reschedule it with no more synch. thank you.

I’m not sure, but the loss of emails in the Inbox.dbx might have happenned while Outlook Express was not exited yet.


Did anyone had anything to comment upon my problem…?

BR, Niklas

Sorry, taken so long, been out and about !

The new GUI excepts the network path as the default location etc., so that’s good but when you go to use it e.g. hit the ‘Default Settings’ it doesn’t apply it to the Backup name, it just changes to the first tab - ‘COMODO Cloud.’ When you change to the Network tab, and then select the NAS etc., the file name is missing, where as if you use the ‘My Computer’ tab, the filename is added.

One nice thing would also be to list the directories in alphabetical in the listview box.


Please create a dump file, when CB doesn’t open so we can determine the reason and fix it.
Please post it with the debug logs.