Comodo Backup bug list [v1 no longer updated]

Please put your bugs for version here.


With regards to the incremental backup mode (using “copy with deleting other than source files”)… I create and delete a lot of files and folders during my work. When it comes time to do my regular backup I have noticed that any files I delete in the source are of course, deleted from the destination (which is correct)… But the FOLDERS that I delete in the source are NOT deleted from the destination. Consequently my destination (backup) is continuously growing with useless empty folders. It seems this latest update has not addressed this problem. Thank you.

I don’t know if this is a feature limitation or a bug but if Backup Type is Service you cannot schedule to perform every X hours, whereas as a User Backup you can

In v1.0.4.337 Service Backup doesn’t support every X hours backup.

Does that mean the feature was removed?

Yes, in v1.0.4.337 for Service Backup it was removed .

I’d like to have known before upgrading.
Thanks for confirming that however I’m going back to

Will it be re-introduced? If so, do you have a rough ETA?

Also, a rough ETA on corrected spanning across multiple CD/DVD’s?

Ewen :slight_smile:

There is no ETA yet. We will try to address both issues in the future releases.

If you add a folder to a backup and also add an Exclude folder the following folder you add to the backup will also have this folder in it’s exclude list.

I just using comodo backup and create a tutorial (Quick Start).

But also I have a problem (screen shot available at my blog above):
→ Files don’t get copied if have asian text as filename


Hi ecadre

Very nice tutorial.

I moved your post to the bug list in hopes that the developers will check it out.


I want to synch one folder on hard drive with one usb pen drive. The problem is: on hard drive, the files are in c:\files\folder, but on pen drive the files MUST be in f:\ (root folder). I can’t set root folder on comodo backup as destination folder. How can I solve this problem?

Thanks in advance.


I am trying out Comodo Backup on an Intel P4 running XP pro sp2, backing up to an external network hard drive.

Although I select the Incremental Backup, it always seems to backup everything as though I had selected a Full Backup.

After running each backup, the archive bits of all the backed-up files are cleared ok, but the archive bits of their folders are not. Those folder archive bits are all left set. Should this be the case? And could it be the reason why an Incremental Backup is backing up everything?


When backing up with compression, the “Backup mode – Copy with deleting other than source files” mode does not delete files from the archive. It mirrors new files from source to destination, but does not mirror deletions (and renames). However, when backing up without compression, this feature works fine.

I started with files A, B. Performed backup. Then renamed A to A1 and deleted B, added C. Performed incremental backup with “copy with deleting other than source files” and subsequently the archive backup had A, A1, B and C.

I’ve already logged a ticket for the same.


Hello, I am looking at using this backup program, version I have tried a few tests and have found a problem with the restore.

I have created a simple copy backup and selected 3 folders in the source tab.

After I run the backup (with no problems) and try to restore using the menu “Backup” then “Restore from Local Machine”, select my backup from the list and click on the “only selected files”, then “next”, only the first folder from my source list is in the “select the files and folders for restore” section.

Any advise would be very much appreciated.

Hi stunlisa

It appears that Comodo has a problem doing subfolders when restoring. I hope they fix it soon. It does not backup any files in a subfolder unless that subfolder is selected as the restore source. I have found that a quick drag and drop works easier than trying to use the restore section of Backup.

Hope that helps you.


I am using Comodo Backup
I have created service backup with source on network and destination on local HDD.
Service starts on administrative account. Permission on almost all files is read/write. About 100 files ore read-only.
Backup starts on schedule in correct time, it works about 1 hour and 30 minutes.
But! In destination folder I see only directory tree, almost without files. Only 100 read-only files are copied.
What is the possible reason?

Creating a backup from files & folders whose names contain non-ASCII characters results in the file & folder names being wrong in the ZIP file. Attaching screenshots of the directory listing of the original files, about Comodo backup log and about the contents of the resulting ZIP file. Interesting enough, the backup log file shows the non-ascii characters all right, it is just the resulting ZIP that has wrong characters. Some issue with ZIP code pages?

I’m using Comodo Backup on a PC with Windows XP SP3 (Finnish).


By looking the created ZIP file with a hex editor, it was apparent that Comodo backup saves the filenames in CP1252 encoding instead of CP437… This is incorrect as the CP437 must be used unless the bit 11 of the general purpose bit flag is set in which case the encoding must be UTF-8.

Please correct this as soon as possible and preferably switch to using Unicode (UTF-8 encoding right away). Feel free to contact me if further information is needed.

[attachment deleted by admin]

Hello, I am running a daily backup which includes about 10 e-mail PST files. Incremental or Full Backup, enable revision or not, I have tried many different option settings, but unfortunately, I find if someone has left their e-mail open (ie sharing violation), the backup records an error, which is fine, but the file (pst from previous backup) that is held in the destination folder is copied over (or name changed with revision filename) by a file with the same name but reports zero kb and no data within it, so if this happens 3 days in a row, and I have only 2 revision set, eventually, I have no backup at all. Is there a way to stop the backup from doing this. If the file is open, just move on without deleting the current backup.