"cmdagent" is vexing awful

Have been using the Comodo Internet Security, and it worked well for about a month, but now has gone completely haywire. A part of it called “cmdagent” is absolutely wrecking my ability to use the machine. This “cmdagent” is more or less constantly using between 50 and 75 per cent of the machine’s power. It kicks in about 4 times every hour, no make it 8 times an hour. When it does, the machine all but stops. I did a search for it in Google, and the only suggestions for dealing with this seem to be for the “firewall” program only, and not for the “internet security” program. Am now getting ready to toss the whole thing and go back to Norton. Very disappointed.

What changes did you recently make to your system around the time this problem started to happen?

How long do these interruptions take? What Windows version are you using?

May be it is getting upset by another program that kicks in frequently. Is there a program on your computer that could does a frequent task?

sorry for butting in but since the last program update of cis, that is “5.4.189822.1355” it’s been doing the same for me like when trying to start a program cmdagent.exe hits really high cpu values and doesn’t let the program start for awhile, even the taskbar freezes as long as this happens.

using winxp sp3

i have a pretty old computer too… 6-7 years or so, so i only have a single core cpu witch makes it worse but as i have 1 of the old pentium 4 prescot cpu’s i also have hyperthreading that splits the cpu in 2, that makes it easier to handle.

I’m having the same issue on XP SP3 since I updated to 5.4.

Occasionally after trying to start a program, the taskbar freezes during which cmdagent.exe uses 50% to 100% of cpu and up to 150 megs of ram. I can use Control Alt Delete to open task manager and that’s it. The only thing I can do is sit and wait a few minutes for cmdagent to settle down, or restart using the task manager.

This seems to have been an issue for some time now as shown is this topic.

Can anyone provide a link for a clean uninstall method to see if that would help?
I tried using Revo uninstaller to do an uninstall, but Comodo wants me to shut down Revo so it can update some files during the uninstall.

Lastly, CIS seems to be working just fine on my Vista box which leads me to believe this is isolated to XP since I have the same programs running. CIS, Sandboxie & Rocket Dock.

My computer situation appears identical to Mr. Elvi above, a single core P4 processor and machine about 6 years old, window XP sp3 and with 3 gbs of “hard” memory. There is no special thing I might have done that I can think of which might have caused this. No program that was installed, etc. I did note that there are many many reports of same problem when I did a search.

There are many proposed solutions to the “cmd agent” listed in various web sites, but they ALL refer only to the stand-alone Firewall. I have the Comodo “Internet Security” which has the firewall, but as part of the program. So the instructions for the firewall-only fix don’t apply. I really like the Comodo Internet Security program, much better than the Norton…except for this one problem, for which there seems no fix.

My computer is also 6 years old running XP3 with a P4 processor. Seems like a pattern to me.

I noticed this morning when cmdagent jumped to 50% cpu usage and froze the taskbar I could still use Rocket Dock to open Explorer and other programs on the dock.

I hope this information is being heard and will help in a resolution.

BTW shouldn’t this thread be in the Bug Report section of the forum?

Does this happen each time you start a program or only when CIS is making new rules?

May be left overs of previously installed security programs are in the way. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

Clean install method. Uninstall CIS and reboot. Then run this clean up tool and you should be good to go.

Try running clean up tools of previously installed programs and see if that helps or not.

I am not sure yet we are looking at a bug. But when needed I will request to file a bug report.

it doesn’t happen with every program and not every time they start either and no rules are made usualy.
doubt there’s any left over from any security programs, from what i remember i havn’t had anything other than CIS in since the last time i reinstalled xp.
the only other “security” software i have then is spybot and malwarebytes and they havn’t gotten any updates recently.
CIS had 2 updates after each other recently maybe at most a week apart, the one before this one didn’t have this problem at all but what version it was… no clue.

Are you willing to try a clean install to see if that helps?

You can keep your settings by exporting your active configuration from under Manage My Configurations to a folder that is not part of the CIS installation.

You can also keep your bases.cav so you don’t have to update the av after installation. You can copy back the bases.cav after installation (don’t reboot but copy bases.cav first). The file is in the scanners folder.

Similar to the situation with the bases.cav you can keep your trusted software vendors list (vendor.h, vendor.sha and vendor.n) and white list (white.h and white.n). They are in the database folder.

didn’t help a thing and it even got a litle worse at startup making the process take 100% cpu, don’t know if that was becuase of me or not but still cmdagent.exe shouldn’t stop a program from starting.

getting the av lists again after the uninstall and reinstall didn’t take long for me as i have a fiber optic connection :slight_smile:

What program was being stopped during boot. You mean stopped as in blocked; prevented from being executed?

i don’t know what program is being “stoped” just see that cmdagent is using up alot of cpu power.
what i mean by stoped is that program is prevented from being executed fully then after awhile they come up atleast later when this sorta stuff happens but at boot i can’t really say what other than what i allready said here.

What programs are being affected by this? I assume the programs function normally once the hogging of the CPU by cmdagent.exe has stopped. Is that correct?

It’s happened clicking on the start menu, quick launch icons, while trying to open task manager from the taskbar. It could be isolated to the taskbar but thats what I use the most. To confirm that I would have to do some testing and post back.

Yes, the programs function normally once the 50% to 100% hogging of the CPU has stopped.

Windows seems to remember what you did while Comodo is busy, When Comodo is done, Windows will open the start menu, launch your program and open the task manager all at once.

The problems you are seeing with start menu that is one we had with one of the previous versions.

Did you try the suggestions I made in the above? When they didn’t help try a clean installation? Sometimes that can “magically fix” those problems. Uninstall CIS reboot, run this clean up tool and then reinstall CIS.

Don’t forget to export your active configuration (from Manage My Configurations) and import it back after installations. You can also keep your av definitions. Just back up bases.cav. You can put back the bases.cav and your saved configuration after installing CIS but before rebooting.

butting in again heh i tried uninstalling again but this time using that cleanup tool, same thing after install but this time the “config” files almost didn’t load with the program setting i had brr, it eventualy did after a few reboots but maybe it was cause i moved the program to another partitision and another hard drive than c:

so far the programs that has been affected for me is “whereisit” and “Trains and Trucks Tycoon” thats the 2 i atleast know about.

First off thank you for you continued support regarding this issue.

Please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

The problem with the start menu is several versions back. I cannot retrieve from memory what specific version. It got fixed in the past.

Because of the similarity with that problem and that there is a certain chance that your current installation is updated from previous versions I figured a clean install could be a good advice.

Actually, I did uninstall 5.3 rebooted twice then installed 5.4.189…

I don’t have that many custom settings so I didn’t even export settings.

I still think it’s worth the time to run the clean up tools.

I will backup registry with erunt before running the tools just in case.

Will post back when I’m done with it some time this week.

Thanks again! :-TU

Keep us posted.