cmdagent.exe crushes and stops running at system boot (v 4.1.150349.920 x32)

CPU: 32 bit
OS: Windows XP SP3
Version: CIS 4.1.150349.920
Account: Administrator account

Symptoms: cmdagent causes an unknown exception (0xc0000417) in the application at position 0x00436704
cmdagent then is closed by OS and CIS reads it as not running.
Diagnostic doesn’t find anything wrong.
The problem happens at every system boot.
If I try to start manually cmdagent.exe it runs for 2 or 3 seconds then stops (as seen in task manager).

The following is a copy of Microsoft bug report on the exception:

Comodo Internet Security - Segnalazione problema a Microsoft

szAppName : cmdagent.exe szAppVer : 4.1.18600.916
szModName : cmdagent.exe szModVer : 4.1.18600.916 offset : 00036704

Appcompat.txt attached

Thanks for help


[attachment deleted by admin]

I’m experiencing the same exact problem running same version of CIS and XP SP2.

did you have any older versions of comodo installed before?

When cmdagent crashed on boot up after I updated from a previous version. I uninstalled CIS and reinstalled from a fresh download with the same result.

you need a much better uninstall. Try following these steps please:

download version 4.1 and have it on your desktop.

Download this batch file and have it on the desktop.

then uninstall with revo, making sure to select the moderate setting. When comodo asks you to restart don’t, finish up with revo and then restart.

After restarting go and check to make sure the network driver is not left over, if it is uninstall it, if it asks you to reboot do it.

After that right click on the batch fine and run as administrator, then when it is done reboot.

After rebooting re-run the batch file to remove any locked registry keys, reboot when done.

Now try installing v4.1.

No luck. I followed your very clear instructions with the same results. I’ve attached the diagnostic report.

[attachment deleted by admin]

I’m not much into reading reports, they make my head hurt, maybe one of the dev guys can jump in here. For the time being I want to ask what other security/virtualization/etc software you have on your system? Can you please also provide me a hijackthis report.

I’m not running any other security type of apps other than CIS.
Here’s the attachment for hijackthis report

[attachment deleted by admin]

you still have things leftover from the old CIS in D: drive. Also why are you installing CIS in D: drive when windows is in C drive, they need to be in the same drive because CIS needs access to windows.

I also see a leftover from symantec, liveupdate?

I believe live update is also used for updating symantec winfax app I use.
It’s odd that comodo would provide the option to store CIS in alternate location if it was required to run on the same drive as windows folder. But, I’ll uninstall CIS and reinstall it on C: and report back.

I think it will install wherever you start the installer from, it does not know where windows is installed.

Reiinstalled CIS on C: with the same result. cmdagent crashes on system startup. Firewall seems to start up but virus database never gets updated since cmdagent crashed.
I post the diag report.

[attachment deleted by admin]

can you post another hijackthis for me.

Sorry for the delay. Here’s an attachment of the log

[attachment deleted by admin]

Finally cmdagent started up without crashing and it was able to update the virus db.
After numerous unsuccessful attempts using the diagnostics/repair process I decided to restart the system with sandbox feature disabled and xp restarts error free.

I’ve tried re-enabling the sandbox feature but system start-up is extremely flaky.

can you provide me a screen shot of pending files and trusted vendors, both under defense plus?

Here are the screen captures of both pending files and trusted vendors. There are multiple screens for trusted vendor.

[attachment deleted by admin]

pleaae select wfxsnt40.exe, wfxswtch.exe and ati conrol panel and move them to my safe files. Now turn the sandbox back on and see how start up is. Are you getting anymore sandbox warning popping up.

I just came back and I thank you for interest.

I have unistalled older versions of CIS and the only security program that is running is spybot.

How can I fix the problem?

I need infos “for dummies” …


Did as instructed and restarted with sandbox enabled. The system behavior on start-up was significantly improved. There’s a slight lag between the logging in and the desktop being displayed, but that’s tolerable.

Before implementing your suggestion, the system seem to hang once the desktop was displayed. The system tray would not get populated; the mouse pointer would turn into an hourglass if you pointed at the task bar; and accessing task manager with ctr+alt+del would make the system unresponsive.

For now all looks good.

Thank you for your help and all the useful suggestions.