cmdagent.exe crushes and stops running at system boot (v 4.1.150349.920 x32)

try also doing a fully system scan and provide me a screen shot of the results please.

Here’s a screenshot of the scan result:

[attachment deleted by admin]

is it any faster after doing a full scan?

It appears to be a tad bit faster. There doesn’t seem to be any significant start-up speed differences with sandbox enabled & disabled. So I’m satisfied.

Thanks again.

Hi Languy99

I’ve tried all your steps, uninstalled CIS, used tool etc.

cmdagent still crushes.

I have then disabled sandbox and it seems to work fine.

Antivirus did the update and cmd agent has not crushed.

Attached is my hijackthis.log.

What do I have to do next?


[attachment deleted by admin]

First thing I would do is uninstall spybot, it has been known to mess with applications. Use revo to remove it.

Uninstalled spybot, I try to enable sandbox and I come back.

I did it and it seems to work fine.

I’ll try a full system scan to see if also the loop problem has gone.

Thanks so far!


I did some reboots of system and I tried some scanning.

cmdagent.exe didn’t crush for a couple of times then started behaving just like before.

Scanning seems impossible as it loops and drains all resuorces.

I’ll desable sandbox again hoping it’ll work.

Please help me solving the problem.


can you provide me another new hijackthis log.

I turned off sandbox and it doesn’t crush.

A new hijackthis log attached

[attachment deleted by admin]

the only thing in your report that I have never seen is that HIDAgent? What is that?

It’s a file that comes with installation of a digital pen.

I scanned the exe file and there is nothing bad with it.

I looked in the net for infos and I found that often that file is used by worms and malaware, so I scanned the entire directory where my digital pen is installed and Comodo gave me no infections.

P.S. With sand box disabled CIS doesn’t crush anymore. I tried several reboots and long sessions of pc work and I had no problems from cmdagent.

I can’t still run complete scans as AV goes into a never ending loop tha absorb all resources.
But this is another problem that I pointed out in another thread.


everything looks ok, can you give me a screen shot of my pending files.

I have no pending files

weird, then I don’t know what to tell you. Without actually being in front of the computer it is hard to go further. Something must be interfering with CIS from running properly. What other security suites did you have installed on the pc before CIS?

Just spybot as I formatted my pc some months ago before installing everything …
HP gives an installation of Norton that I stopped and I tryed an on line scan with panda site some weeks ago, so I have installed the activX control.

Now I eliminated spybot as you told me.

This problem was not present in 3.xx versions of CIS and goes away if I disable sand box.

It’s a long time that I have only CIS as security programs.
(Before that I was used to run both CIS and AVG, but it was before formatting)

has to be something, it’s hard to determine what, it could be another program or even a driver. See if you have anything that looks suspicious in the event viewer.

Nothing that looks suspicious…

When cmdagent crushes OS gives me always the same error, the one that I posted a the beginning, I don’t know if it is useful…

What kind of test can I do more?