CIS steals focus in Game mode - full screen games are minimised [286]

The bug/issue

  1. What you did: New install of CIS5 x86
  2. What actually happened or you actually saw: Program steals focus from fullscreen DirectX games, causing them to be minimized to the taskbar.
  3. What you expected to happen or see: Do not steal focus.
  4. How you tried to fix it & what happened: Set game mode – no effect. Disabled auto update – no help. Disable Defense+ – no help. Disable AV – no help.
  5. Details (exact version) of any software involved with download link: LucasArts KotOR2 (e.g.)
  6. Any other information you think may help us: No problem with this before installing CIS

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.162636.1135, AV 6277
  2. Whether you imported a configuration, if so from what version: no
  3. Defense+ and Sandbox OR Firewall security level: D+: Safe. SB Enabled. FW: Safe
  4. OS version, service pack, no of bits, UAC setting, & account type: WinXP Pro SP3 x86, admin user.
  5. Other security and utility software running: None.

Thank you for your bug report.

For a full report we need you to try the workarounds as described in App. is not working correctly, but does not seem to be s/boxed. What to do? [v5].

Let us know if any of them helped to fix it or not.

The game launcher and executable are both in the D+ trusted files list.

The problem is not limited to games. I’ve had occurrences when I’ve been reading a webpage and noticed that focus has left the browser window.

Did you try the suggested actions as described in App. is not working correctly, but does not seem to be s/boxed. What to do? [v5]?

The problem is not specific to the application. It’s happening in various applications. Even on my Win7 x64 system, which is still running CPF4, I’ve noticed that my current app loses focus when the CPF update check runs and reports an available update. That should not happen. On my WinXP system, with the full CIS5, the fact that the problem (stealing focus) occurs a few times after startup, then ceases, suggests that the problem was not fixed in CIS5.

Hi kaborka

Stealing focus is a very old & well known system problem rather than specifically Comodo’s issue

That was discussed here and in other forums hundreds if not thousands of times

Many security Packages are implementing special Game/full screen modes
Some are working better than others, but none of them are perfect yet

I do not play games ever, but I do use “full-screen-Applications” sometimes & I have several clients who are very involved in computer-gaming

They are using different security Avira; Avast; Emsisoft Anti-Malware, etc. where the said mode for full screen/gaming is implemented

It seems that anyway they eventually (unfortunately ?) just disabling the security in order to play and/or use not-gaming-full- screen Apps.

It looks like at the moment we can just wish we had a better solution(s)

The hope is out there :slight_smile:


I uninstalled Kaspersky AV to give CIS a try. I had no problems with lost focus when I used KAV. I can only infer it’s CIS that is causing my apps to lose focus. As I said, I suspect it’s happening during the program and/or AV update checks that happen shortly after startup.

Thanks for the reply , kaborka

Not all security that are currently employing the method were mentioned
As it was pointed - some do better job than others , but none are perfect
What does it mean: “my apps”? :slight_smile:
please try different ones with Kaspersky & that will fail the same way


I have seen a similar problem in the past few days.

  1. When viewing a flash video in Firefox
  2. Watching a DVD with MPC-HC.

Both were in fullscreen mode, then suddenly exited fullscreen. MPC-HC has written, cmdagent has stolen the focus. It was most probably CIS checking for signature updates. Can there be done something against this?

Latest CIS (2011)
Win7 64-bit

If you need any more info, please let me know. Thanks.

++ exactamundo! @mad: Thanks for your post and for identifying the culprit. It was as I expected.

Hello there,
I have the same focus problem with fullscreen apps and games since the recent skin/UI changes of comodo internet security (my current version is 5.0.163652.1142 / Virus signature 6324, over Win7 x64)
I had not that problem previously thus I guess that the trouble comes from these recent changes.


I think only the devs can tell if there is a workaround for the system issue. So I’ll forward to format verified.

See what response is given.


I have the same problem. You can verify if CFP took the focus when you press ALT-SPACE as soon as your application looses focus. If CFP Updater is active you should see the context menu that has the “About CFPUpdater…” menu entry.
This happened infrequently on CIS4 but it got really annoying since the update to CIS5.

same problem here

Thought I’d chime in… same deal. I’ve been using an alternative “Task Manager” to monitor the processes that eat CPU when the focus switch happens and it seems to be the Comodo Updater every time.

It’s gotten to the point where it does it often enough that my mouse will lose position in mid-highlight when I’m trying to highlight a block of text (code, in most circumstances – annoying) and then I’m forced to re-highlight.

a fix would be nice :S


cfpupdat.exe steals focus from full screen media player

The bug/issue

  1. What you did: Watching video in Media Player Classic Homecinema in fullscreen
  2. What actually happened or you actually saw: video stopped being full screen, message stating focus was lost to cfpupdat.exe (see attach)
  3. What you expected to happen or see: updater doesn’t interrupt full screen viewing
  4. How you tried to fix it & what happened: no obvious solution
  5. If its an application compatibility problem have you tried these fixes: n/a
  6. Details (exact version) of any application involved with download link: mpc-hc.exe v. 1.4.2499.0, Media Player Classic Home Cinema: MPC-HC - Browse /MPC HomeCinema - Win32/MPC-HC v1.4.2499.0_32 bits at
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes. Keep MPC HC in full screen long enough (probably however long it takes before updater performs next check)
  8. Any other information (eg your guess regarding the cause, with reasons): guess - updater expects to have an update dialog before confirming whether there is an update or not, so takes the focus from the fullscreen app

Files appended

  1. Screenshots illustrating the bug: Appended
  2. Screenshots of related event logs or the active processes list: N/A
  3. A CIS config. report or file: N/A
  4. Crash or freeze dump file: N/A

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.163652.1142, Internet Security config
  2. Have you updated (without uninstall) from CIS 3 or 4, if so have you tried reinstalling?: No, N/A
  3. Have you imported a config from a previous version of CIS, if so have U tried a preset config?: No, N/A
  4. Defense+ and Sandbox OR Firewall security level: Defenseplus=Safe, Sandbox=enabled
  5. OS version, service pack, bits, UAC setting, & account type: Vista Home Premium SP2, UAC disabled
  6. Other security and utility software running: No
  7. Virtual machine used: Not applicable

[attachment deleted by admin]

Thanks for a very clear bug report.

This is known issue, so I will merge with the existing report. Please click on the link in the email notification of this post to locate the merged topic.

Best wishes


btw it doesnt only happen with media player classic… also games in fullscreen mode loose focus :confused:

mouse1 can u post the link here so i can check out that topic too? :slight_smile: