CIS slow installation

  1. When doing clean install CIS takes long time. Exactly 22 minutes and 41 second.
  2. CIS is giving me no error warnings
  3. COMODO Internet Security 7.0.308911.4080
  4. Windows 7x64 service pack 1
  5. No configuration
  6. Clean install.
  7. USB disk security
  8. Uninstalled previous version, restarted PC, done clean install of Antivirus and Firewall. All other options unchecked. I have tried with the internet both disconnected and connected and there was no difference.
  9. Slow installation, 22 minutes and 41 seconds. Installer hangs on 67% for a long time.
  10. I expected faster installation. Maximum 7 minutes.

Interesting. If you don’t mind, could you try it again, but this time with the internet connected? I wonder if that is part of this.

If it does install normally, and I’m sorry to have to ask this, but please try once again reinstalling, but this time with the internet disconnected. I just need to make sure that there really is that sort of a pattern if I am going to forward it to the devs.

Thanks and let me know if you have any questions.

I’ve done it twice already with internet disconnected, with the same result.

Okay. What happens if the internet is connected during installation?

Sorry, but I never leave my system unprotected.

For the purposes of testing this Beta please try it, just this one time. My worry is that perhaps CIS is performing some sort of cloud communication during installation, and that therefore severing that connection may cause a great delay. If that is the case I would really like to forward this to the devs as a serious bug, but before I can do that I need to make sure that is the real cause.


Ok, I have now completed a clean installation with internet connected, and the time was 25 minutes and 21 seconds.

Okay, please try reinstalling CIS using the methods I suggest here.

If the same problem continues make sure you have a portable version of CCE on your computer. Then, when it is stuck at 67%, open KillSwitch. Then right-click on any of the processes and select “create dump”. Then select “Create Full Dump…”. After CIS is installed you can upload the dump file to a file sharing site, such as this one and paste the download link in your first post.

Also, after CIS is installed, create a diagnostics report and attach it to your first post.

Let me know once you have tested the reinstallation procedure, and if that does not work provided the two files.

Thank you.

Was reinstalling by following the methods I reference in the other topic able to fix this? If not, have you been able to create the full dump using KillSwitch while the installation is hanging?


I’ll try it tomorrow. To busy at the moment.

Have you been able to test this, and if the issue still exists create the Full Dump?

PM reminder sent.

For the time being I will move this report to the Non-Format section, as it is awaiting important information.

If you are able to replicate this issue please create the full dump using KillSwitch while the installation is hanging. I can then forward this to the devs.

If you have any questions feel free to ask.

Thank you.

CIS version 7.0.313494.4115 Final has just been released. Therefore, if the issue still occurs please create a new bug report for it in this section of the forum. The required format is provided in this post. Just copy and paste the code. Then replace the question marks with your responses.

I’m sorry, but as the most recent release is no longer in Beta the Beta bug reporting format can no longer be used. I will therefore move this report to Resolved. If the issue still occurs please do create a new bug report.

If you have any questions please feel free to ask.

Thank you.