CIS seems to block my VPN program

I am using a VPN software called psiphon3.
Here is the homepage of this software: Psiphon | 适用于 Windows 和移动设备的无审查互联网访问
And here is the download link of it:
This software has only one executable file, “psiphon3.exe”.
It will create/release some other executable files in the temp folder in the running time.
I have changed the reputation of all these executable files to “trusted”, and have created rules to allow all internet connections established by these files in the firewall setting.
This software has two modes, SSH and VPN, which can be switched by clicking the check box “Use VPN Mode”.
When I run it in Comodo’s sandbox, it can establish SSH connection successfully, but cannot establish a VPN connection.
I think this is a bug, because I believed that, with the settings described above, this VPN software should be able to do anything that it could to do in the environment with no CIS.

By the way, with CIS installed, if I run this program in SBIE (sandboxie), it can establish neither a VPN connection nor a SSH connection.
I hope to emphasize that although I am using CIS along with SBIE, I do not think this problem is related to SBIE, since this issue can still be reproduced after uninstalling SBIE.

Hi Hong_Long,

There was a similar issue. Please use the required format in order to further process your issue.

In the meantime, I will move this report to “Resolved” section.
Thank you.