CIS GUI corruption on systems with dual-graphics [M2173]

1: CIS version:10
2: OS version: win 10
3: What you did: try to install CIS 10 with cispremium_installer_6100_08.exe. The GUI gets mixe3d up during installation and after installation
4: What you actually saw: Window black (see comodo wrong.png) and with mouse over sometimes visible (see comodo good.png). I have a system with amd dual graphics. By turning off dual graphics the problem disappears. So I think this is the problem. With Comodo 8.4 no problems
5: What you expected to happen or see: a visible window
6: If possible attach a screenshot illustrating the GUI problem See comodo wrong an comodo good.

I have the same symptoms on a Lenovo G580 laptop.
It has two graphics cards : an Intel HD Graphics 3000 and an nVidia Geforce 610m.
Drivers are up to date.
Windows 10 pro 1607 with latest updates.
CIS 10 is almost unusable : when i click on buttons, check boxes, i am not able to click on them anymore.
I have to reduce then widen each window in order to be able to click again on buttons, icons, etc…
When i move the mouse over objects, buttons, etc… CIS redraws on screen, and seems to blink, flash, etc…
I have several computers, and it is the only one that produce that, and only with CIS 10.
Other softwares work perfectly.
I hope you will be able to fix those graphics gui bugs… it is really annoying…

Have you tried switch different theme for CIS? It would be best to turn off dual-graphics, try a different theme, then re-enable dual-graphics and check. It could be an issue the new lycia theme.

I switch from Lycia to Classic theme.
There are still graphics glitches, strange behaviors when moving mouse over CIS graphics.
That’s strange because i’m not new to CIS.
The previous version installed on that laptop was CIS 8, and it had no problem.
Well, I tried to switch from Intel to nVidia in nVidia default card settings, but had no luck either.
I found no way to disable one graphics card or the other in the bios, or in windows.

I want to point out, as in my first post, that even the installer has the same problem. See my screenshots.

Ok thanks for checking, I have made a report in the tracker noting CIS GUI corruption on systems with dual graphics.

Like AdNL, i had the graphics during setup too.
On three Asus GL752VW, dual graphics, but no troubles at all.

Comodo would like to get system info from msinfo32 application.

  1. Click Start-menu and type msinfo32 and press enter.
  2. From file menu click save and save as any filename.
  3. zip file and attach here or provide a download link to file.



here is the msinfo file, zipped and attached, for a Lenovo G580 2189 laptop.

Here is mine, AdNLmsinfo32

Please check again with Comodo Internet Security v10.0.1.6209 thanks.

Comodo v10.0.1.6209 installed intself this morning. Same problem, windows are corrupted! See example!

Just updated to v10.
Pc is win7 64bit and CIS started tripping out, flashing and becoming unresponsive.
It flashes between black and white depending on where the mouse is, also with repeating fast flashes of small sections of the open window.
When I open a program window or there’s a pop up window like “new network”, it can’t be clicked on until it’s minimised then maximised, if you cant minimise it your stuck, and there’s still flashing bits across the open window. Settings window for example flashes about between black and normal depending on where the mouse is.
I’ve tried reinstalling it, and an older version I have worked fine but failed as well after updating it. My Nvidia Gpu is updated as well, along with everything else.

Hi JonM,
We suggest you to uninstall and re-install latest Comodo version and if you still see problem, please report.


fixed it with 8.4

The new update for comodo a few days ago absolutely broke the program on my side.
The windows keep flickering black and back when stuff happen, buttons wont work 90% of the times, and popups are always 100% unclickable(new network, restart in X mins, ect.)

Hi Nevaran,

Please provide what version of Windows you are using.

Kind regards,

bug 2173

I am using Windows 7 Ultimate

Thanks for the link.

After i read it, and saw that it happens when there are more tha 1 GPUs, i went to my nvidia control panel and forced comodo to use the integrated intel GPU instead of the nvidia one.
The problem seems to be fixed, but i am looking forward for the devs to patch this problem so i woudnt have to do such hacks