CIS does not create startup key or task for cistray.exe [M1204]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Download and inatall CIS premium
2: After it updates and initially scans, reboot the PC
3: CIS trayicon and widget will not load/ be seen on startup
One or two sentences explaining what actually happened:
I followed the help on how to install CIS to fix problems, and yet CIS installer keeps producing the same issue for me. CIS will NOT start on pc startup.
One or two sentences explaining what you expected to happen:
CIS to start on startup of the computer.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Not a software compatibility issue.
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how U tried to fix it etc:
CIS installer probably is unable to create a startup key/task on certain machines for an unknown reason. I could try to manually create a startup key,
but I don’t know how to do so.

Exact CIS version & configuration:
CIS Premium 7.0.317799.4142, and Default Config
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
All on default settings, nothing changed
Have U made any other changes to the default config? (egs here.):
Have U updated (without uninstall) from CIS 5 or CIS6?:
if so, have U tried a clean reinstall - if not please do?:
Have U imported a config from a previous version of CIS:
if so, have U tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 64-bit, UAC on Default, Account: Administrator, Real Machine.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=NO b=NO

– I have not tested beta so I do not know if issue is present in it, so if needed I can try and check with it–

Required Files are Attached

[attachment deleted by admin]

Thank you for reporting this. Have you tried the Beta yet? If so, have you noticed the same issue with V8?


I have not tried beta yet, should I? I will try removing CIS and installing it later.

If you are okay with trying Beta software it would be helpful to know if it also happens with V8. This would be very helpful information. However, Beta testing is certainly not required. If you like I can just forward this for V7 and they can investigate from there.

How would you like to proceed?


I’m fine with testing the beta software, I will report if the issue is present in that version.

Just confirmed that the issue is also present in CIS Beta 8.0.332922.4281.

Attached Diagnostics report in case it helps Comodo solve this issue.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Why is this a beta issue? This is main CIS v7 issue.

I moved it here because it is happening with the Beta as well. In terms of it being fixed, it makes no difference where I put it. I just put it here because some others running the Beta have complained of a similar issue. Thus, I want them to be able to more easily find it, and see that it has been submitted.

Extra note for devs

the problematic CIS installer is

208 MB (218.252.480 bytes)
MD5: E784C7394C653A003DE646C2635E9DD1
SHA-1: CCC5DDCF2251C7BEF8CE967966751D0A1D5EAE2B

I believe CIS beta inherited the problems from it.

What do you mean when you say that it inherited the problem from it?

I believe that the CIS installer with the file information:

Size: 220M ( 230403216 )
MD5: b03c6045711e56c4f9a48184462eaf84
SHA1: 3bc936a249e5a93b448e6faa275e6c0a995a0a51

Doesn’t have this issue, but I have no where to download it and see for myself.

Can you please explain why you believe this, or if applicable post a link which shows why you believe this? I would like to have more details before I add this information to the tracker.


He has tried both to make that point I guess. It happens to one of my test machines as well.

The files I downloaded from the forum and the main website gives me a totally different hash

MD5: 3EC00958ADC9B292CA65958E86BC5AFE

The problem persists.

^Comodo Firewall

I am also having this issue. I have Windows 8.1 64-bit on my machine and no other real-time software installed.

Neither installing CIS or CFW worked as it wouldn’t start on boot.

I confirm CIS7 is still not fixed :frowning:

This issue seems to be fixed for the Beta Version of CIS. Hopefully once it is fully released this will be fixed for everyone experiencing this issue.