CIS crashes Win10 UI; ShellExperienceHost.exe

My system: Windows 10 64, latest version /all updates

Using cmd_fw_installer, fresh install, no updates available

After installing the firewall and doing a restart the Win 10 UI bugs out and/or becomes unresponsive.
Left click on start menu no longer works. Right click on start menu still works, however some of the options there also don’t work anymore.
Like going to setting or the apps tab. Even uninstalling the firewall again wasn’t easy because the UI was barely reacting.

In the windows events logger it says that ShellExperienceHost.exe APP is hanging / no longer working.

As soon as I uninstall the firewall and do a restart the Windows UI works perfectly again and the ShellExperienceHost.exe error is also gone.

Can you give the full details of the windows event log of the application?

I should probably add that this issue just appeared recently, like in the last week or so, I’ve been using the firewall without problems for months before that.
Issue also persisted after a Win10 reset / reinstall , with pretty much nothing else installed.
So I’m guessing that this has something to do with some recent Windows update or a change in the firewall software.

Interesting, I don’t notice such issue. Which version of CFW was installed when issue began?

Should be latest version, downloaded from here
no updates available after install

I just tried a fresh install again with file from the link above, as soon as I restart the PC the Win 10 start button stops working again.

I also noticed some additional errors, I think right after installing the firewall. All of them WMI errors with ID 24, about 16 of them.

Here is one of them.

Protokollname: Application
Quelle: Microsoft-Windows-WMI
Datum: 07.11.2017 17:53:51
Ereignis-ID: 24
Ebene: Fehler
Benutzer: SYSTEM
Vom Ereignisanbieter “” wurde versucht, die Abfrage “SELECT * FROM CisEvent” zu registrieren, deren Zielklasse “CisEvent” im Namespace “//./root/cis” nicht vorhanden ist. Die Abfrage wird ignoriert.




<data_0x8000003F xmlns=“”>


Try adding ShellExperienceHost.exe to don’t detect shellcode injections in these applications and reboot to see if issue persists.

Just tried it, didn’t seem to change anything though. UI still randomly crashing and error message is still there as well.

OK lets uninstall CFW, reboot, run this removal tool with run as administrator when you right click on the .bat file, choose to remove CIS and reboot when it finishes. Then install using the offline installer for the 6406 lasted build here.

done, still same issues as soon as i restart the PC after the installation.

Provide the CIS diagnostic report and if you can run a system information report with msinfo32.exe go to file and choose export and attach. I will contact a staff member to have a look so they can investigate further.

see attachments

Looks like it is caused by incompatibility with avast


Just uninstalled Avast, restart, fresh Comodo install, restart, same issue again. So I don’t think that’s it.

Hello, Yok.

Your issue is under investigation. Please check your PM and provide needed logs and files.

Kind Regards,

Thanks, replied to your PM with the requested logs.

Same problem.
Quick solution: add “Windows system apps” group to “Detect shellcode injections exclusion”. But I do not think that this is the final solution to the problem. I hope Comodo will fix the problem.

Hi, DrGluck.

Thank you for reporting. I have added this info to the internal ticket for dev team. They will try to fix it as soon as possible.

Kind Regards,

Hi Yok / DrGluck,
May you please try latest Beta v6464 and see if you can still produce the problem?


I installed beta from offline installer. After reboot CIS switched to a clean profile. After the next reboot, the problem is still there. CIS log is clean. The problem disappears if I disable Comodo service and reboot OS.
I can do anything else if you tell me what I need to do.

Hi DrGluck,
Can you please uninstall CIS and install CCAV and see if you have same problem with that as well?