CIS 3.8 blocks almost all .exe files on Vista x64

Hi !

I was advised by a senior forum member to repost my problem here so it gets more attention from Comodo team.
The original thread is here:

It seem this is not an isolated problem as many people complain around Comodo forums.

So, the original post is:

I hope Comodo will soon release a fix .

You running Ad-Aware AE? If so remove it and re-install. That fixed my issue with my apps not running.

To help us identify the problem, can you please try the following and let me know:

1 - Pls disable Defense + → Advanced->Defense+ Settings->Trust applications digitally signed by Trusted Software Vendor option and see if it helps to fix the problem

2 - If 1 does not help, can you please set D+ to Paranoid and Firewall to Custom mode and try again to se if it helps?

3 - Can you please paste a screenshot of Process Explorer process list so that we can see what applications are running?


Hi !

I installed the update (3.8.65951.477) after I was prompted by CIS - again the same problem.

Then completely uninstalled CIS and yet again cleanly installed 3.8.65951.477 - again the same problem.

I am puzzled because I saw “FIXED! Applications do not run when CIS is installed in Vista 64” in the release notes of the new version and I still have the problem. That’s why I did the clean install.

egemen , I tried the fixes you provided with no positive result.
Sorry, call me paranoid, but I do not like the idea of posting screenshots of Process Explorer.
Otherwise, I use the tool for a couple of years now.
I know this is not helpful as a screenshot but other started processes after Windows startup are: IntelliPoint by MS, a few exes related to Logitech’s SetPoint Software, a few exes related to SB X-Fi drivers, Stardock’s ObjectDock, uTorrent and that is all (apart from system processes, of course).

Can you please tell me which other security applications do you have installed?

As I said in the first post - none .
I have a double boot configuration with Windows XP SP3 and I make regular manual scans of all my drives from there. That’s why I do not have any other security apps installed on the Vista x64 installation.

I was thinking about one other thing - I have the Bulgarian language pack installed. Another forum member complaining about the same problem had the Polish language pack. Can this be the cause ? I think it should not be as at the system level all Vista installations should be the same - but you should know better.

Ok I can personally try to identify the issue with you if you are willing to have an MSN or EasyVPN session with me?Please PM me if you can.


i had the same problem, i think its Ad-aware SE . I uninstalled it and reinstalled CIS .477 and everything worked fine.

Someone already mentioned this but HAVE YOU TRIED IT??? It should fix your problem.

I have posted it a couple of times now - I do not have Ad-Aware . Well, I didn’t have it … ;D

After losing all hope, running out of any other ideas and being constantly asked “Do you have Ad-Aware ? Uninstall it !” I got creative and decided to … install Ad-Aware, so I can uninstall it after that :slight_smile: . So, I uninstalled CIS ->restarted->installed the free version of Ad-Aware ( I don’t know if it makes any difference if it is the free or paid version)-> restared → unistalled it → restarted-> installed CIS . And now everything works fine !

I don’t know - it is an old install of Vista x64 and I may have tried Ad-Aware for a brief period of time long ago. Maybe the uninstaller of Ad-Aware was ■■■■■■ back then. That’s the only way I can explain it to myself but I still don’t understand why with CIS 3.5 everything was OK. Anyway, the problem is solved for now.

egemen , thanks for your readiness to help. I really appreciate it.

BTW, I am planning to install some AV (that is, at least until Comodo AV becomes really mature product as is Comodo Firewall ). Does CIS 3.8 have any known compatibility issues particularly with Avira free, AVG free or Avast free as is the case with Ad-Aware ?

CIS 3.5.57173.439 plays OK with Antivir and Ad Aware AE (both of which I really like) in Vista 64 bit. I think I will stay with this CIS version for now.

I had the same problem with CIS .477 and I use Ad-aware SE.

Egemen, please let me know if you need more info about my system. Thanks in advance.


I have the same problem with CIS 3.8.65951.477 I have also Ad-Aware. Any help more than welcome!!!

Is there a secure place where I can download the CIS 3.5.57173.439? Thanks in advance!!!

You can download it Here
Please remember the AV does not update in this version.



I also had the same problem with programs not running. I had a version of Ad-Aware loaded at one time (free but version unknown) but not now. Which version of Ad-Aware did you use to clear your system with? I realize you used the free version but did it have a version number? Date and/or filesize? I’m wondering if I might be able to use the same trick on my system. I got my system running again by dumping Comodo and falling back to the builtin firewall (Ugghh).

I am using Ad-Aware 8.03. But the way I found to solve the problem was installing the COMODO CIS 3.5.57173.439. I downloaded it from a secure place from COMODO

Hoping that this help!!! Take care.


Does somebody know if COMODO will fix this bug or I will be forced to use CIS 3.5 for ever?

In the latest beta of 3.9 : “FIXED! CIS blocks some application from being executed” .

For the fast and the curious; you can get 3.9 beta here: .