CIS 3.8 blocks almost all .exe files on Vista x64

Hi !

I have a very serious problem with latest CIS 3.8 version (that is CIS_Setup_3.8.64739.471_XP_Vista_x64.exe).

First I want to clarify some things:

  • I am using Vista x64 SP1 and accordingly I always use the 64-bit version of CIS.
  • I use only the Comodo Firewall, I do not use the AV module.
  • I do not have any other standalone AV, firewall, anti-spyware and so on.
  • Up until a few hours ago everything was running perfectly with latest CIS 3.5 .
  • I made a completely clean upgrade: uninstalled CIS 3.5 and then installed CIS 3.8, no settings from the previous version were transferred and imported into CIS 3.8 .
  • Firewall in Safe Mode ; Defense+ in CleanPC mode.

The problem:
On first boot after installing CIS 3.8 :

  • Windows loads to the desktop
  • No start-up programs are loaded, for example ObjectDock, uTorrent etc. - only the Microsoft IntelliPoint Software and the Sidebar.
  • Double-clicking on program shortcuts on the desktop, or directly on program .exe files (for example perfectly trusted apps like firefox.exe, thunderbird. exe, winword.exe), or on .mp3 .pdf .doc .avi and whatsoever registered file type results in nothing but half a second “busy” cursor and nothing runs. CPU load stays 1-2%, typical for idling system.
    Practically, no program is allowed to start after Windows start-up procedure.

After reading some other threads around here I identified Defense+ as the culprit. The fact is, after deactivating Defense+ completely (not just disable, but using the “Deactivate the Defense+ permanently” checkbox) everything runs as it should.

I played with many options of Defense+ but with no positive result.

Anyway, using CIS 3.8 without Defense+ is depriving it of one of its strongest sides and I think that it makes it much inferior to competing products.

So I thought, you guys with your extensive knowledge may help me here. I grew so used to Comodo Firewall that now when I know it works halfway I feel very irritated.

Could be a bug of some sort, Iam not used to the 64 bit platform, but should not be a problem.
I suggest an other fresh re-install doh, and that you leave D+ to safe mode after doing so.

You are right about D+ being important… =)

i have the same system configuration. and everything started with update from 3.5 to latest 3.8. after loading windows, nothing works; even firefox, winamp… i tried clean install but it diid not make any difference. is this a known bug?

I have exactly the same problem which trierum encounters.

Windows Vista x64 Ultimate SP1, with all the latest updates applied. Comodo Firewall (I don’t use Comode AV, but AVG Free instead as AV) worked as a charm before updating to

Any kind of help would be appreciated.

Seems like a bug many has encountered…
A detailed repost in the bug forum:

Could do the trick, as the DEV checks there a LOT and tries to fix ALL problems posted there! :wink: :slight_smile:

50 different little forums and sub-forums and we gotta find the ‘right one’ to get something done ? Unbelievable.

I’ve been posting this for 2 days now. Can’t even get a Moderator to acknowledge this bug might exist - much less someone from Comodo. As I said in another thread, good luck getting any help from these crazy forums.

Can you try to set the D+ “Keep an alert on screen” to something like 10 seconds and see if that results in “fast flashing D+ alert” after 10 seconds without the possibility to press some button on it ?

If you have Ad-Aware uninstall it then re-install CIS. This is what fixed mine.

The new version had a conflict with Ad-Aware in my case.;msg253995#msg253995