CIS Freezes when scanning a file[M2214]

I have a file that is an .exe, an installer that contains many files and when I try to scan this file, it gets part way and then locks up on the same internal file each time. At that point I can’t stop the scan using the Comodo application… I have to use Task Manager and End Task and restart Comodo.

I’ve sent the .exe to a friend and he has the same results with it so it’s not my machine or my install of Comodo… it appears to be Comdo itself.

The .exe is a little over 40Mb… too big to successfully upload via CIS 10. (It says the file is too big.) I’ve tried zip and rar but they don’t shrink the .exe enough to submit via the Comodo application.

So, how do I present the file to Comodo for testing?


Could send to servers like,, 4sharede post the link here

Thank you for the reply.

Ok, so I uploaded it to Here is the download link:

The file is the Pulseview logic analyzer software that I downloaded from Sigrok’s git page a while back.

When I scan it, it locks up Comodo and my CPU goes to 100%. I have to End Task on it and then I restart Comodo.

I really don’t believe it’s infected, I don’t have any other infections… my machine is clean. It’s just that Comodo chokes on it for some reason.

I’d appreciate it if someone from Comodo can figure this out.


Looks unusual. I’ll report it. Many thanks.

// bug 2214

Ok thank you.

Can you tell me, will I get a notification as to the results of their findings?

The reason I ask is that I have not been able to run a full scan on my computer for over a year because Comodo will hang during the scan on different files but the result is the same… I’ll have to End Task and restart Comodo.


Sure. I’ll inform you when it’s fixed.
Thanks again.

It’s been several more months now and over a year and a half since I first reported this to them and this problem still exists. I haven’t been able to do a full scan in two years. Is there any way to get someone to actually fix this?

You can try posting your bug in the required format so the devs can have all the relevant information to fix the bug.

I understand your frustration and I, personally, mentioned your issue in a discussion (in the past). They’re probably still working on it. Additional information is not needed. Nothing new. Sorry. :slight_smile:

Here’s a workaround:

  1. Disable decompression of archives under Advanced Settings > Antivirus > Realtime Scan.
  2. Disable decompression from scans (Full Scan, Quick Scan) under Advanced Settings > Antivirus > Scans > Edit > Options.

I tried scanning the installer from Downloads - sigrok and it finished the scan without hanging or causing high CPU. Can you check with Comodo Internet Security v10.0.1.6294?

not fixed for sample provided by OP.

Hi guys. Really appreciate you all looking into this. Just wondering if you knew if this got fixed in this new version Comodo Internet Security v10.0.2.6396
Thought I might uninstall and reinstall the new version or just wait for the update to come along but I was curious to see if you all had heard anything about it yet.
Anyway, thanks for helping.

I haven’t checked recently but it may be fixed when scanning a newer version of Pulseview installer but I don’t think it is fixed with the one you provided.

Oh, ok. Well the problem here is that I have other files that cause this same behavior with the file scan and I just used this one as an example since it was a ‘public’ file. So, I suppose there is probably something intrinsically wrong with the scan that is causing this. Hope they can find it and fix it.


Does anyone know if the devs have looked into this problem yet? I have the latest version of Comodo installed and still having the same issue here. All 4 cores lock up at 100%.

Wondering if they just haven’t got around to it yet or if they simply can’t figure it out. It’s been a couple of years since this first showed up here and I haven’t been able to do a full scan in that time. Just waiting patiently but it appears I may be a bit naïve in my expectations.

Seems odd that Comodo can’t scan a file. Curious that they wouldn’t be all over this. Not a word about it… sure would like a reply from them on this issue.


They are going to update the AV engine in an upcoming release so it might get fixed along with other similar issues when scanning certain files.

Sorry, I know this an old post but I’ve been patiently waiting for a resolution.

Can anyone confirm if this problem is fixed in Comodo 11?

I was going to download it and try it myself but I’ve read (here) that there are ‘issues’ with 11 and I don’t really want to make a bad situation worse.


Hi Etek253,

Sorry for the delay. We will prioritize to fix this issue soon.

I was going to download it and try it myself but I've read (here) that there are 'issues' with 11 and I don't really want to make a bad situation worse.
We are going to release fix build for some other issues. We will let you know once fix is available. Please try and provide feedback.

Thanks for understanding.

Kind Regards,

Does anyone know if this has been fixed yet?

Well, it’s been a couple of years now and at version this problem still has not been fixed.

I haven’t been able to do a full scan in over two years.

Is this ever going to get any attention and get fixed?