CFP won't start minimized[Double entries RUN Key] [Merged Threads]

Hi all,

After the last update the behavior of the Comodo firewall window changed. Now each time i start up windows i see the Comodo window opened on my main desktop. Previously it was never the case, pc started up as it should - silent with clean desktop.

Is it a proper behavior? How to get rid of it? It is not a big problem, but mildly irritating that I have to close this window after each startup.

Diagnostics tool did not find any problem with installation, and i did not change any startup options lately.

Thanks in advance!

Hi spad, welcome to the forums.

It’s the “-h” option on the CFP.EXE registry startup entry that starts CFP silently & minimised (works on shortcuts as well). The easiest way to reset this entry is to open CFP - Miscellaneous - Settings - General and uncheck “Automatically start the application with Windows (Recommended)” & then hit Apply. This will remove the registry startup entry. Then go back, check the entry “Automatically start the application with Windows (Recommended)” & hit Apply again. This will create the registry startup entry for CFP (with the “-h” option).

Thanks a lot, will try by the next boot!

Just wondering what might have taken that option away, since I did not change my registry. Will scan for spyware & viruses… or could it be the Comodo itself?

no it is just COMODO it self, if you do what kail is saying than your problem is solved…I do not think this is a problem of malware or something… but scanning for spyware is never a bad idea I guess…

anyway, Have a nice day!



Like triple x said, it’s caused by the application itself, and not malware. No sane malware writer would make the malware show a security application’s window on startup.
So don’t worry about being infected; you’re most likely not. But it’s always a good idea to scan your PC around once a month or so.


Caused by CFP itself? Are you sure guys? I’m not. But, I do agree that nothing hostile (virus, malware, etc…) would do it either.

Well I am sure it is cfp itself, why?..well…I have experienced it myself very often…

Because the only function in CFP that touches the startup registry entry either removes or adds it (as above). CFP doesn’t have any apparent function to manipulate the options on the startup entry & it doesn’t write/rewrite the entry on a regular basis either. So, what Rag said about malware writers, above, equally applies to CFP… why would CFP be coded to do anything like that?

well you never know what users do on their machines and how that will efect that particular piece in the registry of cfp, however indeed it does not makes sense why the developers of cfp will code writing/rewritng that function…but it does happen as you can see in this thread above… Your and my answers will only make 100% sense if we understand and saw the whole code of cfp…which we can not because it is protected and not open source… I think that the registry is verry easy to manipulate by other programs/user interaction and in some way or an other it could effect that particular piece of the registry that shows the start up screen…

as you have said, to make it appear and disappear it is just this: checking/unchecking the option of automatic start up with windows… so that is how easy the registry can be effected…

This is just how I see the things…no problem if you disagree here… I just think it is the firewall itself… that’s all

have a nice day!


I never disputed that it happens, it most obviously does. What I disputed/queried is what the cause is. Nothing wrong with a bit of reasoned inquiry now & again. :slight_smile:

Of course Comodo is supposed to run at startup - it’s a firewall, you want it to be always running.

However, for the last week or so something strange has been happening - now Comodo’s user interface is also automatically displayed on Windows startup.

Does anyone have any idea why, and how I can stop it?

Welcome the forum Vectorspace :slight_smile:
Sorry this problem has occured a few times in the past three I think with no cure you can check your registry (in RUN) it should look like this “C:\Program Files\COMODO\COMODO Internet Security\cfp.exe” -h
EDIT Please check for two entries for Comodo in RUN if there are delete one keep the one same as above if you CIS installed

That’s what I’ve got.
Oh well, it’s only a minor annoyance.

Perhaps reinstalling will help.

Hi all,

My firewall was automatically updated this week and I’ve been having an issue at startup ever since.

Basically, the program won’t start minimised to tray and I can find nothing in my settings that allows to set the program to start minimised.

It used to before the update and I would like it to do so again. Is there anything I can do to achieve what I want?

Many thanks,


Welcome to the forum SM :slight_smile:
Sorry you have this problem it seems to occur occasionally.
Please read this Topic
Thank you


I updated from to 3.5.54375.427 (by letting Comodo to download an update and install it). I rebooted PC after a installation and Comodo was flashing a password prompt and then died (I send 1st .dmp to comodo support). This happened also on 2nd reboot. Anyway this did not happen anymore on 3rd reboot and Comodo starts up, BUT now there is left Comodo Firewall popup open and I need to manually minimize it. Earlier Comodo started silently on background.

Anyway else having this same “cosmetic” problem?

(:m*) Hi all, I merged some threads and posts into this topic as you have the same trouble.


Ok - I have the plain firewall rather than CIS.

My registry is set yo:-

C:\Program Files\Comodo

What do I need to change it to to try and resolve this issue?


Have had the same problem ( not the password ), I uninstalled 3.5.54375.427, and downloaded latest version from Filehippo, on installation,I have version which needed updating to 3.5.54375.427. Now i’m back to square 1 with the Gui showing at boot.I notice the latest version download from Comodo site is Is there a link where I can download 3.5.54375.427, or have i gone mad.Many thanks