CFP.exe CPU: intermittent high consumption [Issue: #254 - WF]

As there is no bug reports topic for version 5.0.162636.1135 I’ve decided to post here. Mods please move this to the proper thread when it is finally created, please.

So, as the subject of this topic says cfp.exe consumes too much CPU resources (up to 32%) for no particular reason. The spikes are intermittent (they last a few seconds) and usually occur when browsing the internet and launchng applications. I didn’t experience this issue in any other version of CIS (4.x that is). I would keep quiet if it was a puny Intel Atom, but I’m on a Q6600[at]3.0Ghz for Christ’s sake!

I’ve reported this issue twice already, but have not received any interest from the devs (at least none that I’m aware of) which is a bit weird especially because I offered help in troubleshooting this bug.

My system specifications:
Win Vista Home Premium 64bit SP2

Comodo Firewall (Win Firewall is off), Avast free av, sandboxie free, mbam free

Proactive configuration (installed on top of ver. 4.1)

Firewall settings:
Safe Mode, block all incoming connections and make my ports stealth for everyone, this computer is an internet connection gateway unticked, protect arp cache, block gratuitous arp frames, block fragmented IP datagrams, do protocol analysis

D+ settings:
Clean PC Mode, the rest is standard

FYI this probably isn’t a conflict between Comodo and avast’s shields because even with them disabled the problem didn’t go away.

BTW: Is it normal for cfp.exe to use about 30MB of RAM? ???


Hello, i have the same issue, cfp.exe consumes too much CP ressources (betwen 50-60%). As you the spikes are intermittend and occur when browsing the internet.
I didn’t see this issue in the former version of CIS (version 4.1). I have a Pentium 4 E5300 dual core at 2.6 GHZ

My OS is windows 7 home premium edition 64 bit. I have comodo firewall and avast free

Also, the consuiming of ram increase till about 20MB.

Thanks for the answers.

I’ve got the same problem with FF and Thunderbird.
My OS is Win 7 Ultimate x64.
I use COMODO firewall, AVAST 5 Pro and Spywareblaster. No other security apps.
My system is:
Asus PQ5-SE Plus, Intel E8400, 8 GB of RAM and NVIDIA GeForce GTS 250.

CFW settings:
Sandbox disabled
FW and D+ in learning mode.

[attachment deleted by admin]

I updated FF to new version 3.6.10, reinstalled CFW and now seems is all happily ok.

Silent Assassin. You mentioned you installed v5 on top of v4.1. I assume the installer first uninstalled 4.1. Is that correct?

Can you see what happens when you disable block fragmented IP datagrams and do protocol analysis one by one?

I add that when i have installed comodo v5, i don’t desinstalled before the V4.1 I have installed version 5 on tof of v4.1.

Could be it the cause of this ?

I add two screens of the CPU’s consumming.

I must point out the configuration of Comodo firewall :

Proactive configuration

Firewall settings : safe mode, creating rules for safes applications, block all incoming connections and make my ports stealth for everyone, this computer is an internet connection gateway unticked, block fragmented IP datagrams

D+ settings : safe mode, creating rules for safes applications, sandbox activated.


[attachment deleted by admin]

It is always better to uninstall the previous version and do a clean install with the new version :slight_smile:

I did a clean install two timesd, and the problem persists.
Uninstalled again.

That’s exactly what happened, yes.

It doesn’t make any difference :-[.


I noticed when you install CFW with the last option, i mean the best proactive prot. there are no problems with CPU usage.

That’s interesting :P. This is the very option I opted for during installation ;D.

I am suffering from the same problem in this new v5 version so I will post some info about my setup.

[b]Your set-up

  1. CIS version & configuration used:[/b]

CIS x32 5.0.162636.1135
Firewall and D+ installed

2. Whether you imported a configuration, if so from what version:

Uninstalled previous version and made new configuration.

3. Defense+ and Sandbox OR Firewall security level:

Defense+ training mode
Firewall Safe mode

4. OS version, service pack, no of bits, UAC setting, & account type:

Windows XP Pro SP3 32 bit, Administrator account

5. Other security and utility software running:

Avast, Sandboxie

6. CIS AV database version:

Cfp.exe seems to do lots of disk access on my pc (hdd led is on) when the CPU usage pops up. Seems to happen when I browse internet with Firefox inside Sandboxie.

I checked the disk/registry accesses with Process Monitor during one peak and cfp.exe seems to have lots of accesses to C:\Windows\system32\msctf.dll with operation type CreateFileMapping and result “ACCESS DENIED”
Maybe there is something wrong with access rights? (I do use administrator account though)

I put a zipped copy of the Process Monitor log file to my server at Free Hosting - Domain Does Not Exist in case there is something useful to you. Amazing that I logged only for under a minute and the log file was 31.9MB already…

To devs: forwarded as at least one user has given information in the requested format (this post predated the new format). There’s also a procmon file which should be very useful.

Best wishes


Forgot to say that I’m using 32-bit OS. Also CIS version should propably read “32-bit” instead of “x32” :slight_smile:
I guess there is no edit button anywhere or I need to get glasses.

OK fixed x32 is OK

No editing by users allowed once transferred here. It could confuse the devs if major!

Best wishes


I’m running Windows 7 x64
I had an older version running, and it has never given me problems and I installed the latest one, version 5

Now when I’m browsing the net, using firefox, CFP.exe uses about 25%of my CPU. this is really annoying

Serg, I’m attaching the configuration file you asked me for.

Best regards

[attachment deleted by admin]

I’m Running XP Pro just upgraded to version 5.0.163262 and quite often cfp.exe jumps to 97% of CPU, and for about 2 mnutes I can do nothing but look at the monitor. >:(

robertjvan and N3G4T1v3 please, if you don’t want to get any physical abuse ( ;D) from the mods please stick to the correct bug reporting format which you can find here: Comodo Forum


Lo and behold! This issue is still here in the latest CF 5.3.174622.1216.

The bug/issue
Whenever I open a new website or refresh an existing one (doesn’t matter whether in opera or firefox) the cfp.exe cpu usage will gradually increase up to about 40% and hover at that level for a while and then drop to 0%. Those spikes are accompanied by an increase in RAM usage by cfp.exe as well.

Your set-up

  1. CIS version, AV database version & configuration used: Firewall only (5.3.174622.1216), proactive configuration

  2. a) Have you updated (without uninstall) from CIS 3 or 4: no, clean installation

    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: -

  3. a) Have you imported a config from a previous version of CIS: no

    b) if so, have U tried a standard config (without losing settings - if not please do)?: -

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Yes. Here they are:

Stealth ports wizard - the 2nd option (alert me bla bla)
Safe mode
Create rules for safe applications ticked
This computer is an internet connection gateway unticked
First 4 boxes in the “Advanced” tab ticked

Clean PC mode
Enable adaptive mode … ticked
Create rules for safe applications ticked

The rest is default (including sandbox settings).

  1. OS version, service pack, number of bits, UAC setting, & account type: Vista Home Premium SP2 64bit (fully patched), admin account with UAC enaled

  2. Other security and utility software installed: avast free av, MBAM free, Hitman Pro free, sandboxie free

  3. Virtual machine used (Please do NOT use Virtual box): none