CFP/CIS stores configuration in registry (V=3.5.53896.424; X32)

CFP D+ uses up about 50% of CPU after allowing a program’s action for around 10 seconds. Also, the program that is allowed hangs for around 10 5 seconds too.
In case you didn’t understand me, here is an example:

I am running VMware WorkStation for the first time. It wants to make a new directory. A CFP D+ alert pops up, and I allow the action. VMware hangs for about 10 now 5 seconds, and for 10 5 seconds “cfp.exe” uses up 50% of CPU.

I’m running Windows Vista Home Premium, X32.

Edit: I upgraded, current v.: 3.5.53896.424

2nd Edit: changed title to “CFP/CIS stores configuration in registry

Do you have a dual-code CPU? That would mean one core 100%

Yes I do. I guess it means one core 100%, but since Task Manager said 50% I just put that much.

You can set up Task Manager to show each core individually. Then you will see one core fully loaded I suspect.


Well, are any devs viewing this topic?

Probably not.

Upgrade to 3.5. If the problem persists, Dev will surely be interested.

Follow up:

After uninstalling CPF & installing CIS Firewall only, the everything is still the same except now it only hangs & uses lots of CPU for 5 seconds. Better, but still not as good as I like.

Current FW Version: 3.5.53896.424

Did you uninstall CFP in Safe Mode? If not, try that. What other security software are you using?

I always get an error while installing something in Safe Mood…

Your system is obviously not in good shape. I bet with a fresh Windows install you wouldn’t get those errors.

I know, planning on doing once I get an external HD. Everything seems messed up. Just a few example:

  • Even though I have it set to open in the same window (in “Folder Options”), Windows Explorer opens a new window every time a double-click on a folder
  • It always seems like the first time I install something, it doesn’t work right.
  • I can’t access certain folders I used to be able to access, and I can’t open the “Screensaver” option window.
  • Plus a lot more that I forgot right now.

So as you can see, I reformat will help some. :wink: I may even try vLiting it… ;D

this is a recurring bug that wasn’t fixed yet …
the wait time seems to increase as the program database (defence+ rules) gets larger. For me it’s around 5s or so and it’s only when we LEARN something (remember action). This happened in last CFP version and does also happen in the newest CIS version. Has nothing to do with OS since XP and Vista 32 give the same result for me.

I did a post about it a while back but i guess no one cared that much about the problem. Maybe DEV’s will take a look at it soon.

Cheers :Beer

Thant’s one long standing problem, e.g.
Basically, every time you add a D+ rule, the whole rules database in the registry is deleted and rewritten from scratch

Oh dear…and it might take long as I get more things in my safe/blocked Database… :’(

Yes, old annoying bug, that would require complete rewrite of the part that handles settings and a completely different settings structure to get it fixed (and I would like them to switch from registry to some custom database anyway, I really don’t like a 2MB key (yes, it’s that big and before I installed CIS from scratch, my previous CFP key was 3.7MB big) bloating my registry, much less if it’s constantly rewritten each time a rule is created/modified). If they didn’t rewrite it when switching from CFP to CIS I don’t expect a fix anytime soon as it would completely break backward compatibility. And 5 seconds is nothing, there are some users that experience a 20+ seconds lags. And the best part comes if you reach some threshold size and get a D+ popup on system shutdown, the result is a full/partial loss of rules, as there is not enough time to delete/rewrite all settings before the system halts.

I’d suggest changing the topic of this thread to “CFP/CIS stores configuration in registry” or similar. This is a huge design flaw and causes delays for anyone after couple days of usage. Additionally, it horribly bloats the registry, in effect slowing down lots of other stuff. The exported registry key has 2.5MB after a week of usage on a freshly installed box.

:-TD >:(

I guess they could use for example sqlite (like Firefox does) to store that info and then password protect it or something so that only the program can change it. That can’t be hard to do. This is the only thing that is stopping CPF/CIS from the 100% mark. (:KWL)

Cheers to the devs :Beer

I just found out about that behaviour when I chose to freshly install CIS.
This is a big problem and I’m definitely not looking forward to D+ becoming again as slow as it was. Waiting several seconds after the alert box is inacceptable for me!

Well, thanks for changing the subject but this really doesn’t belong to wishlist, this is a bug which causes lots of issues.

Dev’s are aware of this issue. It’s on their list but at the moment AV and bug fixing get prio.
And Defense+ works as it should, it’s just making your pc almost unusable, i have the same experience.

You can “workaround” this, by cleaning up your Defense+ rules, start all over again, and use the “Trusted Application” a lot more on programs you already know are safe to use. This will help out a lot. Stay away as much as you can from the all Custom rules, that will slow you down bigtime. Sorry guy’s but that’s the only way at the moment.

Until they fix it, it’s still a design issue.

One thing we could do is tell Dev’s how many rules we have for Defense+ if there are enough users with a lot of rules maybe they can get it higher on the list.

So post your numbers from: HKLM\System\Software\Comodo\Firewall Pro\Configurations\

Now for the number 0 = Internet Security, 1 = ProActive, 2 Antivirus, 3 Firewall, 4,5 etc are imported settings.


Mine has 234 entries on the policy now, and i have all running Custom.