cfp does NOT log anything

I use cfp cfp, winxp sp2, czech version.
I have logging enabled on several rules, both application and global level of security. but nothing appears in firewall event log. Nothing.
I have logging enabled in settings, both for firewall and d+.
Although the summary screen shows hundreds of “intrusions” (logged rules which are fired), none of them appears in log event.
This happened to me in several previous verisons (maybe 2 of them, not sure), before it worked, but I don’t remember the last build it worked in. I was doing updates though automatic updates mechanism, though I run those updates manually. You probably can identify for how long I have been using this installation - as long as reinstall was not needed.
I tried disabling and enabling logging on global level several times, tried diagnostics, but neither helped.

Diagnostics says everything is ok.

Yesterday I reinstalled cfp from scratch to latest version (.329) but the bug remains there.

I don’t use any antivirus, I have clamwin installed just of curiosity and I ocasionally install eset’s NOD to check that I’m clean, and I am.
The I use spybot 1.5.2 and spywareblaster 4.0, I clean my comp regularly (let’s say once a week) with ccleaner.

Since this is happening over some time and several verisons, different settings, I consider this a bug, that’s why I put it here.


any help apreciated.


Please verify log settings (miscellaneous/settings/logging): log size is not 0 mb, options “disable… logging” are not checked.

Another thing to try is clearing the current log in CFP log viewer.
If this does’t work please post a cfp report

this problem was already identified here
with no answer from developers. Just hoping that they put this on schedule with next bux fixies.


P.S. No proste to neumi cesky znaky nekde od verze 3.0.14
Bohuzel log je ulozeny na ceste kde jsou ceske znaky.

I don’t have logging disabled and my log size is set to 2 megs.

I cleared all logs using log viewer, didn’t help.

jerry18 says, that’s because there are non english characters (because of czech windows)in the path to that log file and since cca 3.0.14 it is broken.

to je ovsem pekne na hovno… snad s tim neco udelaji

please test this.
find Documents and Settings\All Users\Data aplikací\Comodo\Firewall Pro\cfplogdb.sdb an open it manually using cfplogvw.exe
if it still empty copy cfplogdb.sdb on c:\ an open it from there.

Hi gibran,
I’ve been this road already (;msg145905#msg145905)
but you seems to missed it. Anyway, I can confirm that even if log file is direclty load using logvwr.exe it seems empty when it is in derectory with czech specific characters. Once path is changed to some non-czech specific letter, it start working. I even manage to find workaround for complete logging. Please read my post (the url above).

Best regards

The sad thing is I have no such file on my comp…

Clean instal is unable to create such file because of czech specific etter in path . I had on one of my computers old one from version which was logging correctly.

Thanks Jerry for the link to that post. I didn’t bother to read the entire topic.
Thanks foxx for taking that test it was useful too.

Since I had no prior knowledge how cfp logging worked I needed a step to step suite of tests to sort out the different possibilities.

As it looks like that CFP.EXE write the log Jerry filemon log of cfp activity was right on the mark.
So the reason foxx cannot find cfplogdb.sdb anywhere is that cfp attempt to write the log in an invalid(non existing) path.
cfplogvw.exe looks for a wrong path too.

So the workaround for Xp czech users is to create a folder named Data aplikac in %ALLUSERSPROFILE% directory.

[ at ] foxx. Does CFP GUI hang on your pc too when you open cfp view firewall events when the log cannot be written?
[ at ] Jerry Does CFP GUI hangs when you open cfp view firewall events when the log cannot be written if you disable D+ and firewall logging in Miscellaneous\Settings\Logging?

BTW please check Documents and Settings\All Users\Data aplikací\Comodo and report if there are any missing files.

You need to run the cmd command and type

cd Data aplikací
cd comodo
dir /s >c:\output.txt

You should find a file named output.txt in the root of c:

here’s content of that output file.
sorry, that it’s in czech, but I think it is readable

I created that “Data aplikac” folder in “all users” and copied comodo subfolder there, after restarting comodo, file cfplogdb.sdb appeared there, but when I click on event log in CFP, it hangs. Before that it hanged rather randomly (but often when actions were related to log viewer).

Edit by mod: attached dir output as txt file

[attachment deleted by admin]

Accordindg to the info provided by Jerry the full path to the log db should be

\Documents and Settings\All Users\Data aplikac\Comodo\Firewall Pro\cfplogdb.sdb

According to the dir output you provided the folder structure in Documents and Settings\All Users\Data aplikací\Comodo\ for the non-log parts it’s ok

so you only need to create a folder structure to hold the log db.

If the log still doesn’t work please try cfplogvw.exe.
If the external log viewer cannot manage to find the db you can open it manually (file\open)

In order to minimize the Gui hang issue you can try to disable D+ and firewall logging in Miscellaneous\Settings\Logging.
I guess those hangs hare caused by cfp gui trying to repeatedly write in the wrong path.

I’ll try to get in touch with the devs. Please wait until they fix this issue.

It just happened to me, that opening event log showed me few of that logs… :slight_smile:
but next time I checked it, it hanged again :frowning:

in my case, when i open the log viewer of comodo i can see logs of firewall and defense+ so i can’t say it doesnt work.

well, whe I open it with externaly run log viewer, it shows some logs, although very little.
When I run event log form inside CFP, it hangs every time since I created that “Data aplikac” folder and correspondent subfolders…

Hello Gibran,
I tried what you want and when logging is disabled (+restart) CFP does not hangs while opening eventviewer

Just a question, CFP worked just fine until some version change someting. I can’t remember but doesn’t one version introduced Unicode support? Would be my first guess to look at.

Best regards

Good morning to all!
I hope theese conclusions will help devs to remove this nasty bug, which makes otherwise great firewall little clumsy.

I’m crossing my fingers.

EDIT: I have to confirm what jerry said. When I disabled logging for D+ and firewall in settings, that event log now doesn’t hang whole gui, and now it shows 2! entries (which where created earlier).

IIRC CFP supports utf-8 since beta. I was not able to find mention to unicode in the release notes.

I don’t know what cause this issue. But as you suggested this could be caused by a codepage issue.
Your codepage should be Windows-1250 whereas the english language supported by default pertains to Windows-1252.

I guess devs are currently focused on V3.0.22 beta so I don’t know if they’ll fix this issue in the next release.
Anyway I would be happy to be proven wrong.

Edit:looking for that í character I found out that it has the same code in windows 1250 and 1252. The code is 237. This means that even if there was a codepage conversion issue that í character was not going to be affected

I’m also not realyl sure which version introduced this bug.
I’ve been doing those updates often, since there where many of them, but I’d say it’s there for cca 4-5 last builds…