CFP RC1- Questions about how it works

Post here your questions about V3 configuration issues and settings explanations.
Please change the subject to describe your post.

Finally got RC1 firewall working after a few reinstalls-had to select the option of doing everything myself, instead of letting Comodo do it to get it to work. Noticed one major change from 3.0.10-Comodo no longer recognizes proxies, which it did previously. I use Stunnel to access email, so that neither Thunderbird or Popman see any IP but . Neither shows up on Network Security Policy list now, although stunnel still does. Don’t know whether this is a bug or just a change in philosophy-different firewalls (Kerio, Sygate, …) have handled it both ways in the past.

I am not having any problems. Diagnostics finds no problems. But at RC status to still have no configuration screens of any kind whatsoever offered at install canNOT be a good thing. I.E., ‘BAM!’, it is installed and you are on your own config-wise. Any ideas anyone?

Can Ver.3 RC1 Firewall only run with System Safety Monitor?

Try uninstalling and reinstalling. I got lots of reconfiguration screens, one of which killed the firewall (apparently) if I selected the option for Comodo to manage things. Vista Ultimate, upgrading from 3.0.10. >:(

You should disable Defense+ (V3 hips) in order to use System Safety Monitor

Maybe V3 does not catch these apps if they start before CFP. Close them and restart these apps. Make them generate some traffic. If there is no alert you should try to uninstall from safe mode or throubleshhot possible conflict with other security apps.

Does the installer warn you when SSM is installed like it does when Process Guard is installed?

It might be of interest to some of us to know what applications the installer currently has on its list that it considers incompatible.


Thunderbird generates a normal network firewall rule response in 3.0.11 if I access the internet directly (a pop3 server, port 995, for example). If I go through the Avast! transparent proxy and Stunnel (, port 12111 which is virus checked by Avast! after Stunnel sets up the connection to pop3 server, port 995) Comodo no longer recognizes it as an internet request. It did on 3.0.10. And different firewalls in the past have had different policies for proxies-Sygate was famous for this proxy hole, for example. I have closed and restarted a number of times, and get the same behavior with mail monitoring programs like PopMan, Mailwasher Pro. And I do get the “Defense+ is learning” messages. For PopMan D+, for example, only “loopback networking” access rights are allowed, which is correct (others marked ask); just surprised that the firewall no longer deals with it. An RC is much too late to need to uninstall via safe mode-will wait to see what the next RC brings. 3.0.10 (where proxies were handled correctly) is the only previous Comodo version that has been installed.

On installation it does balk about SSM. I only installed the firewall,but it still has a problem.

A firewall is currently installed on this computer. Two or more firewalls installed together can conflict with each other.

[ol]- McAfee Personal Firewall Plus 7.1.113

  • Norton Personal Firewall
  • Outpost Firewall Pro 6.0.2162.8224
  • Trend Micro PC-cillin Internet Security 15.20.1151 (Firewall)
  • Sunbelt Personal Firewall 4.5.916.0
  • Sygate Personal Firewall 5.6
  • Tiny Desktop Firewall 6.5.92
  • Trend Micro Internet Security
  • Zone Alarm 7.0.408.000[/ol]

Another product which can conflict with Defense+ is installed on this computer. Install COMODO Firewall Pro as a ‘Basic Firewall’

[ol]- Process Guard 3.150

  • Pro Security 1.30
  • System Safe Monitor
  • Dynamic Security Agent[/ol]

I installed the basic firewall and still it won’t work.

Please develop the issue or file a bugreport complliant with the bugreporting requirements.

I have a question based on my firewall log. There are weird entries as it shows on the picture i attached. I’m behind a NAT/Router with no port forwards and UPNP is disabled. Why CPF RC1 blocks inbound connections? i haven’t forwarded these ports…

[attachment deleted by admin]

Actually there is an issue with logging. V3 log also RST packets (usually sent when an external host attempt to terminate a connection)
The issue would be if that RST is actually blocked or not.

When i uninstalled previous beta which worked good btw, and installed this Rc1 i allowed my defence+ to operate in Clean pc mode. But instead of making rules by it self like it normally does i was swamped with alerts for any program, it hasn’t made one rule by it self. Sorry if i have put this problem in the wrong area :THNK

Maybe you should try to uninstall V3 from safe mode and then look for any leftovers searching for any file/folder called comodo.
If this still doesn’t work you should submit a bugreport adding all infos requested in that topic.

Thanks gibran for the reply but i did try reinstalling, on reinstalling the 2nd time it did seem to be working but for what ever reason it stopped and back to the 100’s of popups. i wouldn’t mind knowing what i need to do to send a bug report as i haven’t really had much to do with beta’s previously.

All the relevant requirement are listed in those threads:

In order to provide enough informations to fix bugs please include those infos in your posts
Please submit one bug per post and change the subject to describe your post.

1. Computer information
2. Operating System information
3. Actively-running security and utility applications
4. Specific symptoms of the bug, and steps you can take to reproduce it.
5. Specific steps you have taken to try to resolve it.
6. If you pc reboots or you have a BSOD read How submit a BSOD bugreport for additional requirements.

Actively-running security and utility applications is one important requirement.
If someting unespected occurs it should be likely due to a conflict with V3.
So it is importaqnt to list Antivirus, antispywares, Hips and such in your post.
Another useful info is a GMER report (only for 32bit OS) to attach to your bugreport.

I have gotten it working now. :BNC