CFP Alpha Bug Reports (XP) [Closed]

Just some other info. I have set all Avast components to trusted applications as well as allowing all network access. I have also tried uninstalling both Avast and CPF then reinstalling them both in different orders with no difference.

I have noticed after first boot, Firefox and IE can access web pages. After they have been closed, then reopened, I loose all webb access on these 2 applications.

Turning off web shield, gives me full access.

I can’t check Email with Outlook Express and also I can’t connect to the Internet with IE.
Although I have Defense+ and Firewall set to allow all.
I also tried posting here with Opera, but when I click on Post, I get an error saying I have no Internet connection, although browsing is working.

Exiting CPF didn’t work either. I had to kill cmdagent with taskmanager.
Now IE and Outlook Express are working again.

I’m using Avast, too.

Another thing mentioned before: The IPs in Eventlog are mixed up. They are mirrored.

I wait for the final release or at leased the beta and meanwhile I stick to the 2.4.


Mrm1, and when you configure the WebShield HTTP proxy?

Greetz, Red.

OK, if i open a program from a shortcut on my desktop (Gimp, Packetyzer, any program…) that is not listed in the Apps section and I use the radio button to select “Trusted Application” then I get an error popup say that the application is not a valid Win32 application.

It doesn’t crash anything or freeze but just doesn’t open the program.

I can do the same thing immediately after the error popup and allow whatever it is asking to do, just not select “Trusted Application”, on the first prompt and when it pops up another popup it will allow you to select “Trusted Application” without any further errors. It will then run just fine and allow you to rerun the program without further prompts.

Maybe this is by design so that you have to allow it first before it can be trusted? If that is the case then the combo box shouldn’t offer that on first time startup.


IE and Firefox can’t not connect to internet …(i selected “allow all” ,but it still can’t connect internet) … (:AGY)

PTW:I’m using Avast 4.7 HOME ,BUT Avast can download the update files…

I concur. The “More” button opens the FW logs, but there’s nothing for D+ (and there have been events; at least what I would call events - it gave alerts).

For D+ alerts, the “treat application as trusted” (along with Remember) does not appear to have any effect. It not only does not treat it as Trusted, it doesn’t even allow that even to go through; the same alert continues to appear until the regular “Allow” (with or without Remember) is used.

The D+ protection almost seems a little over-the-top, even on the default levels (meaning, Learn Safe, and EXE only); almost as if the safelist is not being used. Just to print a PDF file in Foxit Reader (opened from within Outlook) there were more than 12 alerts, including combinations of Outlook, ctfmon, foxit reader, and various HP executables. Surely foxit reader is popular enough to be included in the list… and I should hope that both Outlook and ctfmon are (but I got combo alerts on those as well). I also had a number of alerts for Firefox and various Windows apps (such as Outlook, explorer, ctfmon, etc)… is FF not on the safelist? Or is the safelist not on? I have found no setting (as in 2.4 or earlier) to utilize safelist or not.

I left for about 10 minutes; when I came back and logged in (locked terminal), the desktop would not open; it completely froze with nothing but the background showing. I had to hard reboot with power button. It may be because I had decided to use the “executables” group for D+, and something had occurred with that to jam things up. (oh my, talk about a lot of popups; I swear it took five minutes to open Outlook and check mail, with all those!). I removed that grouping, and set the D+ level to Learn All, as I am confident in the cleanliness of the system.

Oh, and all popups have no info or suggestions available as to the security risks of any of the applications; I’m thinking this is a known thing because of an early Alpha release. Perhaps tied in with safelist issues?

On the other side, the IPs shown in connections and logs appear fine; no reversals or mirrors. Install went fine, no problems there. It’s sure jam-packed with stuff; I’ll be glad when it’s all actually in there. The graphics/layout is nice, but on a personal note, the popups remind me of a combo of Zone Alarm and CyberHawk in their appearance (largely because of the orange, I think).


Yes, I get this too.

Defense+'s event logs? I can only see the Log via the More button… But, I do have Defense+ Logs… yes. The More-Logs screen has both in a tree structure. It might not be immediately apparent.

well, I tried this version of comodo and I couldn’t even get to the desktop. I ended up having to remove it from startup and then remove it. Might have to wait a little to see when the next version comes out.

Good job I love it so far lol. Windows hangs on startup and I ran Shields UP!! and port 445 was open. I did add a global rule so I will not run into port problems with games and p2p apps. Source, Destination Address is set to any, Source Port is set to any, Destination Port is set to A Port Range 1-65535. Also on the the port range if you let Comodo enter in 65,535 it will revert to 65, you have to enter the number without the comma. I looked at the firewall events right after I ran Shields UP!! and there was no events listed.

Ev’rytime when I try to acces the internet (ie7) true the startmenu then the Comodo Defense & Alert is poping up with the message “CursorXP.exe is trying to acces ctfmon.exe in memory” what would you like to do, before I can give say allow and remember the answer, the cursor is locking up so I can anly use my keyboard in a very limited way, an restart from the system is nessacerry then, is this situation known by other users and yes what is the solution.
Please forgive my poor english.

Regards, Browny

It seems there’s a good bit wrong so far. I wonder if the release date was so expected and debated that the developers felt they just had to get something out today. Perhaps they would have preferred to wait a couple of weeks ideally. Maybe release dates shouldn’t be given at all. Just keep saying it’ll be ready when it’s ready.

Browny, try this for a solution. As soon as you get into Windows, open CFP, go to Defense +, Advanced settings.

find the entry for CursorXP and open to Edit.
Go to Access Rights (red underlined text)
Find Interprocess Memory Access, and change from “ask” to “allow”
Then Apply on every window to set the change.

Then see what happens.

If that doesn’t work you may have to modify the Protection Settings of ctfmon to Allow interprocess memory modification. Seems to me it would be better perhaps to go the other way first.


OMG! Check CFP 3’s memory size guys. Amazing… mine’s just over 10MB for both processes.

hmm… that must be during peak… wait and see how it drops (well it should :slight_smile: )…


Peak!?! Well… yea, of course… I’ve been playing with the GUI a fair bit… peak… way too 8) for words.


I just had a crash and had to go thru and clean out the registry to be able to reinstall CFP-Alpha. I have attached a .zipped “.dmp” file(no password) if someone wants to see it. The error number on the blue screen was all 0’s (0x000…). The crash happened when I was starting programs from my desktop. Message said" crashrep.exe trying to access cfp.exe".

The firewall closed on it’s own then I had to hard boot it and go into safe mode to get rid of the program in Add/Remove Programs. I then restarted and was able to boot into Windows and clean the registry after it wouldn’t install. Said I had used an old installer. It reinstalled ok and is working without problems again, so far so good.

On this install I have entries in the first log window this time, but all other things I found previously are the same. I also now have entries in the D+ logs.

hope this helps,


[attachment deleted by admin]

So far I have not been able to create any problems Checked all my programs and they open just fine a lot of pop-ups but in an Alpha version and for a training period for the firewall and also myself That’s not a problem

Quite impressive
Only thing to mention so far is when I get the pop-up.
(File XXX) is trying to access a protected file or directory. What would like to do?
I would like to know exacly what File or folder is being accessed. Maybe something like this will confuse new users but for me I would like to know exactly what is being writen where.

My def of protected file is
All SYS, DLL, EXE, and OCX files that ship on the Windows CD are protected. True Type fonts–Micross.ttf, Tahoma.ttf, and Tahomabd.ttf, …are also protected.
Not exactly sure about protected Directory but my guess would be \Windows\System32 if any one kows other protected Directories i would not mind knowing

CFP (V3) Alpha looks good to me if i can break it I will

Opus Dei

Impressive mines running 9096KB we’ll se how it does after I get it loaded down with rules

So far the only change I’ve made to the program defaults is to turn the aleart freq. to high.

I put a password on CPF for a few minutes, but every time I wanted to look at something, including logs, it wanted a password.

I would suggest putting all the configuration settings in a different page and require a password for this. ( maybe if it was possible to get to the logs it would be possible to use this to break in, in this case maybe only require a pasword to open the interface like Symantec Corp AV.

Opus Dei

I have a small display bug. All the large green fonts in the menus are chopped off half way. Only the top half shows. This is with a GeForce Go 7950 GTX display adapter.

I am going to love it when everything gets straightened out. First of all I set up a FirstDefense Test snapshot to check out Ver.3 Alpha. I tried to remove the old Ver. I went to add remove programs and removed. For some reason it caused a problem with Comodo BoClean. When I would try to reboot I would get a pop up saying BOC423.exe didn’t want to shut down. While running the Alpha I would open programs and ok them. When I tried to re-open one of them the system re-booted. So I booted to my Base snapshot and updated my TEST snapshot to bring it back to pre Alpha. I may try again using COMODO uninstall.