CFP Alpha Bug Reports (Vista) [Closed]


pls post your vista related bugs here.

i’m using vista business i noticed when comodo asks for permission to open program, before i approve the request of comodo its already opened.

nice job re: Comodo Firewall Pro for vista…please, don’t screw it with next builds (S)

after installing cfp3.1.a unable to view web sites that require java. the web site returns a message that the web browser (ie7) does not support java. jv16 2007 will not start even though it’s been granted permission. vista hp: dell, e510.

just 2 suggestions: (as it appears that this new thread is not just for bug reporting but for feedback as well)

it would nice to implement ( as I suggested in a new topic of the Beta Corner, but no reply yet…) a Firewall email notification (like there was in Sygate) in case of any serious attack like a port scan etc…

second, less important: could you make it so that minimizing the main software windows does not give a minimized tab in the taskbar, the tray icon is there for restoring it.


I agree! That would be a nice add! And you can make it a option!

hey thanks for the support! :SMLR
that’s right, it could also be made as option, as it is in other programs (password managers, download managers… ).

Vista Business & Comodo 3 alpha. i experience huge lags when i play Warrock, it is a free multiplayer game. there is huge FPS slowdown for a couple of seconds and then the game is normal & then slowdown again & this repeats all the time. so it is not possible to play smoothly. i don’t know if that is because of the Firewall or Def+. i have all ports properly set up. even if i exit the firewall & kill both comodo processes in the task manager, the game still lags. to make sure it is the game, i uninstalled the firewall & now everything is as supposed to be - smooth gameplay.

so far really like the new firewall, keep up the good work.

don’t know if CFP 3.0 alpha really causes the lag,but if you think that’s the case, instead of uninstalling, just launch the task manager and kill the cmdagent process, or disable temporarilly
the comodo firewall service (right-click the “Computer” icon on the desktop, click manage, then “continue” in the UAC dialog box if it’s on, and scroll down the window until you get to services).
I wouldn’t be surprised if the alpha causes a low framerate in games, since it’s got graphic bugs at the moment, and I doubt it’s “Desktop Composition” compliant for now. Some users have already reported stronger fan activity in Vista when using CFP 3.0 alpha…see my post here:,9609.msg70085.html#msg70085

now the other possibility would be a network slow-down caused by the firewall when you play online games. But I doubt it, the firewall either allows the traffic or blocks it. Any kind of analysis the firewall does shouldn’t slow down systems in most cases. Only someone from the dev team could confirm that.

Hi Guys just a couple of things ive noticed…and re posted in the Vista only feed back/Bug reports

CFP 3 Alpha Vista Premium

1 “Treat this application as” is greyed out after two days also posted by Gharkh…

2 Desktop icon and all programmes can’t launch the UI unless i exit the icon in the notification area

3 Noticed an increase in the fan noise after installing CFP 3

4 Sometimes the icon in the notification area auto hides, i haven’t set this to do that

Still can’t believe your offering all this for free…Good work guys and i think the password protect is great especially as it’s a shared pc

Nil Satis Nisi Optimum


I can’t even use it on my Vista system. Whenever I connect to the internet, I get a blue screen. The driver mentioned is ndisuio.sys.

since this is the only one game i play, there is no way to compare with other games. so to be sure i uninstalled Comodo & everything is perfect now. i tried killing cpf.exe & cmdagent.exe, when i play, but i still have this lag. i don’t know what else could be the reason. the game is FREE, so maybe someone can install it & give us feedback.

I have another computer at home running windows vista and when I installed comdod firewall I was not able to connect via remote desktop and I was not able to see the share folders in the computer. I added the computer I was connected from as a trsuted IP address, even added a rule in the firewall to allow all incoming and outgoing traffic for trusted network and to generate an even whenever the rule was trigger, nothing happened, put the rule on top of the rules and at the bottom and the same results.

i’m in the same situation (samba doesn’t work) of you but i can’t set my lan as trusted zone. how did you do that?

Hi Guys
CFP 3 Alpha for some reason while browsing the web the CFP icon in the notification area vanished twice (not hidden) and i needed to click on the desktop icon to restore it which wouldn’t have worked had it been available in the notification area as previously posted…so i don’t know if this is now a Vista problem or a CFP alpha problem…


One thing you might want to look into is your firewall doesn’t play nice with streaming video or music to an Xbox 360. Or any other device for that matter. Is there a way for me to get it to allow this? It doesn’t ever ask me if I want to block it. It just does it automatically. ???

Vista Business 32

I also had my ‘Treat application as’ choices greyed out which turned out to be due to the as-shipped Predefined Security Policies disappearing. I was able to recreate them (by Adding some new ones) but then had to reassign them to the programs again as they had all reverted to very restricted ‘Custom’ policies. (I had a crash which took down CFPro and then various bits of Windows and needed my logging out and back in to carry on working.

View Defense+ Events seems to bring up a window containing Firewall events instead and clicking ‘More…’ definitely brings up the ‘Firewall Logs’ in CFPLogViewer which have to finish displaying before I can choose the Defense+ Logs.

I also seem unable to talk to my local Samba servers now though I was able to create a Network Zone (but that got forgotten too at some point).

Many of the features look like they will be useful.

For those of us who have the issue with Vista not waking from sleep/hibernation, this is in fact due to a windows issue not CFP v3. there is a MS hotfix that will correct this. Not sure why I did not see this until after installing V3… but the hotfix seems to have fixed the issue. This does not apply to just ati graphics. just fyi. MS Article ID: 928135
got from -


I’ve just noticed if uac goes to the protected mode (in my case Power Strip) when a programme etc. needs to and a Comodo window appears needing to be answered then Vista stays in protected mode waiting for the window to be answered.

I found a work aroung by chance as I tried to bring up task manager and bingo I could then get back to the Comodo windows to answer them.

If my guess is right the windows can’t appear in protected mode. Next time I will note what the first window asks. I think it was allowing uac. (yes should have read it better).

DEFENCE+>Avanced>Computer Security Policy

If U drag and drop an event and move(without relese it), up and down on window the bug window report is showed but is impossible use it and a part of system freeze(task manager too). So need to restart system…that’all.

A question: why in DEFENCE+>Common Tasks there are double windows for same event, one not editable and one editable:

My Protected Files<->My file Groups
My Protected Registry<->My Registry Groups

…etc etc…?

Anyway guys…u have made a monster application, a real real real real step on (R)

I had a quick question…I hope I am asking it in the right forum. I installed CFP alpha on my machine running Vista Ultimate x64. It looks like it is running properly and I get the pop-ups for specific applications, etc. When I look in Process Explorer I see the cfp.exe but no cmdagent.exe…should that be present? If so, should I uninstall and reinstall? Thanks