CD Crashes when opening any page


I updated to Windows 8.1 and initial all was fine. Until I rebooted again and tried to start start CD.
I have several tabs pinned and CD crashes when trying to display those pages.

When I disable (or even remove) all the extensions, it still crashes when trying to open any page.
I followed the steps to create a new profile, but it still crashes when loading any page. I see a new ‘Default’ folder in my UserData.

Reinstalling CD did not fix the problem

Please help. I do not want to use another browser

Hi Comm512,
When you say CD crashes, do you receive any error messages?

You could see if the problem persists with the portable version, this is independent from the installed version.
Portable Version



CD standard opens the yahoo page. It also tries in my case
1 second after startup, I see that CD loads the yahoo page and then closes
1 second later I get an alert with ‘Whoa! Comodo Dragon has crashed. Relaunch now?’
When I try that, it just crashes again.

Also running as admin does not fix the error
I also run CIS and I added all .exe’s as trusted. They already were in the trusted list.

I will try the portable version.

Please try a clean install… uninstall CD and clean registry values caches everything wtih CCleaner maybe. Then install latest CD :-TU
Keep your bookmark and passwords :wink: Maybe it will be helpful

I tried the portable version with the same ‘Whoa!’ message.

Could it be that my 8.1 install messed it all up?
The portable version uses the same registry values as the nonportable version?

I will try to clean my reg and do a clean install of CD.

Do you recommend the Comodo endpoint cleaner or CCLeaner?

You can use Wise Registery Cleaner or Aulogic, Comodo System Cleaner :-TU

I personally doubt that it is a registry issue, considering the portable is also doing the same.
I do suggest a couple of experiments below, which can first be tested on the portable version.

Experiment 1) Right click the Dragon.exe file, select properties and under the compatibility tab choose to run the file in ‘Compatibility mode for Windows 7’.

Experiment 2) Copy/Paste dragon://flags/#touch-events into the address bar and enter, then disable this option.

I tried several compatibility options, but non worked. The difference is that Windows 8, 7 both gave me the ‘Whoa!’ alert and Vista, XP compatibility mode gave me ‘Untitled page’ with every website I put in the address bar

When I quickly paste the dragon://flags/#touch-events into a new tab (ctrl+t, ctrl+v pressed rapidly after each other) I was able to disable the touch options.
The tab loading Yahoo (default) is still visible and he Yahoo icon is loaded. But when I focus the Yahoo tab, CD crashes and shows the ‘Whoa!’ alert.

Is CD compatible with Windows 8.1?

I am not absolutely sure.
But it seems to me that at you blocks firewall CD exit in the Internet.

I thought of the firewall. I run CIS and because I am in a domain, I am forced to have Windows firewall enabled as well. This has never led to a problem in the past. CD is the only program so far that shows this issue. Chrome itself (I installed that to test if that works) does not have an issue.

I trusted and allowed CD in both CIS and Windows firewall.

I am lost.

Whether you tried to disconnect DNS Comodo?
As to use only Firewall Comodo?
I don’t use win 8. But I think you need to disconnect Firewall OS.
While ideas aren’t present more.
Portable CD works without problems.
Try: Only other folder (Create a name).
Before installation.
In the section C: or in other.

I do not use Comodo DNS
Portable dragon gives the same behavior and pops the ‘Whao!’ alert as soon as CD tries to load a page

I use CIS, so FW and AV.

Due to domain restrictions, I am unable to disable Windows Firewall. I have permission to install CIS given by the sysadmin. This because I use my laptop also outside of the domain.

I tried to have CD portable install into a preexisting folder, but still CD crashes on opening page.

Hi Comm512,
I am with you, so I have PMed Staff/Dev to take a look at this topic.

Sorry I can’t come up with any other suggestions.

I presume 8.1 ((Desktop Mode) should be compatible.
System Requirements

Kind regards.

Alright thanks. If more info is required to determine if it is local to my machine or a CD problem with 8.1, you can always contact me and I will try to provide the info.

I will use Chrome for now… but I rather use CD :). I will keep a close eye on this subject

Try in CD Settings - the Network
Where to change settings…


What settings do i need to check? If you are referring to how to disable the Windows Firewall, I do knwo where the disable feature is located, only it is disabled by my system admin

Try in CD settings - Additional settings - the Network.
Where to change connection settings…
Not sure certainly. ???


Try disabling hardware acceleration under Settings>Show advanced settings> System.
Please let us know if this helps.


I disabled the HW acceleration, but it still crashes when loading any page.

I still do not believe that it is a network issue. When i quickly change to the settings tab of CD after selecting an url to be loaded, it loads in the background while i look at the settings tab.
In CIS’ network connection viewer, i see CD receiving and sending bytes

As soon as i switch to the tab i let load in the background, it crahses

I installed Chrome along side CD and Chrome does work and has HW acceleration enabled.
Could it be Privdog?

See if uninstalling PD from Dragon fixes it or not.

Also try adding it to Define exceptions for behavior blocking in CIS to see if that makes a difference.