Can't copy text to clipboard in containment mode.

Up until i updated to the latest version of CIS 10 i could copy and past password into browser for lastpass add on for Dragon Browser but now i have found when i copy password and paste into lastpass master password the clipboard is blank, and i have also found if i copy a video url from youtube and paste into video downloader again the clipboard is blank , but before latest update that sytem worked fine , so i have rolled back to version before this version and all works fine again . also i should state that is when browser is running virtually.
hope you can help

not a great deal but though i would let you know
besides that amazing virus and firewall program

This is to protect against clipboard based exploits from applications running inside Sandbox.

We will be bringing some options where you can allow copy from and to.


thanks for the info Umesh

regards john :slight_smile: :slight_smile:

Hello, it’s really bad and dangerous to not be able to use the copy paste in the sandbox, when will you change that?

I use the copy paste between sandboxed apps and non-sandboxed apps all the time. Since the latest update, copy paste doesn’t work anymore, which means that the Comodo sandbox has become useless for me. Where can I download the previous version ?

If you want them, they’re here: All versions of Comodo Internet Security for Windows -

Or you can wait for the next release and probably have that and more functionality back

Yes, please bear with us.

You will see this change coming first in this month end CCAV release and same will be followed up in CIS.


A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes. Very reliably.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Open any application in containment.
2: Press ctrl+c (or shift+insert, or by application context menu) to copy some text to clipboard.
3: Clipboard is empty.
One or two sentences explaining what actually happened:
I cannot copy text to clipboard from applications in containtment mode.
One or two sentences explaining what you expected to happen:
I expect to see selected text in clipboard.
If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:
I tried Firefox 56, Firefox 57, Total Commander 9.10
Any other information, eg your guess at the cause, how you tried to fix it etc:
It started after the last CIS update.

Exact CIS version & configuration:
Comodo Internet Security Premium
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
All modules enabled except Content filter
Have you made any other changes to the default config? (egs here.):
A lot (many firewall rules), but I tried switching to default config and problem persists.

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Have you imported a config from a previous version of CIS:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 Ultimate x64 with almost all updates.
UAC is enabled. My account have admin rights.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

This will be addressed in the next release;msg868651#msg868651

Thanks. Now i found that issue in outdated reports forum branch.
Can you please take a look at my CisReport?
When i ran diagnostics it said that there is errors that it coulnd’t fix. It was surprise to me because i have no other problems except described in that topic.

Another issue that will also be addressed in next release, when diagnostic can not reach TCP service it will report failure. The TCP service it tries to connect to is rarely used by CIS so they will remove checking for connection or report ok status even if no connection can be made.

Big thanks.
Such a good service for a free product.

The usability improvements for controlling copy/paste between containment and non-containment processes will not come with the next immediate release but a different later release.

Wait, but it is important thing for me.
May be there is some setting in registry that i can change manually?

No it is hard coded within CIS, you can use shared spaces folder to save text to a document, then open that document to copy text from.

Merged topics of same issue that is going to be addressed in a later release.

Any update on copy/paste being re-introduced into Containment?

It’s very high on our list.
We have introduced improvements in CCAV v619 and same changes are planned for CIS.


I hate being a nag - just wondering if this got into the latest update, cuz I’m not seeing it.