Blocking Avira "avnotify"

When I was using Online Armor I could successfully block the Avira pop up “avnotify” and still get normal updates. I tried blocking it with Comodo and no luck. I have it blocked on the firewall end but cannot seem to do it with D+. I added it to “my blocked files” which does work but then Avira will not update properly and if you do a manual update then you will need to reboot. Avira is on to people blocking the free version pop up and the reboot required is how they are paying people back for blocking “avnotify”. I tried making “avnotify” a limited appclication and receviced an error. Anyone having any luck at successfully blocking “avnotify” with Comodo?

Not with Comodo, but with XP Pro you can create a policy that avnotify is not allowed to run. That works fine.

There was also a way to achieve that on XP Home (that is lacking the group policy editor of Pro) but I forgot. Perhaps in safe mode?

EDIT: Alternatively one could invest a few euros and even get additional mailguard and stuff with it…

  1. Start-> Control Panel
  2. Administrative tools-> Local security policy
  3. Click on Software Restriction Policy-> Action (at the top)-> create new restriction policies
  4. Right-click additional rules (on the right side)-> new path rule
  5. Click Browse and navigate to C:\Program Files(Avira)\AntiVir Desktop\ and double-click avnotify.exe
  6. Set the security level to Disallowed-> apply-> ok

Summat you could try with regards to blocking it with Defence+ is to add avnotify.exe as a Blocked Application in the Run an executable section for update.exe

Double click the update.exe–>Access Rights–>Modify next to run an .exe–>Blocked applications–>Add/Browse to avnotify.exe

It`s a while since i used Avira with CIS so it may not be Update.exe you need to block it from,it may be avcenter.exe…

Sure you`ll figure it out, but like you said Avira have cottoned on :wink:


Try doing it in windows “safe mode” Make sure avira isn’t running
C:\Program Files\Avira\AntiVir PersonalEdition Classic\ In the avira program, right click on avnotify.exe
and rename it to avnotify.exe.bak

@Matty: That won’t work because you will get another notification that you have to reboot your computer (not forced, but another thing to click away).

@jay: I think the updater will see avnotify missing and quickly reinstalls it.

Im pretty sure i’ve successfully blocked it on my Nephews laptop. I ran the avira update, the pop up appeared, i went to “view active processes”, i blocked and terminated it, ran the update again and it worked. No reboot was asked for.

Ill have to check it then if you guys say it doesn’t.

On two laptops running XP home I didn’t succeed with adding it to D+ blocked files list.


start → run → regedit
then go to…

Find avnotify and add " /nosplash " to the end.

Hope this helps

None of those help actually. Avira is on to people blocking “avnotify”. I got a free upgrade license for the premium form a buddy. ;D

Sounds more like an issue with Avira than D+. If I understand correctly, you wish it to update you regularly, but not have the notification popup when it does?

It is not an issue. One of the draw backs to Avira free is the daily update nag screen. You use to able to block it via a Windows trick. I was able to block it with Online Armor and no errors. If you block “avnotify” then the next time you run an update you will be asked to reboot. Its all over the forums for Avira. They are catching on to people so this is how they are paying us back. Block “avnotofy” and your updates will require reboots.

So what it really needs it to be permitted to run, but block any screen outputs (thus fooling the module).
If you have your D+ rule to allow this module to run, try this:
Edit the rule, select ‘Access Rights’. Block ‘Computer Monitor’ or ‘Windows Messages’.
Do any of these help you?

That’s a good idea I may try. However the screen message needs a click on OK. We’ll see…

EDIT: I didn’t try it with Comodo, but found the lost instructions for XP home. It was indeed via safe mode:
That works for XP home.

Just did what you said word for word and when Avira updates it asks for a reboot cause it knows that avnotify is being blocked. This is Avira 8 I am referring to.

Did not work.

I managed to block it back then (and it was with Avira 8.x), it was not the obvious option to define avnotify.exe as isolated app. It was something similar to what Matty said but not quite I think. Try looking in D+ for policies for . “run as executable”… Or an exception to the allowance for explorer.exe to “run as exe”… Or the same but for . instead of explorer.exe… Something like that, my memory is weak.

That worked… ;D

Would this help??

“Description”=“Start von avnotify.exe”
“ItemData”="C:\Programfiles\AntiVir PersonalEdition Classic\avnotify.exe <–you probably need to edit this :slight_smile:

I removed the quote
I felt it was inappropriate :frowning:

Ill have to check it out, But it definitely didn’t ask for a reboot. And it is avira 8 also.