Autoupdate problem

I just downloaded BoClean on top of my Commodo Internet Security (including Commodo Firewall).

When I go to BoClean’s menue and select the CHECK FOR UPDATE button, I get:

“MISSING MODULE: Autoupdate is either corrupted or is being blocked by another security program”

Is this a configuration issue with CIS? If so, how do I fix it?

UPDATE: Forgot to mention, I’m running Vista x64, and the Windows firewall is obviously off in favor of Comodo’s firewall.

Hi cidsamuth :slight_smile:

The “MISSING MODULE” problem under Vista. If I remember well this one puzzled Kevin too :-\

Maybe you should try a reinstall :

  • Please download a fresh copy from here :

  • Shut down BOCleanfrom its Menu.
  • Deinstall BOClean.
  • And follow the Install Instuctions for your Operating System from here :

Greetz, Red.

Tried it. I even uninstalled CIS, then re-installed them both (BOClean first). Problem is still there.

Update does work if you go through PROGRAMS-COMODO-BOCLEAN-UPDATER.

Just doesn’t want to work going through the BoClean menu . . .

I don’t think this is a firewall ( CIS ) problem. But does BOClean update after booting according to your configuration settings ???

Greetz, Red.

Hello and thanks for the reply.

I don’t know if it updates at reboot, as it has the current policy now from the fresh install today. I’ll have to wait and see the next time a new policy is available – it definitely doe NOT give me an ‘error’ screen at boot up, though, like it does when I try to update from the Boclean screen.

Again, if I update via the START-PROGRAMS-COMODO-BOCLEAN-UPDATER, it works fine (though, again, it “aborts” because I already have the most up-to-date policy).

This is definitely a Vista ‘User Account Control’ issue (compatibility issue?). If I turn off UAC, the update from the Boclean menu works fine.

I don’t want to turn off UAC, as it disables the constraints on the ‘guest account’ I have set up, not just my administrator account. So, I guess I’ll keep using the START menu for updates until someone gives me a fix (:AGY)

Maybe you should look at this topic and the tips/links posted there :

Greetz, Red.

Okay, so if I’ve digested this info right (including the links), this is a Vista issue with no current fix?

So, I’m seeing that the ‘updater’ via the START menu works, but using the “Check for Update” button doesn’t work in Vista with UAC activated. Does the automatic update (where the interval can be changed in the configuration page) work with Vista/UAC, or will I have to manually update?

I can’t tell you that, as I am not using Vista. But if you want I can email Kevin about it :slight_smile:

Greetz, Red.

That would be great. There was an update today when I used the START-PROGRAMS-COMODO-UPDATER option, so I can only assume that the UAC didn’t allow the BOClean to auto-update, but a definitive answer from Kevin would be great . . . and I’m sure I wouldn’t be the only one who would benefit from hearing from him on it.

Done :slight_smile:

Greetz, Red.

Sorry for the wait … this one’s a very rare one and I had to go back and look over the code in order to venture a guess on this one. And since this advice will probably be used again, had to make doubly sure that it might actually work. :slight_smile:

Vista is a special case for BOClean because of the UAC as well as the need in all prior versions to be compatible with ALL versions of Windows, all the way back. For the few who have run into this problem that we’ve never been able to reproduce, my last guess on this would be a problem in the registry if not outright blockage by UAC or something else which has usually solved it before.

Since Vista does block the external call to run the updater from within BOClean as a “system call,” as of BOClean 4.25, we’ve built the updater function directly into BOClean for Vista while on older versions of Windows, we call the external updater and it works. Since detecting whether or not we’re running on a Vista box is unreliable (since settings and other factors are inconsistent) we went with a call to the registry to determine if the “Common Appdata” key points to a folder called “ProgramData” which is unique to Vista. Looks like somehow either that folder doesn’t actually exist, the registry key is wrong, or BOClean was installed to other than the main hard disk. That would cause BOClean to think it’s not running on Vista and thus default to “normal mode” in calling the external updater which of course is jammed by Vista security.

Since in my own personal cynicism, I didn’t trust anything, turns out that I had cautiously built in a workaround that I’d forgotten about. As Professor Farnsworth in the Futurama cartoon series would say, “Good NEWS, everyone!” Heh. We might have a solution for ya …

You’ll need to first search for a file called BOC427.INI. It’s possible that there will be more than one of them found, but the one you want will be the largest one of them all. Load that largest BOC427.INI into notepad (you’ll need to change the “open file” from TXT to “all files” in order to get it, and once you have BOC427.INI loaded into notepad, at the very top, you should see:


… as a header. Push down the lines below it and insert a new line as follows:


… then SAVE the BOC427.INI file (not “save as”) and hopefully that will kick your BOClean into “Vista mode” since something on your copy is preventing BOClean from detecting that it’s Vista.

A word of warning to those NOT running Vista … DO NOT do this on any other version of Windows or things can get squirrely. This is ONLY a workaround when BOClean is running on Vista and Vista fails to inform BOClean of what it’s running on … hope this helps. :slight_smile:

Okay, thanks Kevin. So, to sum up the Vista autoupdate fix:

Go to Program Files and find the file, BOC427.ini. Save it (maybe to the desktop) as BOC427.txt.

Open the file and add “vista=1” (without the quotes) after the entry “[prefs]”

Save it as BOC427.ini at the original location in Program Files.

Sound right?


Thank you for your ‘fix’ for the problem with updating BoClean from the menu on Vista machines. However, I’m still having some problems.

The BOC427.ini file you mentioned seems to be located in the Windows folder of the C drive. When I open it, it opens to Notepad automatically. However, when I add text “vista=1” and try to resave it, I get this error:

“Cannot create the C:/windows/boc427.ini file. Make sure the path and file name are correct”

Any advice?

Hi cidsamuth :slight_smile:

I beleve there is a little communication problem here ??? I will email Kevin about it :slight_smile:

Greetz, Red.

Hi cidsamuth :slight_smile:

Kevin is very busy with CIS, so he asked me to help you :slight_smile: You should open Notepad from your Start All Programs menu by right clicking it and choose “Run as…” with your Administrator account. Than load BOC427.INI into Notepad the way Kevin described and it will let you safe the changes you made :slight_smile:

Greetz, Red.

A workaround also, Red, as I have seen this with my own Vista, is to save the file in a personal folder, then drag&drop the file to the desired Windows folder. Vista will ask you to confirm this operation. Upon responding ‘yes’ the file will be copied (or moved if that is the desire) to the folder.

This is just part of Vista’s defense system to prevent unauthorized tampering by users.

Thank you, John B. Your method did allow me to save the changes.

Unfortunately, I still have no joy with the original problem. Even when I add ‘vista=1’ underneath [Pref], the problem is still there.

Again, this issue only prevents me from updating using the BoClean menu. If I access the ‘Updater’ via the Start-Programs-Commodo-BoClean-Updater method, it updates okay.

As such, I think the hassle-factor has officially grown beyond my desire to fix this.

Thanks all, anyway.

Version 3.9 of CIS will have BOClean included within. This also may be a solution for you.

Hi cidsamuth :slight_smile:

Is there a line “NT=1” in the BOC427.INI file ??? If so, delete that, and try again :slight_smile:

Greetz, Red.

Hey Red,

I appreciate the time you’ve taken here, but it still didn’t work :-[

I tried it inputting the vista=1 and deleting nt=1

I also tried NOT inputting the vista=1 but I did delete nt=1

Neither worked. Just to be safe, I also restarted the computer after each change.

Just to be clear, my original title is deceiving; this is not an “autoupdate” problem. Instead, this problem is with the update button on the BoClean menu. That’s what these fixes were intended to help, right?