automatic functioning

I have i-vault version Since I updated to IE7, i-vault seems to no longer record new cards automatically, nor to insert the login details automatically as it used to do. I can use Qick PW, but it is much less convenient. When I click on a card to login, it opens the login page but the login field sare yellow instead of green and the login details are not entered. Is there a solution to this?

I’m having the same problem and I have seen no responses for a solution. Any idea what to do? Uninstall and re-install?

Thanks for the PM, harringtone. Sorry no one has responded. My suggestion would be uninstall and reinstall. Make sure you have a current/up-to-date copy of your .civ file.

It could be related to the fact that you’ve upgraded browsers since initially installing. When you uninstall and reinstall, make sure you turn off/disable any active security applications (AV, antispyware, HIPS, etc). Reboot in between. Check msconfig to make sure there’s not an autostart entry remaining active for iVault before reinstalling.

Also, make sure you have the most recent release to reinstall with. Earlier versions came packaged with LaunchPad, but I don’t think the current version is.

Hope that helps,


I saw this post & followed your advice. So now I have a newly downloaded ivault which is the same version as the previous (, is still bundled with launchpad, & behaves identically. javascript:void(0);

(& a second license? - not sure about that cause when i opened it to install the newly emailed license, it shows I’m registered already. not sure exactly what the original license date was, but I only have ivault a couple of days total anyway).

Is this the latest version? If not, please post a link to it, since the Comodo download area is not yet updated.

I hope the new version will be compatible with firefox.


If you downloaded that from Comodo’s site, then that will be the current version. I know they have removed LaunchPad from their product lineup due to user feedback. I could be mistaken about it not being in the current version; perhaps they haven’t updated iVault since that point.

If you don’t want LP, that’s easy enough to get rid of. Regarding iVault and automatic login or form-filling problems, the only time I ever experienced that, I uninstalled and reinstalled and it was fine from that point on.

Not intended as a slight or insult in any way, but please check to make sure you’ve set it to automatically capture the card info, and automatically input to the website. Be aware, too, that some sites change a part of the page’s path each time, so it’s never actually the exact match. This will cause iVault to want to generate a new card each time you follow your existing card’s link.

That info may not help you at all; if not, please be as specific as possible in describing the problem, all symptoms, and the steps you have taken trying to resolve it.


Thank you for your quick response. My immediate concern isn’t the launchpad rather uninstall/ reinstall changed nothing:
1.Quick pw isn’t working in firefox nor in ie7.
2.IE integration isn’t working (ie 7)
(Is quick pw supposed to work in firefox? I don’t want to waste my time trying to do the impossible!)

To test the sw, I have 1 active storage with “web resource” cards for 2 websites. (One is this forum.) For this forum, I also created a regular login card, to test whether the quick passwords function wasn’t working due to the card type. Please note that I realize that i-vault won’t work while minimized, so I sign into it before navigating to the site.

Here are my settings:

General Tab
Startup - all checked
Interactive- checked confirm perm item deletion; delete to recycle folder & close button minimizes to tray.
Unchecked keep main button always on top.

Printing options - currently unchecked

More Tab
everything checked

Quick Passwords tab
checked: enable quick pw; require keyboard focus

data transfer -via secure clipboard

build quick pw list from active storage only

IE Integration tab

Ie integration checked

Data retreiving from new pages: Hidden: acquire silently
Data insertion into known pages: interactive.

I chose interactive cause hidden requires inserting pw the “normal way” the first time. I assume this means entering it directly on-site, revealing the pw just that once. I prefer to type directly into encrypted sw. Am I misinterpreting the way hidden data insertion works?

The web pages loaded, but iTrust never popped up asking me to fill out a card, so I created it
myself. Is that why all later attempts to auto-login just haven’t worked? This makes little sense to me, cause that means I can’t import my pw from another program but have to re-enter all while at the sites.

Advanced Settings:
Checked Highlight login/pw fields

What would be the reason to consider disabling updates of existing cards? (Seems inconvenient to need to delete & create another card whenever I wanted to change passwords.)

Also, wouldn’t it decrease security if I allowed arguments to pass to the site globally? (I assume this means personal login info) How can this be enabled only as needed?

I hope you can point me in the right direction.

Selecting “Interactive” for data insertion will negate the automatic function.

No, automatic will not work with FF… that’s the whole “We want FF integration!” issue in the wishlist. :slight_smile:

My suggestion would be first to change from Interactive to Auto. Try your sites from your stored cards. If no joy, delete the stored cards, reboot computer.

Leaving everything set to full Auto, navigate to login page normally in IE (again, no auto integration in FF).

I note that you said you weren’t prompted to create/fill out a card; with “Acquire Silently” set, you won’t be prompted… that’s only with an Interactive for the acquisition.

Hope that helps,


I havent gotten to this yet, i’m in the process of switching my used- to- be- ok but no longer adequate security & ironing out the glitches. Will get back to this soon, I hope. But thank you!

“I note that you said you weren’t prompted to create/fill out a card; with “Acquire Silently” set, you won’t be prompted… that’s only with an Interactive for the acquisition.”

acquire silently = I type into the website? is what I type on site encrypted / safe? if not, is there any way to set this up without exposing banking / credit card info just once?

No, automatic will not work with FF… that’s the whole “We want FF integration!” issue in the wishlist.
Quick pw also only in ie?

Yes, only IE has the automatic integration function. :cry:

If you don’t want to type into the website for automatic acquisition of login, your option is to manually build the card with all info. Then you’ll need automatic integration for sign-in set, or else use the secure copy feature to copy and paste (one-time only) for login and passwords.

Hope that helps,


Thank you! I think I’ve got it now! Now all I have to do is get to it.

Yes. Well all that is fine. I use IE7m fully updated but “hidden data retrieval from web page” still does not work and I have to either manually create a card or switch to “interactive” and then remember to switch back to hidden unto prevent the interactive dialog boxes from popping up every time I enter a page.

How exactly is one supposed to get rid of LP? I tried. I have been unable to find any way to open the IV interface except through LP. IV may launch automatically on startup, but there is no tray icon or other way to make the GUI show.

In addition, if another of my users logs on to the computer before me then LP opens in their account and I do not see it at all, and have to manually open it from the start menu in order to get into IV. I posted this in a separate thread but no one answered. I imagine this requires a registry edit but do not have a clue what changes to make. The solution has to be to eliminate the LP dependence of IV so that IV runs as a stand alone application.

to remove launchpad & set it to open manually

(a combo of 3 steps, first 2 I found posted on this site. last I did myself. Hope it works for you! I only had one listed entry & the service & stopped them using Winpatrol :wink:

Post 1. Go to Start/Run, type “msconfig”. Go to the Startup tab, find the entry for CLPTray, uncheck the box. There may be one other launchpad-related entry, but I can’t remember the name; they’ll be together tho’, as I recall. If it’s there, uncheck that box, too. Click Apply. OK/Close. Reboot the computer.[/i]

Now navigate to c:\program files\comodo\launchpad. Right-click Launchpad folder, and select Delete.

LaunchPad has been removed from further versions of the application(s); however, Comodo is not redoing their code to accomplish this until they are updating the actual application in question. I just found that the recent version of Backup does not include LP. They’re slowly but surely eliminating it.

If you can’t find a Service for LaunchPad, don’t worry about it. By using MSCONFIG and unchecking CLP’s entry in the Startup tab, it won’t run at next reboot. Then you can delete the entire folder, c:\program files\comodo\launch pad. Reboot.

Post 2. Check to make sure this registry key is gone; if it’s still there, remove it.
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run Registry

  1. Create a shortcut to start ivault as needed.

Go to yourdirectorypath/comodo/ivault/.

right click on ivault.exe, choose Create a shortcut. (ivault.lnk) I placed it in my quicklaunch, but it could go on your desktop or be pinned to start as well. Your preference.

I got autologin to work, except that when I go back to the page using the loginto button from the new card autologin created, it creates a second card - regardless of setting.
As in this active post:

Beyond this issue, autologon is only fine for non-private stuff. Have been trying again to securely enter my info into a new card & then auto-login, which is the only way I’d want to handle private info. Still no go.

I expected better! Time to move on to something else that will do what I need. javascript:void(0);
Thumb Down javascript:void(0); Thumb Down javascript:void(0); Thumb Down

What you wrote seems fine. The next question is when opening i-vault from i-vault.exe, is there any way to get it to minimize to a tray icon only instead of a minimized window in the taskbar?

Supposedly: Tools, Preferences, General, choose “close button minimizes to tray” However, although I have this option selected (along with minimize at startup) it isn’t working. This doesn’t concern me greatly, since I doubt I’m going to be sticking with it.

Minimize to tray works only in conjunction with launch pad.
Why do you intend to abandon i-vault? Have you found security problems? If so, what?

It works fine for me more or less. For some sites autologin works, and for others it doesn’t or isn’t convenient because of the structure of the site, in which case I have to click one button to enter. Only in very rare instances do I have to use Quick Password to enter data. The user name and password are usually entered without problem, which is what I really wanted from the program.

I am bothered by the difficulty in creating new cards since I upgraded to IE7. The automatic card creation (hidden setting) no longer seems to work and I have to use Interactive which is a bother.


Since upgrading to IE7, have you perhaps reinstalled iV? The .civ file will remain the same, but that might resolve the integration issue. I’ve used with IE7, but have re-installed iV since IE7 came to the machine.


“Why do you intend to abandon i-vault? Have you found security problems? If so, what?”

After considerable time on the forums & effort to make it work, it doesn’t do what I need the way I want to do it. Other sw packages do.

  1. My primary browser is firefox. iVault cuts & pastes securely, but I can’t resize it, so it’s cludgy to use, as well as less convenient than sw that integrates with firefox.
  2. It does auto-logon in ie, But has a problem using parameters to login…
  3. Have tried again & again to create cards & then auto-logon with them, but it doesn’t work for me at all. When it comes to confidential info, I don’t want to enter info unencrypted into the browser to set up autologon. I want it transmitted securely in encrypted form. I can’t do that.
  4. Quick Passwords has not worked for me. ever.

It’s still on my system, but I can’t waste more time on this version. It doesn’t do what i need. Maybe I’ll upgrade to a future version if it adds the functionality I need.

For now, I’m happy with BoClean & Verification Engine - in both cases my time & effort on the forums & adjusting settings paid off & they do what they’re supposed to for me. Last night I installed CFP 3 - so far it’s smooth sailing. It’s a top-notch firewall/ hips & I will benefit more from addressing the learning curve I face to master it than spinning my wheels with iVault.

I finally figured out how to run i-Vault w/o Launch Pad. It simply requires two command clicks (either on a shortcut or on i-vault.exe). The first click starts the process. The second click opens the GUI. If i-vault.exe or a shortcut is placed in the startup folder to start the process, then a single click will open the GUI.
Without launchpad running in the background my computer seems to be running a lot faster and smoother than before. It is now easy to open IV when i need it. However, I would still like to see a tray icon for IV when the process is running w/o GUI open.

How do I uninstall? None of the uninstallers (Z-Soft, Revo) seem to remove the program. Does it even require uninstalling, or just deleting the folders and files? What about the registry? Unlocker doesn’t report any locks. Revo didn’t seem to complete the uninstall and showed a whole bunch of registry entries. Zsoft said it was uninstalled, but the files were still there and I could still open the program and GUI.