automatic functioning

I’m not using iV at the moment (I use a portable app that will launch FF and works in Linux), so this is from memory… I’m not sure if there’s a valid Add/Remove Programs entry, since it is installed through LaunchPad integration; I don’t think it’s even listed in Start/All Programs…

You probably need to get rid of LaunchPad as has been discussed previously. Then use Zsoft (or msicuu2) to remove the installation entry, if iV can’t be uninstalled “officially.” Delete any remaining folders in Program Files, and run ccleaner (or similar) to remove any leftover registry entries. Reboot, and you should be good to go.

BTW, there’s also a good free tool by sysinternals, called PageDefrag. If you run this, you can set the option for it to defrag your pagefile and registry hives on reboot. It takes a few seconds, but will help speed up your machine, especially after you’ve edited the registry.

Hope that helps,


I have previously removed LaunchPad. I-Vault appears in Windows Add/Remove as well as in Zsoft and Revo file lists, but none of them seem to do anything. if I understand you correctly, you are saying I should just delete the files/folders and then clean the registry. Just to prevent me from doing anything stupid, please confirm that that is what you meant.
Then I can reinstall from a fresh download, again get rid of LaunchPad, and i-Vault should should integrate correctly in IE7, I hope. Correct?

Correct. If trying to run an uninstall routine does nothing, your only option is to manually remove program folders, etc. iV doesn’t have a service or autostart entry that I recall, so it should be easy to delete the program file for it. Zsoft has an option to remove the program entry, which I would suggest as well (or you can use msicuu2 for that purpose as well).

Once the files are gone, clean the registry, reboot, and you should be set to reinstall fresh. The reboot is necessary after cleaning the registry up.


The reinstall didn’t work. I a got an error message: “Error 1719: The Windows Installer Service could not be accessed.
This can occur if you are running Windows in safe
mode, or if the Windows Installer is not correctly
installed. Contact your support personnel for assistance.”
I tried fixing it according to "The Windows Installer Service Could Not Be Accessed" error when you try to install a program in Windows 7 or Windows Vista - Microsoft Support, but that didn’t help either.
I restored the deleted registry components and the deleted i-vault files and it runs as before except that now it doen’s interact at all with IE7. i.e doesn’t even enter the loginin details into the web pages and I have to copy paste each one…
Therefore it seems that I really do need to reinstall to get proper functioning in IE7.
If you have any ideas, I am all ears (eyes).

Have you tried this?

Good. I will give it a try. I think I saw something like it in one of the MS KB or forum articles but didn’t quite understand it. This is much clearer. I will let you know what happens.
Many thanks.

Yeah, MS KB articles can be rather confusing at times… I always try to find something that’s a little easier to deal with.


Hi Little Mac,
It didn’t work. I did exctly what it said in the instructions you sent. Then I got the rror message 1607- Unable to install Installshield Scripting Run Time. Since I know I am going to have some programs to install in the next few days. it is getting urgent that I solve this problem.

Do you have any more ideas.

If you go to the InstallShield website and find their Support section for older InstallShield stuff (not their current product offerings) - you may have to Google it up, but it does exist - they will have instructions about identifying which exact installer the application is using, and instructions on how to resolve the issue.

Here’s what I’ve experiened/learned in the past. There are a large number of different InstallShield engines used for MS Installer packages (different releases or versions), and unless you have the correct one installed on your machine (you may not), you have various issues and error messages.


PS: Here’s a link to one such InstallShield site.

It’s the “consumer.” at the front that’s key…

Thanks. I will look into it. The only problem is what will happen with installation of other programs?

Has no impact on it. As their instructions will tell you, you check the installer package you’re working with to find out what version of Installshield created it. Then you download that version. So it only allows you to interact with the install package you’re working with (or any others that require that specific version).

I’ve normally only seen this on a new/fresh reinstall of the OS on a slightly older system, but it can be a pain when it happens. Over time, you normally accumulate a variety of these different InstallShield engines.

Hope that helps,


OK. I will try it. Thanks.


Reason: Out-Dated post.