Author Topic: Comodo Internet Security 2020 v12.2.2.7036 RC is now available

Hi All,

We are pleased to announce that Comodo Internet Security 2020 v12.2.2.7036 RC is now available for download and testing.

Setup Details:
In order to install online setups, please ensure you have following entries in Windows hosts (c:/windows/system32/drivers/etc/hosts) file:

Comodo Internet Security 2020:

Size: 4.78 MB (5,020,536 bytes)
MD5: e40d8cb2bc789f96b855432b597ce22a
SHA1: 90c2577e94cb2b1556abd50baebd52f0b4605bf6

Comodo Firewall Installer:

Size: 4.78 MB (5,020,536 bytes)
MD5: d6ac13d92c620cd65aa26679c8c1c88a
SHA1: 4ddbcc0d12db905988fb35fcdd757a212ee32347

Comodo Antivirus Installer

Size: 4.78 MB (5,020,544 bytes)
MD5: c38447813fa58fc72995a9ddbdc63828
SHA1: 20b8637365fc6d25b89a7d6e3cded050c2213c4b

− Migrate the vast majority of legacy HTTP links to HTTPs.
− Folder Protection.

− Upgrade over install doesn’t work.
− HTTPS website filtering no longer works on Chrome 78.
− Chrome crashes in Containment.
− CIS creates error while unplugging USB.
− Uninstallation & Installation failed.
− Uninstallation of Comodo Killswitch and Cleaning Essentials.
− Freezes in Win10 build 1909/1903.

Please give your valuable feedback! :-TU


Congrats for the new release!

Is there any offline installer available?

Not at this current juncture.


Installation error

Me to Windows 7 64.

Have you altered your Hosts file?

In order to install online setups, please ensure you have following entries in Windows hosts (c:/windows/system32/drivers/etc/hosts) file:


Did a Clean Install this time from the Beta2 . . . imported saved Config and File List. Installed w/o any problems along with KillSwitch

The only tiny thing I noticed, was that despite checking the box to show the Widget, it didn’t do that and I had to recheck it when installed. Apart from that, running well.

Excellent job and many thanks :-TU

The recognizercryptolocker.dll is downloaded but not listed as an available installed recognizer. And it seems when you install killswitch/CCE/autoruns, it downloads the beta 2 version

Same here - another update just installed but nothing changed on those points

Thanks for the info Ploget
After modification, it’s Ok :-TU

Congrats for the new release ! :slight_smile:

Windows 10 Pro 1909
Version 10.0.18363
Comodo CIS RC

Setup + PC Reboot
Function tests> Ok
Good team work :-TU
Thank you


Anything for CISPro ?

Many thanks for your effort!

Same things really - Premium and Pro. You just need a purchased license to convert the Premium version to to the Pro

“Comodo Internet Security 2020” see that? >:-D

im really glad to see another test build… waiting for the final with hope that this will be the best cis ever… :slight_smile: congrats devs for the efforts.

I have a purchased key.
So i guess i download the premium installer, i uninstall other version, install the RC and activate it then ?

Edit: I did as i said. Worked fine but i couldn’t download the Website Database through update.
Fixed it by marking the hosts (#), checking for updates that returned an error ofc ( but not only for the Database this time ) and then unmraking the hosts and checking for updates again seems to load the database without even downloading it.
The error on database load/download was undefined. Without crash or report. But for now everything works as expected without problems!


note: users windows 7 out of date, install updates: windows7-kb4474419 and kb3033929 (in some cases) :-TU

Finally!. :_TU

I installed using the online installer because the update was not available when using the program updater. I imported and activated a saved profile.

The problem with the systray icon not showing was not solved in this build.


Gmer also sees this build as a rootkit.

Gmer can’t access comodo service registry keys so they get listed as a ‘hidden service’ because CIS prevents access to its services in the Windows registry.

The tray icon issue I think is a Windows bug as I used to have this issue when I was using 1903, when I went to install 1909 it was installed on a re-formatted disk, and since then the tray icon has always been visible on startup. Sane as with the Windows security center integration issue that would sometimes indicate Comodo firewall was disabled when it wasn’t, after a clean install of 1909 I have yet to see warnings from WDSC about the status of CIS, both with beta 2 and now this build.