AnyDesk is not working well with Comodo Internet Security active

Hi, i will report the same to AnyDesk:
I found that in two different PC where Comodo Internet Security is active AnyDesk are not working fully.
No error showed but user are unable to manage windows or write with keyboard.

No issue with other remote program.
Seems AnyDesk work fine where Comodo is not active.

If Comodo i active on the destination PC to support operator can be unable to use keyboard for digits letters, charcaters.

Is the application being run in containment on either system? Do you have a global firewall rule to allow the incoming connection on the destination system? Is Anydesk rated as unrecognized in the file list or does it have a trusted rating?

The app is not running as sandboxed.
No alert from Comodo so the app is safe for Comodo also.

Really don’t know the cause about this, maybe AnyDesk will test more… just know the app seems have issue when Comodo Internet Security are present on the remote PC.

No alert from Comodo does NOT mean it’s considered trusted - incoming connections of unknown applications are blocked by default as far as I’m aware.
Does AnyDesk show up as a blocked application (open Comodo - click on “unblock applications”)?

Yes… there are AnyDesk locked from HIPS

Does Anydesk need one or more ports to be opened for incoming traffic?

Hi EricJH,
sorry i do not know this … anyway i emailed AnyDesk Team with a link to this topic… they maybe are interested on solve this issue.

I just discovered the issue.

AnyDesk does not require any port specific access. It operates in the same manner as LogMeIn, TeamViewer, etc.

I’ve also posted in your thread about AeroAdmin being sandboxed (Comodo Forum).

Hope this helps,
Ewen :slight_smile:

This issue does not happen in version 10 but only in version 11 for me. Disabling the firewall makes all work again , logs does not show anything blocked with firewall enabled.

Hope this helps

I have version 10 of Comodo :slight_smile: and i see issues.

Running the latest beta and I see no issues after I open the port to use direct connection.

Hello. Does anyone know what rule to prescribe in the global CIS rules to allow Anydesk to work.
The Proactive Security configuration is used. Ports are hidden. The application has a trusted status. Firewall and hips in Safe mode. There are no requests from the firewall or from the hips. In the logs there is no information about the access to Anydesk of incoming packets.

I found a solution in an experimental way. In the application rules, specify Anydesk to allow. In the global rules, assign permission to inbound TCP packets to the port (default 7070) of the direct connection specified in the Anydesk settings. Voila!

I have the same problem with anydesk and have been redirected to this post, the content of my previous one is:

After update to, i'm unable to connect to other computer with Anydesk. - If I treat as Allowed application => Can't connect - If I treat as Outgoing Only => Can't connect

If I remove the rules for Anydesk and attempt to connect and in the alert popup, I allow for specific IP and Port, I can connect to the target computer
But I have to do it for each computer I want to connect to, of course each computer have a dynamic IP, so it’s not a solution on daily usage.

If I try on popup alert to set Anydesk as “Allowed” => Anydesk is blocked.

Disable the firewall allow to Anydesk to connect to everywhere.

I have tried to allow TCP (+UDP) incoming on port 7070, in app setings, in global rules… but it doesn’t work for me.
Of course, no information in the logs for outgoing or incoming blocked connections…

At the moment it seems the only apps to have a problem…

In application rules, assign Anydesk to an application that is allowed.
In the global rules, write two elements in the rule:
All outgoing packets are allowed, incoming TCP port 7070 (make sure that this port is in the Anydesk settings).

I think I have found the problem!
Lucky because I wasn’t searching to resolve it anymore!

In Juanary, I have changed my router and anydesk was working, then few days later I have updated Comodo that breaks Anydesk connections…
In my new router the UPNP was enabled by default and anydesk was creating rules (Random external port to 7070 Internal port).
I have disable the UPNP in my router, now I can connect to remote computer.

I haven’t investigate more to understand the links between comodo - UPnp - Anydesk


I’ve had the same issue a while, AnyDesk used to work normally, then it stopped working and only works if Comodo Firewall is disabled.

Needing to use AnyDesk daily, this has become highly annoying and I’ve been looking for a solution, haven’t found one yet.

Here is what I’ve tried so far:
o I’ve tried changing the AnyDesk connection port.
o Make sure that AnyDesk.exe is allowed - it is.
o Uninstall and re-install Comodo.
o Set the connection port rules in global rules.
o Disable UPnp from the router.

The problem exists in all computers I use, with multiple Windows versions.
I’ve done the above steps in all of them - the problem still exists.
I need to disable the Comodo Firewall, only then AnyDesk will start working normally.

This is not normal behaviour, the firewall must follow the rules it has been given.
If AnyDesk.exe is an allowed application - Comodo Firewall has to allow ALL traffic connected to it.

The problem must have come with some update a while ago, it seems plausible.
What else can this be called, other than a bug in the Comodo Firewall software?

I really hope Comodo fixes this issue soon.

You need to make sure in the AndDesk connection settings allow direct connection is enabled and the port listed is the same one for the global rule. Also check the firewall logs to see if anything is being logged as blocked. I would also enable logging for the global block rule that blocks all incoming connections and try again to see what gets blocked.


I created a global rule for the Anydesk port, enabled logging - nothing gets logged. Absolutely nothing.

All this time Anydesk has been in the application rules as an allowed application and it’s ports are opened with manual rules.

All should be fine, however while the firewall is active - no connections to Anydesk can come from outside and I cannot make connections to any computer with Anydesk, which can be normally connected to when the firewall is disabled.

This is happening with all computers on which I performed the latest update, only with Anydesk.
Everything else works fine.

Networks including firewalls are my work, I feel it ridiculous that I cannot have one firewall software work with an application when it is allowed, ports are opened, there should be no reason for not working.
Before the latest update, this has been working fine for years. Then I update Comodo and this happens out of nowhere.

I am still standing behind what I said - this is some sort a bug in the firewall software itself.

Can you describe the rule you made in Global Rules as follows?

Source Address:
Destination Address:
Source Port:
Destination Port