An error occurred while setting the schedule. The schedule has not been set


I’m running Comodo backup 3.0.17317.130 and I am trying to backup files to an external drive. I am getting an error that says “An error occurred while setting the schedule. The schedule has not been set” every time I try to create or edit a backup. I have tried sync copy backup and also creating a incremental cbu backup file but each time I get the same error.

I searched online for this issue and found a previous post which discusses this error in version 2.0 but I’m using 3.0 and I’m running Windows 7 32-bit. I have been unable to make backups so any help on this topic would be greatly appreciated. Thanks!

Hello and welcome to the forums! :slight_smile:

Are you running CBU as admin (Right click icon on deskto > Run as admin)

and If you are running as admin; How is your external connected? USB/Network/etc


Hello there,

Having the exact same problem (I think)

My situation, running;
win 7 (32 bit)
Comodo Backup v. 4.0.7

I tried to run as admin, but didn’t seem to work… Do you want me to make a “control” file through cmd, in order to have a closer look at my specific situation…?

Best regards, Niklas

PS. I saw you had posted a special bug-fix (GUI-x86) related to this issue, but the had been removed from the page

try the 4.1 beta. The GUI issues should be fixed in this version.

Nope, didn’t solve the problem…

Also, experiencing probs with opening the prog (though I somehow managed to do it once…)

Try collecting the debug information and attach it here so a dev can see what the problem is


OK, here you are.


[attachment deleted by admin]

Thanks, Emanuel should respond

Ok, thanks.

The logs don’t show anything unusual.
Please post a screenshot with the error you get when pressing “Save schedule”, so we can look at the settings you used for the schedule. Please also mention where you are trying to save the backup (local, network, ftp, or etc…)


Hmm ok…

a few secs ago, I went to do the screenshot, just to discover that it somehow WORKED… :open_mouth:

The only thing i did, meanwhile (before and after), was opening the comodo backup wizard…- have no further rational explanation…!

but thanks for taking the time anyway…! :slight_smile:

I’m having the same issue saving the schedule with the 4.1 Beta 2. Screenshot attached. Win7 64 bit.

[attachment deleted by admin]

It might be caused by a different issue in your case.
Please collect the debug logs. Please also mention any non-default settings you might have used in the backup steps.


Debug log is attached. Non Standard options? I’m not sure what you mean. I created my own profile to backup my user directory to an external USB drive. So, it is an “Incremental”, “Automatic Base”, “Files & Directories”, “C:\Users\xyz” and “Simple Copy”. The target is "Computer\D:\Comodo xyz". The profile runs manually with no errors. I don’t think I set anything else except for unsuccessfully trying to set a schedule.

[attachment deleted by admin]

The logs don’t contain any information from the time you got the error (2nd of April) because logs get overwritten to avoid using too much disk space.
Please reproduce the error again and then collect the logs.


New screenshot and .cbu file attached.

[attachment deleted by admin]

Please try this GUI.exe 64 bit OS (place it in the installation folder), the issue should be fixed.
If not, please post again the debug logs.


OK, I ran the new executable, and I am no longer getting the error when I save the schedule.

HOWEVER - when I save the schedule, the profile is no longer listed in my shortcuts. Is that what is supposed to happen? So, to edit the profile I now go to the manage tab?

If I choose a “When Idle” schedule, I can’t see the profile in the Shortcuts or Manage tab - so I can’t edit it and I can’t verify it is actually going to run?

Also - should I rename this new executable to CBU.exe so the desktop & start menu shortcuts will work?


We’ll fix this issue in next release.

Yes you can.


Hi folks, I had the same problem with scheduling a shortcut in CB, so I tried the version posted in this thread (which I found out later was older Running the older version allowed me to get past the schedule error, but the Shortcut disappeard (which is intended - but to me this seems a strange and inconvenient behavior) and the Schedule does not appear. So I’m left with no shortcut and no schedule. I checked Windows Task Scheduler, nothing in there for CB. This is a completely fresh install of CB, BTW. So, I reverted back to the original executable ( and I get the same behavior: Setting the schedule does not error, shortcut is removed, and schedule is no where to be found. I’ve attached the debug logs of this behavior. Thanks!

Edit: Backup shortcuts are as follows:

  • Registry - Full - My Computer - Compress Max - Pwd On - Log to File - Email on Failure - All other options are default
  • Outlook - Full - My Computer - Compress Max - Pwd On - Log to File - Email on Failure - All other options are default

[attachment deleted by admin]