After a few seconds after starting a scan, it gets aborted

Hello. I got a problem. I recently ran into some problems with Comodo and re-installed the entire things and it components, which fixed my problem, but when i try running the initial scan, it runs for a few seconds and then it stops, showing the status “Scan Aborted”. This happens with quick scan and full scan. I tried doing a custom scan and only scan one file, which resulted with “scan aborted”. A rating scan seems to work without a problem.

So anyone knows how to run a scan without it for some reason compulsively aborts the process?

I might have found a related error. I can’t update the software via Comodo Update.
The tasks “Check for program updates” and “Check for signature updates” says “Error” and the “Status” reads “A connection with the server could not be established”.

Is it related or just another problem to deal with?

Hi Hewkil, I just had exactly the same problem. No amount of reinstalling would fix it. I tried using the community uninstaller too. It was seriously wierd that the server could not be contacted by Comodo, given that I could successfully do an nslookup and ping the update server via the command line. I was able to update the database manually by downloading it from this page, (full install instructions here) and then added it to Comodo by clicking on the Question mark (top right in Comodo) > About > Import Virus Database. This made comodo ‘Secure’ but still automatic updates were still failing.

N.B. This is Comodo 7, (7.0.317799.4142) and Windows 7 Pro. Your mileage may vary…

This was fixed by a support request, but this is what they did;

Open Regedit, and navigate to;

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\

Open the DefaultConnectionSettings key, select the contents of this key and copy. Then navigate to;

HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\

Open the DefaultConnectionSettings key, select the contents of this key and paste. After a reboot, Comodo was successfully able to contact the server and update. I hope that’s helpful!

Thanks for the share, neuralnet.

There is a known issue regarding this subject, actually.

Hi qmarius,

there isn’t a fix in the link you shared (at least not one that I could find) other than the proper way to uninstall comodo, which I already linked to. Perhaps you should be linking the other post back to this one as this has a fix in it, actually. >:-D

Thank you, neuralnet… this solution worked on at least one computer I tried it on and it should be listed as a viable solution for this issue… since uninstalling / reinstalling doesn’t work in most cases.

Thank you, neuralnet…+1

My main PC had just started with the “Failed to update the virus database” today. I remembered it had happened on another machine of mine running CIS about 4 months ago. This was the solution to that as well. It took me one hell of a time finding a fix the first time. I vaguely remembered enough to find this thread ( all though a new thread, the same fix )fast when it happened again today. Decided to register just to chime in that this has helped me twice now over a span of 5 months. This should be stickied or atleast mods should be aware of one possible solution for future reference.

tryed the solution and it didnt work on my end hopefuly its solved in the next update

Neuralnet. I tried your solution but cannot copy the data. I am on Windows 8.1.1. Does anybody have a clue?

Hi Eric,
Double click the ‘DefaultConnectionSettings’ key under the name column which opens the edit value window, then you can right click the value data to select all and copy.
After copying, IMO it is best to then choose cancel to close the edit window to cancel out any possible accidental edits.

Kind regards.

I tried that but no luck. It allows me to copy put then there is nothing to paste. And that’s what’s puzzling me… :-\

What Windows are you on and what version of CIS are you using? I am on In 8.1.1. x64 and using CIS v8 beta.

Win 8.1 64-bit.
It allows me to copy and paste it to the ‘data value’ of the edit value screen.
It is a little strange the way it acts as it doesn’t allow pasting into a text file.

The latter hits the nail on the head. I did try to past it to Notepad just for testing and there it fails. But when I copy it to a registry key I made for testing it did work. It is strange indeed. Good catch. :slight_smile:

No problem, thanks. :-TU

My issue with Comodo was fixed as well by the terrific response here. :azn:

Hello…fellow techno-geeks… :slight_smile: - I had this problem with my Vista Laptop…(Compaq) - I downloaded and installed… CIS Premium 6xxx free… installed it in a clean…environment (had run Combofix, Malwarebytes, Eusing Registry Cleaner and Spybot…with a REBOOT… PRIOR to downloading and installing CISP fresh off the Comodo Free Download link. It downloaded and installed… perfectly… -notified me that database was out of date and scan had not been executed… so I clicked on update… - it brought up the updates page… 2 or 3 seconds of revolving arrow (status icon) … and boom… failed/aborted… etc…etc…

Did a proper start… control panel… programs and features… comodo internet security premium… - uninstall… - followed by a reboot… - on boot up… - ran the UNINSTALLER (provided off a comodo link) . .to take out… CIS Premium… did… rebooted… - followed the advice to run it a second time… (odd note… neither time did it take the CIS Premium icon off the desktop… not a biggy for me… easily delete-able) - upon second scan with Comodo uninstaller…

I rebooted… - downloaded a fresh copy of… CIS Premium (in case…first one came down corrupted… and passed its “check-sum”… but still snarled up code… )

…installed it… - SAME :frowning: failed/aborted during manual update…

CAME TO THIS FORUM… found the fix… - cut and pasted… the reg key from HKEY_Current_User…over to HKey_User S-1-5-18 as described here… - exited out of regedit… rebooted…

brought up… Comodo… - forced it to do an update… - TADAH!! IT WORKED :slight_smile: …temporarily :frowning:

it went ahead and did a “quick scan”… found nothing… turned “RED WARNING” into “GREEN SECURE” status :slight_smile: all good so I thought… :slight_smile: no infections found during quick scan…

REBOOTED THIS MORNING…wanted to force another update… and perform a FULL SCAN… - and during the update process… all four updates -failed… aborted… couldn’t connect to server…

WHILE STILL GREEN/SECURE…figured…yesterday’s database should be good enough to do a full scan today… and set it loose on my system… to scan… (still scanning at the time of this writing… )

THAT SAID… any other ideas… or suggestions…reg fixes… patches… downloads…prayers… or voodoo… ANYTHING?.. I can do to fix it… permanently… as this registry copy and paste… only worked the one time… …am waiting the end results… of the FULL COMODO Scan just in case there is something else running interference… but I suspect not…

thanx… “jimmimcsandy”

After 8 months of not updating, trying different fixes, uninstalls, rollbacks etc this finally worked and took about 2 minutes. neuralnet, you are indeed a God amoungst men. I tip my hat to you

bump… WORKED FOR ONE UPDATE… now back to the “no updates” … 0x80072ee7 “Server name or address could not be resolved”… - I even did a reset on the TCP/IP Stack… using the netshell command… in case there was some kind of error/corruption…there… :frowning: no go… no show… :o

…so I’m open to any suggestions… thank you …

RESOLVED :smiley: ;D :o 88) :a0 after… trying to sort things out… why did it work once… and not again… on the update… “INTERMITTENCE”… yep… turns out…there is a flakey circuit on my laptop’s wireless card… I tried another router… same…issue… so I disabled the onboard wireless nic… added a nano-usb wireless… loaded the driver …boom! connected…updated… every time…

thanx for your patience everyone…

Congratulations finding this. Sometimes issues are hardware and not software.