Yahoo keeps showing up

I do not want Yahoo as my default search engine and I do not want Yahoo to be my start page. For some strange reason, when I go to settings, I can change my preferences but they do not save and I cannot save them, as there is no “done,” “save,” or “finished” buttons. It seems that Yahoo has hijacked CD. Do I have to delete and reinstall? EricJH suggested this as a bug report.

I’ve tested at my end and can when I change the On Startup page to Open New Tab, that works fine then changed search engine to Google and restarted browser. Address bar search still Yahoo. I changed it again and restarted browser and it stayed at Google. Doing a PC restart to see if any of it comes back but it may have been down to the CD Processes still active for a minute after I closed the browser.


No issue after reboot at my end. Just took two re-starts to change search engine.


Had the same problem. Windows (!) restart solved the problem also in my case.

Had the same problem. But restarting the Windows NOT solved the problem.
It did not work for me. :frowning:

I performed the update and it did not work.
So I uninstalled and reinstalled (clean install), and it also did not work.
Yahoo remains my home page, and I do not want it. I particularly hate Yahoo.
Please correct this error urgently…!! o/

Temporary fix;msg876690#msg876690

Works (for now). Thanks…!! :-TU
And now waiting for a update to fix it… 8)

I can also confirm that Yigido’s workaround for the persistence issue has temporarily resolved the problem after a restart.

UPDATE: I spoke too soon. Opening a new browser window defaults to Gotta get this fixed, folks!

Same as Manu… temporary fix work…

■■■■ it - Yahoo is back! I will try the remporary fix…

Well, I may have found a new ‘workaround’ for the Yahoo!/newtab issue.

Out of curiosity, I selected “Continue where you left off” under the On Startup section in Settings, which as expected opens up the previous instance of CD, complete with all of the previous tabs.

However, when opening a new separate instance of CD, it WILL open ONLY with a newtab and NOT with the dreaded Yahoo!

Can anyone try this ‘workaround’ and verify this behavior?

Strange, I could change all in the settings (my prefered start page, search engine) without extra saving.

It seems to be very erratic. One time google (my preferred starting page) shows up as starting page, next time yahoo; suddendly it’s google again … then again yahoo … very strange… Well, I hope, they fix it with the next update, otherwise I will go back to the Iridium browser.

Now I observed the following:
When I start CD my preferred startup page shows up!
However, if I open a new additional CD window (a new window, not just a new tab), Yahoo appears, regardless of my settings - even the “chrome://newtab/” workaround doesn’t work!

I advise Comodo just to completely remove this Yahoo-thing from the browser. (Set Yahoo as the default starting page or as the default search engine if you want, but nothing more - remove Yahoo from the browser-“guts”).

You can do the following:

  1. open a new TAB i.e.
  2. draw this TAB on the desktop
  3. a new CD-window will open without yahoo but with (the dark blue background is the desktop)
    I don’t know why this image is not displayed - but it doesn’t matter, it shows only CD-window on the desktop

you can this windows make revers and you have the TAB, again

Thanks. That’s a “work around” to get a new window (which I already knew). However I am just used to click on the task bar with a middle mouse click to get a new window (whenever my first window is too crowded with tabs or i just want to seperate different topics with different windows) - and then yahoo shows up. No big issue - in fact. I click on the home button and my preferred starting page opens. So, the “new window yahoo issue” is not a big thing. But as a matter of principle I dislike the fact of not having the control over the settings (at least over the standard settings). (Malware do such things!)

By the way … these “news” on Yahoo really annoy me. I want to keep my eyes and brain clean from even a splitsecond of a glimpse of such bullsh…

Yes, that’s could be a problem, really. I don’t think a new window is “clean” whereas the method I made could have all what is in the “origin” window. I don’t like yahoo, too.

But I think yahoo is a partner of comodo so you will have to live with it or to use another browser. But meanwhile I like CD and IceDragon more than some time before.

The Yahoo thing is a minor nuisance. Aside of this, CD and CIceD evolved very well! I like them both a lot.

I just installed CD 66.0.3359.117 (x64) RC and it appears that the Yahoo page issue has been resolved. Thank you, Comodo.

It not only appears so, it does so! Thanks posting and to Comodo and to mightythor for this proposal btw. suggestion.

According to the new data protection guidelines yahoo opened a window with a long list of partners that had to be blocked to prevent them from collecting data. Same procedure again next time or blocking them with an add-on.