XYplorer doesn't work with defense mode turned on (revisited)

I read the other post that is orphaned. That didn’t help.

The bug/issue

  1. What you did: Turned on Defense
  2. What actually happened or you actually saw: XYplorer no longer allows opening or editing of documents.
  3. What you expected to happen or see: opening or editing of documents
  4. How you tried to fix it & what happened: Turned Defense mode off. I also added XYplorer to the Trusted files list.
  5. If its an application compatibility problem have you tried the application fixes here?: I don’t understand what this is?
  6. Details & exact version of any application (execpt CIS) involved with download link: Not a download
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Yes, just turn on Defense, and the application no longer functions correctly.
  8. Any other information (eg your guess regarding the cause, with reasons): I’m trying to learn how to run applications with “full” protection. In other words, W7 UAC on, all Comodo features on.

Ok, now that I’ve done the above to the best of my ability…?

I’m running 5.5.195786.1383 - DB v 10297
W7, sp1, 2Gb ram.
XYplorer version 10.30

When I’m in an XYplorer window and try to open an excel file, or a text file, I get:

“Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item.”

I turn off Defense and it works fine. I added the program to the Trusted list. The other programs, notepad, excel, etc all work fine. All the associations work fine. If I try the same operation with Windows Explorer or the Total Commander (another file manager) everything is fine with Defense on. This is in Cleaning Mode. When I use Training mode, the applications don’t work as above, but I don’t get the windows popup error message.

I just need to know how to edit Comodo settings to allow this program to function with Defense on.


PS, if this is in the wrong place, please feel free to move it.

OK, I followed the instructions for reinstalling Comodo without saving any of the previous settings etc.


It worked.