XP does not recognise CF is up and running

Hiya there

I have just done a re-install of windows, and i have noticed that aftre a short while the alert from XP alert comes up, and when i go to security center it says there is no firewall installed.

Now when i check CF it says it is up and running with no problems ??



Maybe that was before and after you installed the vast amount of critical updates? Or maybe it’s Windows screwing with you mind. Windows is a fickle thing. As long as you’ve got that little Comodo icon down in your systray, I wouldn’t worry.



(i didn’t want to open a new topic for this)

This is from a Hungarian user:

  1. : 2006 10.10. bought notebook with NIS 2006, valid for 28th dec.
  2. : 2006.12.28. NIS 2006 was deleted and a new KIS 6.0 (30 day trial) installed
  3. : 2007.01.24. KIS removed, Comodo 2.4 (final with Hun.) and avast!4.7 Home Editon installed.

If he switch off the windows firewall, then he gets the following message: The Norton Internet Worm Protection reports… and he turns on, he get “The Windows Firewall protects your computer” (not exact)
He found a Symantec Shared/CCPD-LC/Symantec.dll file and solved the Noton problem with a “Norton removal tool” (i don’t know this).
Anyway, the Windows XP still can’t recognise the CPF. Any ideas?

The answer to both is most likely rebuilding the repository. There is a script by one of the Mods, panic, here: https://forums.comodo.com/index.php/topic,2479.msg19751.html#msg19751

Hope that helps,


Thanks, Mac! I’ll inform him.


He tried to reset the wmi but no success. He also informed me that he has also tried to install ZoneAlarm, Outpost, Kaspersky and Panda 2k7 at the weekend and every other firewall showed it’s correct name at the security center, only CPF couldn’t do this and the Norton message remained there. So i guess egemen should find out something for this - as others might have found out what to do ;)!

Ewen’s script has never failed me. Reboot required.

As i said, Soya, no luck.

There’s another user with a similar issue where the script works, but only temporarily: https://forums.comodo.com/index.php/topic,6961.0.html

Sure way on my system to get WSC to say that I don’t have a Firewall:
Disable the DCOM Server Process Launcher service from Administrative Tools/Services.

The warning goes away if I re-enable the service.
I try and eliminate any service I don’t really need, and many websites say that the above service isn’t needed by any known software - I guess the exception is Comodo.

I’m a Service clean freak and even I don’t recommend disabling Process Launcher. It’s required for prefetching to work among other things like the install wizard and maybe Windows Update.

Windows defrag won’t run either if you disable DCOM. I did not bother trying to find out
what else wouldn’t work. It’s not worth turning it off.


Not a recommended action.
I’m a bit like Soya

There are some sites out there that give advice regarding windows services that I would steer well clear of.
There are a couple of good sites if you need to know about services.
Did a quick google and picked 4 sites at random, not one recommended disabling DCOM Server Process Launcher. It should stay at automatic