Xbox 360 being blocked

Hi guys, I have a problem connecting my Xbox 360 to the internet using my laptop as a gateway. I connected it fine and if i turn off the firewall, it connects like it should. I have added exceptions in Network Security Policies > Global Rules to both allowing anything from the Xbox’s source IP and adding the individual needed ports as per the Comodo FAQ about Xboxes. It still doesn’t work however.

When I take a look in firewall event, I see a myriad off blocked instances of the Xboxes IP to the ports that I have previously opened through the global rules.

Am I missing something here? Is there another place I’m supposed to be adding these exceptions?

Hi visti,welcome to the forums,

I think you need to add the same rules as you put in the “Global rule set” to “System” in application rules
Also make sure any Allow rules are above any Block rules.

Thanks, Matty, but it didn’t work.

I added the same rule to the Application Rules > System

To spell out what I’ve done so far:

I erased a bunch of spaghetti rules I had made and started from scratch.

As per your advice, I went to Application Rules > System and added:

Allow all incoming / outgoing requests where the source address is (The Xbox), Destination Address, Destination Port and Source Port set to “any”.

I have the exact same rule in “global rules”, though set to the IP Mask of /, which wouldn’t matter I figured.

Yet if I try to connect, I go “firewall events” I see a bunch of:

Windows Operating System - blocked - Protocol: TCP - Source IP: - Source Port: 57289 - Destination port: 80

Now, this suggests to me that you’re right in suggesting that I apply a rule to System - however, it still didn’t work. I don’t understand why the rule is not applied.

Variations include attempts at destination port 3074 and 88, also from Windows Operating System.

I’m having the exact same problem:
I want to connect to xbox live through my pc running vista x64 and comodo firewall, of course. But i can’t and when i test the live connection on the xbox, it fails at the internet step.
With the firewall disabled, i can connect easily, so im sure my setup is good.
I tried to open ports, following the tutorial on this site, then tried to allow any type of connection for both system and svchost.exe and in global rules for all types of protocols without success …
Now i’m kind of deseperate :■■■■
I think there might be something broken in version 3.5, for this matter, because i dont remember having those problems with previous version.
Anyway, any help would be much appreciated.

I really don’t know what else to try other than a different firewall and I would really like to avoid that as Comodo does everything else I want. Except this one thing.