X1Search crashes with CIS Pro 7

center]A. THE BUG/ISSUE (Varies from issue to issue)[/center]
Can U reproduce the problem & if so how reliably?:
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Select the X1Search program from X1 Technologies Inc.
2. Manage Data Sources
3: Edit Outlook Email options

One or two sentences explaining what actually happened:
X1 crashes, error windows says:
There was an error reading form the pipe: The pipe has been en… (unreadable, beyond window))
This only happens after CIS Pro 7 has been installed. X1Search works flawless without CIS installed.

When previewing outlook search results, the X1Search preview window is empty, except for “Unable to connect to Outlook (There was an error reading from the pipe: The pipe has been ended. (109, 0x6d).). Please contact support for assistance.”

One or two sentences explaining what you expected to happen:
I do not expect X1 to crash because of CIS

If a software compatibility problem have you tried the advice to make programs work with CIS?:
I tried everything.

Any software except CIS/OS involved? If so - name, & exact version:
X1Search version 8.3 build 5001lw (64-bit) , outlook plugin version

Any other information, eg your guess at the cause, how U tried to fix it etc:

Exact CIS version & configuration:
Comodo Internet Security Pro version 7.0.317799.4142, Database version 20005

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS: Clean PC mode, Autosandbox: partially limited, firewall: safe mode

Have U made any other changes to the default config? (egs here.):
yes, tried many settings, no results

Have U updated (without uninstall) from CIS 5 or CIS6?:
CIS Pro 7
if so, have U tried a a a clean reinstall - if not please do?:
Yes, clean re-install
Have U imported a config from a previous version of CIS:
if so, have U tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 Pro, 64 bit, UAC default, administrator, Lenovo W540

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
No Comodo log files mention this crash.

[attachment deleted by admin]

Thank you for reporting this. Please run the diagnostics and attach the diagnostics report to your first post.

In addition, please paste a link to the exact product which you are using.
Also, in terms of trying to make this work with CIS, did you try the advice given here?


Problem solved: added X1Search folder to as an exception to shellcode injection and now it works. Thanks!

I’m very happy to hear that. In that case I’ll move this report to Resolved. If you run into any problems in the future please feel free to let me know.