wxDownload Fast / Flashgot / Firefox integration broken by COMODO

with defense+ switched on from Training mode up, when flashgot trys to launch wxDownload fast a message saying not properly installed appears - this is described in the flashgot FAQ as being common on blocking internal COM channels / dll - with defense+ disabled, everything works fine.
I can find no combination of trusted application nor safe files that gets this to work.

what if any rules do I need to sort out to get this to work.
Frustrated++ and currently thinking defense+ is more bother than it is worth.

First of all read the forum policy and change your user name. Very unnecessary. I use Flashgot with Firefox and have no issues. I use Free Download Manager for my downloads also. Have you tried making it trusted under D+? Works for me. Also what version of Comodo are you using? Also make Firefox a web browser under the Firewall policy. I never heard of wxDownload manager either. Your better off using Well known programs such as Free Download Manager or Orbit.

Thanks : as per the original post, I have tried making the manager trusted under D+
wxDownload Fast is a very well known open source download manager : http://dfast.sourceforge.net/ for more info.
The issue for me is that the firewall is clearly blocking a system internal but there is no indication in any of the logs / screens what and where, and certainly no clear way to trust/enable this application.
I do not particularly want to have to swap to new software because the firewall doesn’t let me configure it.
I have until very recently been using Sygate Personal Firewall quite happily : a similar issue with that forced me to switch as that is no longer developed/supported and I was hoping for a little more support with this.
I find the interface difficult to be honest, and the D+ pop ups unclear. Already one near critical moment being locked out of all file access even as administrator.

re version : COMODO Firewall version

the forum is not particularly easy to navigate

This forum is very well laid out and I might add to move your post to the “help” area of Comodo 3.0 and not a feedback area. Did you try making Firefox a web browser under the Firewall policy? Also you might try doing a complete uninstall and reinstall of Firefox to let Comodo learn everything. Are you using Firefox 3.01 and Flashgot You might also want to try deleting all entries of Firefox and related items out of D+ and then reboot. Start Firefox and see what happens. When you get a D+ alert just make it trusted. Also you need to make Flashgot a trusted item under D+. You can manually add it which is found under Documents and Settings\Your Name\ Application Data\ Mozilla\ Firefox\ Profiles\ tpfb6vg7.default\ Flashgot.exe.

hmm, reply seems to be lost.
tried all that. latest firefox/flashgot.

if help is the appropriate place so be it.
feedback is : no way to see what / why this is blocked - D+ does say blocking suspicious event but no way to change rules/settings.
Orbit also has same feature with flashgot = only works with D+ disabled.
I’m contemplating the obvious solution re D+

I have also tried Orbit and it works just fine with D+. What setting do you have D+ on? Show a screen shot of your logs and I can help you. What exactly is being blocked. Of course there is a way to change it.

Solution found.

Flashgot was set as isolated application. Change to trusted and all works.

It would help if in the computer policy section if the Application name defaulted to right justified as without a horizontal scrollbar it is difficult to see what files are being used - or a tool tip with the full path visible

maybe 3 columns File: (eg Flashgot.exe) Path: C;/path/to/variable/in/multiple/sub/folders/±file.name Type &c
Otherwise applications are difficult to see in the policy section.


The only way it was isolated was that D+ gave you an alert and you selected “isolated”. If you just click allow it would have made a custom rule for it.

But I don’t believe in just clicking allow on any old pop up. Mea Culpa

HOWEVER, the logs never show the culprit file/permission - only that a “create process” was attempted - no info on wether it is blocked, nor which rule is invoked to stop what is happening.

equally there are several places to give permissions - Network Security Policy, Computer Security Policy

also I have yet to find a definition of what is a limited application, an isolated (?stand alone) etc.

It would be nice to define my own file groups to enable me to cluster some applications needing similar permissions together

I will persevere. the granularity of control is excellent - it just feels a little too distributed around several parts of the application.

I’m off to try and set up VNC class in the predefined firewall policys.
A collection of templates/examples might be nice…