Wow being crashed by comodo

At first when I attempted to play wow (after the 1 million are u sure ur sure ure sure this program is ok popups) I got “wow.exe tried to execute shellcode as a result of a possible buffer overflow attack”, I chose to always skip, now when ever I go2 login it just crashes… please help I just got this and already I miss ZoneAlarm

I rightclicked in the toolbar comando and clicked exit in attempt 2 shut it down… im not sure if it did, but when I went to load WoW it still crashed on entering details :frowning:

I ran as admin, which magicaly made it work… why?
I am blaming comodo for the crash as problems first occured on installing comodo

Do the D+ logs give us a clue here? Post a screenshot of them. They are in Defense + → View Defense + Events.

For certain programs it helps to add the installation folder to the exceptions of the Shellcode injections.

easy there… don’t blame comodo that it doesn’t work. Have you tried to put WoW as trusted file? if you haven’t then do so.

Tell me how is goes


Also check out Fixes for games/comms/utilty software that won’t run with CIS 5 by Mouse1.

Had the same problem I went to Defense+ Settings then under the Execution Control Settings tab added WoW.exe to the Detect Shell Code Injections exclusion list and it works fine now… I think.

I just want to say I love the defense this program provides but it is one of the least user friendly programs I’ve ever used.

I’d also like to say that I really shouldn’t have had to go through this in the first place, WoW is beyond popular and you should have tested that your new settings would allow it to work properly before putting out a new version of your program.