Workaround to make games with Gameguard work

It’s very strange, I discovered it by chance testing the beta features. I installed it on my test computer so I could do anything with no concerns. It’s an old computer but it’s running Windows 7 Pro 32bits, I installed CIS beta with no AV since I like to use Avira.
I tried everything to make those games work with no success. I went to Computer Security Policy I found the game client there and set all access rights to allow, that didn’t do the trick. Don’t ask me why I turned on all Protection Settings for the game client and tried to run the game twice, obviously the game client didn’t run because Comodo was protecting it from the hooks it must receive. I went back to Protection Settings and disabled them all. I try to run the game again and it worked! I was able to open and connect the game client. For some strange reason looks like Comodo wasn’t sensing the game client and started to sense it after that trick. I tested only with the newest beta and with Luna online. Unfortunately no success with Archlord.

Try turning off Shell Code Injection Detection, or try to add on exclusion list gameguard.des and game executable. So far it did the trick in CIS v4. If you chose 2nd option, you won’t be able to start other programs while game is running.

You shouldn’t have to turn off anything or make any exclusions. All applications should be able to work or there is a flaw in CIS, period.

If specific settings are required to allow this to work, then make the required changes. Not everyone uses Gameguard, nor do they play games online when they do play games (I for one).
If you don’t wish to help resolve this issue, then, please do not post.

I always got a game to work by doing two things.

  1. Disable the sandbox and leave it that way if you’re a gamer.
  2. Make sure there are no rules for the game files in either D+ or the Firewall. If there are any, delete them. Then put both D+ and the Firewall in training mode and play the game until you have done everything that the game requires you to do. Then put D+ and the Firewall back to your usual settings. The game should work after that.

Just because “not everyone uses Gameguard” doesn’t mean the program isn’t flawed. CIS - or any AV for that matter - should not interfere with any aspect of a computer’s use. It’s obvious that, out of the box, CIS is a hindrance to gamers.

Unfortunately it doesn’t work with Game Guard. It has conflict with Buffer overflow protection (used to be Memory firewall) not with D+ or Firewall. Putting D+ in learning mode won’t affect shell code injection detection settings.
And before we go into philosophical discussion is Game Guard piece of ■■■■ (yes, it is), the fact is if you like to play cheap Korean MMOs, Game Guard is necessary evil.

@slobix I tried what you said and it worked! You’re the best! XD Sorry that I can’t kiss you, I have a boyfriend and he’ll be mad. XD

Game Guard piece of ■■■■ (yes, it is), the fact is if you like to play cheap Korean MMOs, Game Guard is necessary evil
Also the makers of "Game Guard" are not very helpfull either :-TD

They answered only one e-mail from me and, everything they told me was to turn off all my security apps to play the games… ¬¬’

Now the guard32.dll from the new version is crashing Luna Online…

Last thing I know about GameGuard, not a gamer here, is that is unhooks CIS’ kernel hooks. That is very aggressive and straight up malware like behaviour; it simply tries to kick CIS out of the kernel and therefor is trying to disable the protection by CIS.

The problem here is not CIS - it’s GameGuard and its unorthodox (read - non-standard) method of kernel latching.

Bad behaviour in one application does not mean there is a fault in another. :wink:

I tested 2 games, only Luna crashed but the launcher crashes. The client didn’t even have time to start, therefore Gameguard didn’t start. Archlord worked with no problems.

There are enough problems with CIS and games that do not use GameGuard to justify the statement that CIS has more than enough hindrances for gamers.

The guard32.dll problem is gone with the new version 5.0.159634.1091! That’s the way! I can’t wait for the final version to install on my main computer.
Online Armor makes my machine boot very slow…

You say that the problem were gone with the newest rc,but did u run the game with cis on with default settings or you got turn off some settings?

I did just what slobix said, I put the games’ clients under exception of Shell Code Injection Detection and firewall and D+ at learning mode the first time. As he said you can’t open anything else while playing but it worked.

Eric, Flyff has no issues with Comodo. Some games with Gameguard have no issues at all.
And multiboxing is illegal, his daughter should never open more than 1 window. I’m sure she’s bypassing Gameguard because it blocks multiboxing. I hope her accounts get banned for cheating.