Won't respect "trusted" program

I’m getting a prompt every time I launch Legacy.com (a genealogy program) that it has not been digitally signed and “should not be trusted”, well I know this program, DO trust it and added it to trusted programs. However, I still get the same prompt every time I launch it and it’s irritating. Why won’t Comodo listen to me when I’ve told it to trust it? It appears in the trusted programs.

There is a kludgey workaround that should help. Go to Defense+ → Computer Security Policy. Click the Add button and navigate to your application. Then give it the predefined security policy of Installer or Updater.

Thank you HeffeD, that worked perfectly! I’m not going to bother the programmers to fix this since your workaround resolved my issue.
I wouldn’t legacy.com expect it to be added easily to Comodos list of ‘safe’ applications, but I’m still disappointed a user can’t designate a program on their own computer as safe.
This is the 1st time I’ve tried Comodo and if there aren’t any other issues I’ll probably stay with it as it seems like an excellent suite with an extremely helpful forum. Thanks again HeffeD.
I’ll make note of the instructions should I have to submit something in the future using the official format.

I’m glad it worked!

Why it’s not accepting that it’s “trusted” is likely because the application has changed in some way. I’m assuming that as this is a geneology application, there is a database aspect that you are editing? (Adding to, refining entries, etc…)

Currently CIS doesn’t handle this type of application very well. It uses SHA1 hashes to recognize a program. If the program has changed at all, the hash no longer matches. This means that CIS sees it as a completely new application the next time you start the program. As you may imagine, this is a bit of a sticky issue for software developers because each new build is grabbed by CIS.

Currently the only method to get CIS to keep its hands of each new build is to give it the Installer or Updater security policy which is a bit counterintuitive as the application is most likely neither an installer, nor an updater.

I can only hope that the developers figure out a solution for this type of application in the future.