Won't extract

When trying to install CAS I get a message that asks if I want to continue as Norton 2009 is installed, which I already uninstalled when I switched to AVG. If I hit YES to continue it then starts to install but fails when it can’t extract “Uninstall.exe” and when I hit OK it rolls back the install.

Running XP

Sorry you are having this problem. Hopefully I can help you resolve it.

First can you tell me whether you are installing the Beta (2.7) version (can be downloaded only from the CAS Beta corner).

Then please try the following. Download CAS Beta as well as the release version, giving the Beta installer a different file name. For security reasons do a manual AV scan and quarantine any malware. Don’t surf or download anything else from the internet until this process is complete. Then temporarily switch off real time filesystem AV scanning in Norton. Also switch off email scanning (both AV and antispam if Norton supports both).

Now try installing CAS. Try the Beta if the release version won’t install.

Then re-enable real time file system scanning but NOT real time email scanning or antispam. (This should not pose a significant security risk as the real time file system scanner should catch email-borne malware as soon as the files are opened, and CAS, working properly, will exclude almost all spam from your client. But if in doubt consult Norton documentation - also see extensive discussion in CIS forums on this topic!). Reboot and start CAS. It is possible that Norton will try to block some CAS files, so watch the logs and give CAS files appropriate privileges. You may need to reboot again after getting Norton privileges sorted out.

If you still experience difficulties, please post them here and I or someone else will try to help you. Alternatively wait for 2.7 public release, which we are assured, will address known bugs and (avoidable) incompatibilities.

Best wishes


Thanks for the reply Mouse1. I’m trying to install I uninstalled Norton last week and replaced it with AVG. There are no Norton groups in the program list or under add/remove programs in the control panel. ???

Hi twasnae,

I know zippo about CAS, but the traces of leftover Norton is a classic.

The following Steps and Tool should sort that out, and hopefully that in turn sorts the CAS install issue.

Download the Norton Removal Tool.

Save the file to the Windows desktop.
DOWNLOAD from Major Geeks

find the link on this Symantec page.

On the Windows desktop, double-click the Norton Removal Tool icon.

Follow the on-screen instructions.

Restart your computer.
Your computer may be restarted more than once, and you may be asked to repeat some steps after the computer restarts.

The Tool and steps are directly from Symantec Support.


Sorry missed the bit about uninstalling. Bad frogger has given really good advice here. So I’d follow his guidance. I’ve had problems with Norton incompletely uninstalling myself. It will likely cause difficulties with other apps in future if you don’t completely uninstall it, so its worth it anyway.

But note you may also have to temporarily disable AVG real time AV file scanning if you still have a problem with the installation.


Well, I ran the Norton tool and still had the same problem. I unistalled AVG and tried again, same problem. I reinstalled AVG and ran the Norton tool again, same problem. Any more ideas or should I just give up? Thanks.

Don’t give up yet!

  1. Can you post a screen shot of the error message. If you don’t have screen capture software, Faststone, FastStone Screen Capture - The Best Screen Capture Software reviewed in the helpful Gizmo’s freeware reviews www.techsupportalert.com, does the job simply and reliably. (You may need to exclude it from any proactive security software, as it reads from the screen directly).

  2. Could you give details of all the utility software you are running, including any zip/file compression software. Also which XP service pack (right click on my computer and choose properties).

  3. Could you try to see if CAS 2.6, downloadable from the main comodo site, will install.

  4. I assume you have sufficient disk space and RAM, and have absolutely no other security software running (including anti-spyware?)

  5. Worth checking if you have data execution prevention (DEP) on for programs, as it can be over-ferocious. Navigate to My computer, then properties then advanced then performance and choose the DEP tab. Exclude the CAS installer if you have DEP set for programs then reboot.

  6. Armed with the above information I will try to stir the developers.

Best wishes


Oh if you have XP after SP2 you can sometimes need to right click on installers, choose properties, then choose to ‘unblock’ the file. This is XP’s own security looking after you.

Fairly self evident but also worth checking you are logged on to a user account with admin privileges