WOL not getting through

If I disable the Firewall my WOL Sniffer receives the packet but otherwise it doesn’t.

I’ve tried adding a Global Rule to Allow TCP or UDP In from Any to Any Port 7 but that hasn’t helped, nor has adding a rule for the app to Allow All IP In/Out from Any to Any IP Any.

Is it possible to get WOL working with Comodo?

Did you set the source port to Any and destination port to 7 in the rule in Global Rules?


Can you check the Application Rules of the Firewall and see if there is a rule called “All Applications”.

If that rule is there then the rule for WOL is probably at a place underneath the “All Application” rule. Please move the rule for WOL to a place above the “All Application” rule.

It was underneath the All Application rule (which was at the top) but moving the WOL rule above it hasn’t made any difference. The All Application rule was set to “Allow and log UDP Out from Any to from/to Any port” and “Allow LAN” which is a custom predefined rule I made to “Allow IP In/Out to/from Network Zone LAN”. It also had a Block All rule after that but it doesn’t seem to have be doing much as I’ve still been getting prompts to allow stuff through. I’ve removed that rule now just in case but it’s still not letting the WOL packet through.

Sometimes pictures tell more than a thousand words. Can you post screenshots of the Global Rules and Application Rules?

Here you go:



Thanks. The rule you made look good to me. The sniffer traffic should be coming in. So it is odd your Wake On Lan is not working.

Time to take other things into consideration. Make sure that left overs of previously installed security programs are no longer around by removing possible left overs with cleanup tools of those programs. A list of such tools can be found here: ESET Knowledgebase .

When that does not help see if the D+ logs (View Defense + Events) show anything related to the wolsniffer program.

Yeah, it’s definitely blocked by Comodo firewall as if I disable that the sniffer sees the packet come in, enable the firewall and it sees nothing again.

I don’t think I’ve ever installed any other Firewall/Anti-virus on this system other than the currently installed Comodo/Avira but the fact that disabling Comodo firewall allows the packet in seems to point to that rather than anything else.

I don’t have Defense+ enabled so the Events log for that is empty.

This looks like a bug to me. If you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

Thanks, will do.